summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2012-05-20 21:37:22 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-05-24 12:52:11 +0200
commit5b6549cd03b26c2cf300ab85ee6334f4d7389b1d (patch)
treec7ec0c4ffa7b8d32db9d805a4e2ff9a2077b1637
parentf38bcd610519ba59526fe1248411a138fae452ac (diff)
downloadmeta-openembedded-5b6549cd03b26c2cf300ab85ee6334f4d7389b1d.tar.gz
ubi-utils-klibc: clean ubiformat patch
* fixes have been committed in klibc for stdio and the additional * fflush is not necessary anymore (runtime tested pressing CTRL+D) * bump PR Signed-off-by: Andrea Adami <andrea.adami@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc/ubiformat.c.patch16
-rw-r--r--meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc_1.4.9.bb2
2 files changed, 4 insertions, 14 deletions
diff --git a/meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc/ubiformat.c.patch b/meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc/ubiformat.c.patch
index 7539d76e3..d21ed577b 100644
--- a/meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc/ubiformat.c.patch
+++ b/meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc/ubiformat.c.patch
@@ -1,25 +1,15 @@
1--- a/ubi-utils/ubiformat.c 2012-05-03 01:14:39.000000000 +0200 1--- a/ubi-utils/ubiformat.c 2012-05-03 01:14:39.000000000 +0200
2+++ b/ubi-utils/ubiformat.c 2012-05-03 01:00:57.000000000 +0200 2+++ b/ubi-utils/ubiformat.c 2012-05-20 23:11:57.000000000 +0200
3@@ -246,7 +246,11 @@ 3@@ -246,7 +246,7 @@
4 4
5 while (1) { 5 while (1) {
6 normsg_cont("continue? (yes/no) "); 6 normsg_cont("continue? (yes/no) ");
7- if (scanf("%3s", buf) == EOF) { 7- if (scanf("%3s", buf) == EOF) {
8+
9+ fflush(stderr);
10+ fflush(stdout);
11+
12+ if (fgets(buf,4,stdin) == NULL) { 8+ if (fgets(buf,4,stdin) == NULL) {
13 sys_errmsg("scanf returned unexpected EOF, assume \"yes\""); 9 sys_errmsg("scanf returned unexpected EOF, assume \"yes\"");
14 return 1; 10 return 1;
15 } 11 }
16@@ -259,10 +263,13 @@ 12@@ -262,7 +262,7 @@
17
18 static int answer_is_yes(void)
19 {
20+ fflush(stderr);
21+ fflush(stdout);
22+
23 char buf[4]; 13 char buf[4];
24 14
25 while (1) { 15 while (1) {
diff --git a/meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc_1.4.9.bb b/meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc_1.4.9.bb
index 9a8987cb6..f975952b2 100644
--- a/meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc_1.4.9.bb
+++ b/meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc_1.4.9.bb
@@ -6,7 +6,7 @@ LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \ 6LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
7 file://include/common.h;beginline=1;endline=17;md5=ba05b07912a44ea2bf81ce409380049c" 7 file://include/common.h;beginline=1;endline=17;md5=ba05b07912a44ea2bf81ce409380049c"
8 8
9PR = "r2" 9PR = "r3"
10 10
11inherit klibc 11inherit klibc
12 12