summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2022-08-01 17:04:32 +0800
committerKhem Raj <raj.khem@gmail.com>2022-08-06 09:07:11 -0700
commit59eff6269c4f4c150d976054d585872c92f20207 (patch)
tree90cc1f024d3ebe81f2aa57d73515d256f318a736
parent9444f67b261ff1f09f4915deed0576d6dbf43ea5 (diff)
downloadmeta-openembedded-59eff6269c4f4c150d976054d585872c92f20207.tar.gz
postgresql: Fix the buildpaths issue
Fixes: WARNING: postgresql-14.4-r0 do_package_qa: QA Issue: File /usr/bin/postgres in package postgresql contains reference to TMPDIR File /usr/bin/pg_config in package postgresql contains reference to TMPDIR [buildpaths] WARNING: postgresql-14.4-r0 do_package_qa: QA Issue: File /usr/include/pg_config.h in package libpq-dev contains reference to TMPDIR [buildpaths] WARNING: postgresql-14.4-r0 do_package_qa: QA Issue: File /usr/include/postgresql/server/pg_config.h in package postgresql-server-dev contains reference to TMPDIR File /usr/lib/postgresql/pgxs/src/Makefile.global in package postgresql-server-dev contains reference to TMPDIR [buildpaths] WARNING: postgresql-14.4-r0 do_package_qa: QA Issue: File /usr/lib/libpgcommon.a in package postgresql-staticdev contains reference to TMPDIR File /usr/lib/libpgcommon_shlib.a in package postgresql-staticdev contains reference to TMPDIR [buildpaths] Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-dbs/postgresql/files/0001-config_info.c-not-expose-build-info.patch110
-rw-r--r--meta-oe/recipes-dbs/postgresql/postgresql.inc8
-rw-r--r--meta-oe/recipes-dbs/postgresql/postgresql_14.4.bb1
3 files changed, 119 insertions, 0 deletions
diff --git a/meta-oe/recipes-dbs/postgresql/files/0001-config_info.c-not-expose-build-info.patch b/meta-oe/recipes-dbs/postgresql/files/0001-config_info.c-not-expose-build-info.patch
new file mode 100644
index 000000000..101a74877
--- /dev/null
+++ b/meta-oe/recipes-dbs/postgresql/files/0001-config_info.c-not-expose-build-info.patch
@@ -0,0 +1,110 @@
1From b92eebe8b0760fee7bd55c6c22318620c2c07579 Mon Sep 17 00:00:00 2001
2From: Mingli Yu <mingli.yu@windriver.com>
3Date: Mon, 1 Aug 2022 15:44:38 +0800
4Subject: [PATCH] config_info.c: not expose build info
5
6Don't collect the build information to fix the buildpaths issue.
7
8Upstream-Status: Inappropriate [oe specific]
9
10Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
11---
12 configure.ac | 2 +-
13 src/common/config_info.c | 68 ----------------------------------------
14 2 files changed, 1 insertion(+), 69 deletions(-)
15
16diff --git a/configure.ac b/configure.ac
17index 0eb595b..508487b 100644
18--- a/configure.ac
19+++ b/configure.ac
20@@ -23,7 +23,7 @@ AC_COPYRIGHT([Copyright (c) 1996-2021, PostgreSQL Global Development Group])
21 AC_CONFIG_SRCDIR([src/backend/access/common/heaptuple.c])
22 AC_CONFIG_AUX_DIR(config)
23 AC_PREFIX_DEFAULT(/usr/local/pgsql)
24-AC_DEFINE_UNQUOTED(CONFIGURE_ARGS, ["$ac_configure_args"], [Saved arguments from configure])
25+AC_DEFINE_UNQUOTED(CONFIGURE_ARGS, ["ac_configure_args"], [Saved arguments from configure])
26
27 [PG_MAJORVERSION=`expr "$PACKAGE_VERSION" : '\([0-9][0-9]*\)'`]
28 [PG_MINORVERSION=`expr "$PACKAGE_VERSION" : '.*\.\([0-9][0-9]*\)'`]
29diff --git a/src/common/config_info.c b/src/common/config_info.c
30index e72e729..b482c20 100644
31--- a/src/common/config_info.c
32+++ b/src/common/config_info.c
33@@ -123,74 +123,6 @@ get_configdata(const char *my_exec_path, size_t *configdata_len)
34 configdata[i].setting = pstrdup(path);
35 i++;
36
37- configdata[i].name = pstrdup("CONFIGURE");
38- configdata[i].setting = pstrdup(CONFIGURE_ARGS);
39- i++;
40-
41- configdata[i].name = pstrdup("CC");
42-#ifdef VAL_CC
43- configdata[i].setting = pstrdup(VAL_CC);
44-#else
45- configdata[i].setting = pstrdup(_("not recorded"));
46-#endif
47- i++;
48-
49- configdata[i].name = pstrdup("CPPFLAGS");
50-#ifdef VAL_CPPFLAGS
51- configdata[i].setting = pstrdup(VAL_CPPFLAGS);
52-#else
53- configdata[i].setting = pstrdup(_("not recorded"));
54-#endif
55- i++;
56-
57- configdata[i].name = pstrdup("CFLAGS");
58-#ifdef VAL_CFLAGS
59- configdata[i].setting = pstrdup(VAL_CFLAGS);
60-#else
61- configdata[i].setting = pstrdup(_("not recorded"));
62-#endif
63- i++;
64-
65- configdata[i].name = pstrdup("CFLAGS_SL");
66-#ifdef VAL_CFLAGS_SL
67- configdata[i].setting = pstrdup(VAL_CFLAGS_SL);
68-#else
69- configdata[i].setting = pstrdup(_("not recorded"));
70-#endif
71- i++;
72-
73- configdata[i].name = pstrdup("LDFLAGS");
74-#ifdef VAL_LDFLAGS
75- configdata[i].setting = pstrdup(VAL_LDFLAGS);
76-#else
77- configdata[i].setting = pstrdup(_("not recorded"));
78-#endif
79- i++;
80-
81- configdata[i].name = pstrdup("LDFLAGS_EX");
82-#ifdef VAL_LDFLAGS_EX
83- configdata[i].setting = pstrdup(VAL_LDFLAGS_EX);
84-#else
85- configdata[i].setting = pstrdup(_("not recorded"));
86-#endif
87- i++;
88-
89- configdata[i].name = pstrdup("LDFLAGS_SL");
90-#ifdef VAL_LDFLAGS_SL
91- configdata[i].setting = pstrdup(VAL_LDFLAGS_SL);
92-#else
93- configdata[i].setting = pstrdup(_("not recorded"));
94-#endif
95- i++;
96-
97- configdata[i].name = pstrdup("LIBS");
98-#ifdef VAL_LIBS
99- configdata[i].setting = pstrdup(VAL_LIBS);
100-#else
101- configdata[i].setting = pstrdup(_("not recorded"));
102-#endif
103- i++;
104-
105 configdata[i].name = pstrdup("VERSION");
106 configdata[i].setting = pstrdup("PostgreSQL " PG_VERSION);
107 i++;
108--
1092.25.1
110
diff --git a/meta-oe/recipes-dbs/postgresql/postgresql.inc b/meta-oe/recipes-dbs/postgresql/postgresql.inc
index 00c010746..bef33e6bb 100644
--- a/meta-oe/recipes-dbs/postgresql/postgresql.inc
+++ b/meta-oe/recipes-dbs/postgresql/postgresql.inc
@@ -215,6 +215,14 @@ do_install:append() {
215 install -m 0644 ${WORKDIR}/postgresql.service ${D}${systemd_unitdir}/system 215 install -m 0644 ${WORKDIR}/postgresql.service ${D}${systemd_unitdir}/system
216 sed -i -e 's,@BINDIR@,${bindir},g' \ 216 sed -i -e 's,@BINDIR@,${bindir},g' \
217 ${D}${systemd_unitdir}/system/postgresql.service 217 ${D}${systemd_unitdir}/system/postgresql.service
218 # Remove the build path
219 if [ -f ${D}${libdir}/${BPN}/pgxs/src/Makefile.global ]; then
220 sed -i -e 's#${RECIPE_SYSROOT}##g' \
221 -e 's#${RECIPE_SYSROOT_NATIVE}##g' \
222 -e 's#${WORKDIR}##g' \
223 -e 's#${TMPDIR}##g' \
224 ${D}${libdir}/${BPN}/pgxs/src/Makefile.global
225 fi
218} 226}
219 227
220SSTATE_SCAN_FILES += "Makefile.global" 228SSTATE_SCAN_FILES += "Makefile.global"
diff --git a/meta-oe/recipes-dbs/postgresql/postgresql_14.4.bb b/meta-oe/recipes-dbs/postgresql/postgresql_14.4.bb
index 64e83b2cd..1daab22f9 100644
--- a/meta-oe/recipes-dbs/postgresql/postgresql_14.4.bb
+++ b/meta-oe/recipes-dbs/postgresql/postgresql_14.4.bb
@@ -8,6 +8,7 @@ SRC_URI += "\
8 file://0001-Improve-reproducibility.patch \ 8 file://0001-Improve-reproducibility.patch \
9 file://0001-configure.ac-bypass-autoconf-2.69-version-check.patch \ 9 file://0001-configure.ac-bypass-autoconf-2.69-version-check.patch \
10 file://remove_duplicate.patch \ 10 file://remove_duplicate.patch \
11 file://0001-config_info.c-not-expose-build-info.patch \
11" 12"
12 13
13SRC_URI[sha256sum] = "c23b6237c5231c791511bdc79098617d6852e9e3bdf360efd8b5d15a1a3d8f6a" 14SRC_URI[sha256sum] = "c23b6237c5231c791511bdc79098617d6852e9e3bdf360efd8b5d15a1a3d8f6a"