summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Joslyn <robert.joslyn@redrectangle.org>2018-04-08 11:25:06 -0700
committerArmin Kuster <akuster808@gmail.com>2018-05-01 18:12:49 -0700
commit5818f54160016088c79030217fe80f2688714546 (patch)
treeda486cc25358cad414bb337a50c9abe07bf3b23e
parent9c96e14e5e16b9d70ee5716f00fb5b0972b1239d (diff)
downloadmeta-openembedded-5818f54160016088c79030217fe80f2688714546.tar.gz
htop: Update to 2.1.0
Add PACKAGECONFIG options and update formatting to better conform to the style guide. Signed-off-by: Robert Joslyn <robert.joslyn@redrectangle.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/htop/files/0001-Use-pkg-config.patch35
-rw-r--r--meta-oe/recipes-support/htop/htop_2.0.2.bb25
-rw-r--r--meta-oe/recipes-support/htop/htop_2.1.0.bb35
3 files changed, 49 insertions, 46 deletions
diff --git a/meta-oe/recipes-support/htop/files/0001-Use-pkg-config.patch b/meta-oe/recipes-support/htop/files/0001-Use-pkg-config.patch
index ff5cd4923..fc0d86e33 100644
--- a/meta-oe/recipes-support/htop/files/0001-Use-pkg-config.patch
+++ b/meta-oe/recipes-support/htop/files/0001-Use-pkg-config.patch
@@ -1,36 +1,32 @@
1From 7ebcbf17ad9483c7109e4a83b66966bc02f09bd4 Mon Sep 17 00:00:00 2001
2From: Paul Barker <pbarker@toganlabs.com>
3Date: Sun, 5 Nov 2017 20:10:10 +0000
4Subject: [PATCH] Use pkg-config
5
6We need to use pkg-config to find the ncurses library instead of the 1We need to use pkg-config to find the ncurses library instead of the
7ncurses*-config applications. 2ncurses*-config applications.
8 3
9Signed-off-by: Paul Barker <pbarker@toganlabs.com> 4Signed-off-by: Paul Barker <pbarker@toganlabs.com>
5Signed-off-by: Robert Joslyn <robert.joslyn@redrectangle.org>
6
10Upstream-status: Inappropriate 7Upstream-status: Inappropriate
11 (`ncurses*-config` can be used outside of OpenEmbedded) 8 (`ncurses*-config` can be used outside of OpenEmbedded)
12---
13 configure.ac | 10 +++++-----
14 1 file changed, 5 insertions(+), 5 deletions(-)
15 9
16diff --git a/configure.ac b/configure.ac 10diff --git a/configure.ac b/configure.ac
17index 7e0edd1..c5a8365 100644 11index 559dc4d..77aea22 100644
18--- a/configure.ac 12--- a/configure.ac
19+++ b/configure.ac 13+++ b/configure.ac
20@@ -185,9 +185,9 @@ m4_define([HTOP_CHECK_LIB], 14@@ -185,10 +185,10 @@ m4_define([HTOP_CHECK_LIB],
21 15
22 AC_ARG_ENABLE(unicode, [AS_HELP_STRING([--enable-unicode], [enable Unicode support])], ,enable_unicode="yes") 16 AC_ARG_ENABLE(unicode, [AS_HELP_STRING([--enable-unicode], [enable Unicode support])], ,enable_unicode="yes")
23 if test "x$enable_unicode" = xyes; then 17 if test "x$enable_unicode" = xyes; then
24- HTOP_CHECK_SCRIPT([ncursesw6], [addnwstr], [HAVE_LIBNCURSESW], "ncursesw6-config", 18- HTOP_CHECK_SCRIPT([ncursesw6], [addnwstr], [HAVE_LIBNCURSESW], "ncursesw6-config",
25- HTOP_CHECK_SCRIPT([ncursesw], [addnwstr], [HAVE_LIBNCURSESW], "ncursesw5-config", 19- HTOP_CHECK_SCRIPT([ncursesw], [addnwstr], [HAVE_LIBNCURSESW], "ncursesw6-config",
26- HTOP_CHECK_SCRIPT([ncurses], [addnwstr], [HAVE_LIBNCURSESW], "ncurses5-config", 20- HTOP_CHECK_SCRIPT([ncursesw], [addnwstr], [HAVE_LIBNCURSESW], "ncursesw5-config",
21- HTOP_CHECK_SCRIPT([ncurses], [addnwstr], [HAVE_LIBNCURSESW], "ncurses5-config",
27+ HTOP_CHECK_SCRIPT([ncursesw6], [addnwstr], [HAVE_LIBNCURSESW], "pkg-config ncursesw6", 22+ HTOP_CHECK_SCRIPT([ncursesw6], [addnwstr], [HAVE_LIBNCURSESW], "pkg-config ncursesw6",
28+ HTOP_CHECK_SCRIPT([ncursesw], [addnwstr], [HAVE_LIBNCURSESW], "pkg-config ncursesw5", 23+ HTOP_CHECK_SCRIPT([ncursesw], [addnwstr], [HAVE_LIBNCURSESW], "pkg-config ncursesw6",
29+ HTOP_CHECK_SCRIPT([ncurses], [addnwstr], [HAVE_LIBNCURSESW], "pkg-config ncurses5", 24+ HTOP_CHECK_SCRIPT([ncursesw], [addnwstr], [HAVE_LIBNCURSESW], "pkg-config ncursesw5",
30 HTOP_CHECK_LIB([ncursesw6], [addnwstr], [HAVE_LIBNCURSESW], 25+ HTOP_CHECK_SCRIPT([ncurses], [addnwstr], [HAVE_LIBNCURSESW], "pkg-config ncurses5",
31 HTOP_CHECK_LIB([ncursesw], [addnwstr], [HAVE_LIBNCURSESW], 26 HTOP_CHECK_LIB([ncursesw6], [addnwstr], [HAVE_LIBNCURSESW],
32 HTOP_CHECK_LIB([ncurses], [addnwstr], [HAVE_LIBNCURSESW], 27 HTOP_CHECK_LIB([ncursesw], [addnwstr], [HAVE_LIBNCURSESW],
33@@ -200,8 +200,8 @@ if test "x$enable_unicode" = xyes; then 28 HTOP_CHECK_LIB([ncurses], [addnwstr], [HAVE_LIBNCURSESW],
29@@ -201,8 +201,8 @@ if test "x$enable_unicode" = xyes; then
34 [AC_CHECK_HEADERS([ncurses/curses.h],[:], 30 [AC_CHECK_HEADERS([ncurses/curses.h],[:],
35 [AC_CHECK_HEADERS([ncurses.h],[:],[missing_headers="$missing_headers $ac_header"])])])]) 31 [AC_CHECK_HEADERS([ncurses.h],[:],[missing_headers="$missing_headers $ac_header"])])])])
36 else 32 else
@@ -41,6 +37,3 @@ index 7e0edd1..c5a8365 100644
41 HTOP_CHECK_LIB([ncurses6], [refresh], [HAVE_LIBNCURSES], 37 HTOP_CHECK_LIB([ncurses6], [refresh], [HAVE_LIBNCURSES],
42 HTOP_CHECK_LIB([ncurses], [refresh], [HAVE_LIBNCURSES], 38 HTOP_CHECK_LIB([ncurses], [refresh], [HAVE_LIBNCURSES],
43 missing_libraries="$missing_libraries libncurses" 39 missing_libraries="$missing_libraries libncurses"
44--
452.7.4
46
diff --git a/meta-oe/recipes-support/htop/htop_2.0.2.bb b/meta-oe/recipes-support/htop/htop_2.0.2.bb
deleted file mode 100644
index 395b83ff6..000000000
--- a/meta-oe/recipes-support/htop/htop_2.0.2.bb
+++ /dev/null
@@ -1,25 +0,0 @@
1SUMMARY = "htop process monitor"
2HOMEPAGE = "http://htop.sf.net"
3SECTION = "console/utils"
4LICENSE = "GPLv2"
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=c312653532e8e669f30e5ec8bdc23be3"
7
8DEPENDS = "ncurses"
9RDEPENDS_${PN} = "ncurses-terminfo"
10
11SRC_URI = " \
12 http://hisham.hm/htop/releases/${PV}/htop-${PV}.tar.gz \
13 file://0001-Use-pkg-config.patch \
14 "
15
16SRC_URI[md5sum] = "7d354d904bad591a931ad57e99fea84a"
17SRC_URI[sha256sum] = "179be9dccb80cee0c5e1a1f58c8f72ce7b2328ede30fb71dcdf336539be2f487"
18
19LDFLAGS_append_libc-uclibc = " -lubacktrace"
20
21do_configure_prepend () {
22 rm -rf ${S}/config.h
23}
24
25inherit autotools
diff --git a/meta-oe/recipes-support/htop/htop_2.1.0.bb b/meta-oe/recipes-support/htop/htop_2.1.0.bb
new file mode 100644
index 000000000..5ff2fcfbf
--- /dev/null
+++ b/meta-oe/recipes-support/htop/htop_2.1.0.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Interactive process viewer"
2HOMEPAGE = "http://hisham.hm/htop"
3SECTION = "console/utils"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=c312653532e8e669f30e5ec8bdc23be3"
6
7DEPENDS = "ncurses"
8
9SRC_URI = "http://hisham.hm/htop/releases/${PV}/${BP}.tar.gz \
10 file://0001-Use-pkg-config.patch"
11SRC_URt[md5sum] = "f262b66ad6c194782f4d3a80627e84c8"
12SRC_URI[sha256sum] = "3260be990d26e25b6b49fc9d96dbc935ad46e61083c0b7f6df413e513bf80748"
13
14inherit autotools pkgconfig
15
16PACKAGECONFIG ??= "proc \
17 cgroup \
18 taskstats \
19 unicode \
20 linux-affinity \
21 delayacct"
22PACKAGECONFIG[proc] = "--enable-proc,--disable-proc"
23PACKAGECONFIG[openvz] = "--enable-openvz,--disable-openvz"
24PACKAGECONFIG[cgroup] = "--enable-cgroup,--disable-cgroup"
25PACKAGECONFIG[vserver] = "--enable-vserver,--disable-vserver"
26PACKAGECONFIG[taskstats] = "--enable-taskstats,--disable-taskstats"
27PACKAGECONFIG[unicode] = "--enable-unicode,--disable-unicode"
28PACKAGECONFIG[linux-affinity] = "--enable-linux-affinity,--disable-linux-affinity"
29PACKAGECONFIG[hwloc] = "--enable-hwloc,--disable-hwloc,hwloc"
30PACKAGECONFIG[setuid] = "--enable-setuid,--disable-setuid"
31PACKAGECONFIG[delayacct] = "--enable-delayacct,--disable-delayacct,libnl"
32
33do_configure_prepend () {
34 rm -rf ${S}/config.h
35}