summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-02-19 20:37:31 -0800
committerKhem Raj <raj.khem@gmail.com>2024-02-20 08:38:30 -0800
commit57db42741df341718b9bb4b1b8f20d2e2fcf7010 (patch)
tree9f1ef160309c3580882eb48bf40bf6f91755aa94
parentb26585720b7479ecab5f9b3d650740d60b322951 (diff)
downloadmeta-openembedded-57db42741df341718b9bb4b1b8f20d2e2fcf7010.tar.gz
python3-pocketsphinx: Upgrade to 5.0.3
License-Update: New licenses added for WebRTC json parser, and json escaping [1] https://github.com/cmusphinx/pocketsphinx/commit/4cb5845898c7d9e53688aba370ea3c00c0ef7db2 [2] https://github.com/cmusphinx/pocketsphinx/commit/6b9a923832a1fd77c5304eba18e63d8b0e2ef0b8 Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-pocketsphinx/0001-cython-Use-cythyon3-in-cmake-check.patch29
-rw-r--r--meta-python/recipes-devtools/python/python3-pocketsphinx_0.1.15.bb14
-rw-r--r--meta-python/recipes-devtools/python/python3-pocketsphinx_5.0.3.bb20
3 files changed, 49 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pocketsphinx/0001-cython-Use-cythyon3-in-cmake-check.patch b/meta-python/recipes-devtools/python/python3-pocketsphinx/0001-cython-Use-cythyon3-in-cmake-check.patch
new file mode 100644
index 000000000..40b2544d5
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pocketsphinx/0001-cython-Use-cythyon3-in-cmake-check.patch
@@ -0,0 +1,29 @@
1From 5e6eb640f54a0d716d62ab4db8d96d3b6f3aa7bc Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 19 Feb 2024 22:11:41 -0800
4Subject: [PATCH] cython: Use cythyon3 in cmake check
5
6OE does not install cython anymore, it only has cython3
7therefore point the build system to find cython3
8
9Upstream-Status: Inappropriate [ OE-Specific ]
10
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 cython/CMakeLists.txt | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-)
15
16diff --git a/cython/CMakeLists.txt b/cython/CMakeLists.txt
17index daa4f76..93dd030 100644
18--- a/cython/CMakeLists.txt
19+++ b/cython/CMakeLists.txt
20@@ -1,5 +1,5 @@
21 find_package(Python COMPONENTS Interpreter Development.Module REQUIRED)
22-find_program(CYTHON "cython")
23+find_program(CYTHON "cython3")
24
25 if(NOT USE_INSTALLED_POCKETSPHINX)
26 set_property(TARGET pocketsphinx PROPERTY POSITION_INDEPENDENT_CODE on)
27--
282.43.2
29
diff --git a/meta-python/recipes-devtools/python/python3-pocketsphinx_0.1.15.bb b/meta-python/recipes-devtools/python/python3-pocketsphinx_0.1.15.bb
deleted file mode 100644
index f7ffd9d26..000000000
--- a/meta-python/recipes-devtools/python/python3-pocketsphinx_0.1.15.bb
+++ /dev/null
@@ -1,14 +0,0 @@
1SUMMARY = "This package provides a python interface to CMU Sphinxbase and Pocketsphinx libraries created with SWIG and Setuptools."
2DESCRIPTION = "Python interface to CMU Sphinxbase and Pocketsphinx libraries"
3HOMEPAGE = "https://github.com/bambocher/pocketsphinx-python"
4SECTION = "devel/python"
5LICENSE = "BSD-2-Clause"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=826ebda787eb48e78aec2624f9faba72"
7
8SRC_URI[md5sum] = "94d008eebea16acb60a9ffe614575dee"
9SRC_URI[sha256sum] = "34d290745c7dbe6fa2cac9815b5c19d10f393e528ecd70e779c21ebc448f9b63"
10
11inherit pypi setuptools3 features_check
12
13DEPENDS += "swig-native pulseaudio"
14REQUIRED_DISTRO_FEATURES += "pulseaudio"
diff --git a/meta-python/recipes-devtools/python/python3-pocketsphinx_5.0.3.bb b/meta-python/recipes-devtools/python/python3-pocketsphinx_5.0.3.bb
new file mode 100644
index 000000000..4ffcb4db8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pocketsphinx_5.0.3.bb
@@ -0,0 +1,20 @@
1SUMMARY = "Python interface to Pocketsphinx libraries."
2DESCRIPTION = "Pythonsphinx is an Open source large vocabulary, speaker-independent continuous speech recognition engines."
3HOMEPAGE = "https://github.com/cmusphinx/pocketsphinx"
4SECTION = "devel/python"
5LICENSE = "BSD-2-Clause | BSD-3-Clause | MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=c4d720cdc9c6953091f65e8b01524bb4"
7
8SRC_URI += "file://0001-cython-Use-cythyon3-in-cmake-check.patch"
9SRC_URI[sha256sum] = "27f4de0ca2d2bce391ce87eaab84fe6f0bc059b306fd1702d5fe6549b66e1586"
10
11inherit cmake pkgconfig pypi python3native
12
13DEPENDS += "swig-native python3-cython-native python3-scikit-build-native gstreamer1.0 gstreamer1.0-plugins-base"
14
15EXTRA_OECMAKE += "-DBUILD_GSTREAMER=ON"
16
17PACKAGES += "${PN}-models ${MLPREFIX}gstreamer1.0-pocketsphinx"
18
19FILES:${MLPREFIX}gstreamer1.0-pocketsphinx = "${libdir}/gstreamer-1.0/"
20FILES:${PN}-models = "${datadir}/pocketsphinx/model"