summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Dragomir <daniel.dragomir@windriver.com>2018-03-08 18:54:56 +0200
committerArmin Kuster <akuster808@gmail.com>2018-03-16 19:27:54 -0700
commit55d20eeab8e63a178d89091930b581d62711f183 (patch)
tree9ef2a734eab5ca3d9624c5146ea69d05b6bf8586
parent10fdb67d10dee74be4be47f2c4a2276ada32df0f (diff)
downloadmeta-openembedded-55d20eeab8e63a178d89091930b581d62711f183.tar.gz
python-pyexpect: add recipe for 1.0.17 version
Minimal but very flexible implementation of the expect pattern. Signed-off-by: Daniel Dragomir <daniel.dragomir@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-pyexpect.inc11
-rw-r--r--meta-python/recipes-devtools/python/python-pyexpect_1.0.17.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pyexpect_1.0.17.bb2
3 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyexpect.inc b/meta-python/recipes-devtools/python/python-pyexpect.inc
new file mode 100644
index 000000000..d2d41d51d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyexpect.inc
@@ -0,0 +1,11 @@
1SUMMARY = "Python expectaton library"
2DESCRIPTION = "Minimal but very flexible implementation of the expect pattern"
3SECTION = "devel/python"
4HOMEPAGE = " https://bitbucket.org/dwt/pyexpect"
5LICENSE = "ISC"
6LIC_FILES_CHKSUM = "file://README.md;md5=500b884e9dcd5f677a53cbbee8ace939"
7
8inherit pypi
9
10SRC_URI[md5sum] = "c71307d6c7096fdbde0813018dfa0092"
11SRC_URI[sha256sum] = "d656ef7e07a8aa539ce0a4883a683341037b6fc1c329bf55b63bffbf2cce9582"
diff --git a/meta-python/recipes-devtools/python/python-pyexpect_1.0.17.bb b/meta-python/recipes-devtools/python/python-pyexpect_1.0.17.bb
new file mode 100644
index 000000000..d26beb794
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyexpect_1.0.17.bb
@@ -0,0 +1,2 @@
1inherit setuptools
2require python-pyexpect.inc
diff --git a/meta-python/recipes-devtools/python/python3-pyexpect_1.0.17.bb b/meta-python/recipes-devtools/python/python3-pyexpect_1.0.17.bb
new file mode 100644
index 000000000..bfd584041
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyexpect_1.0.17.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-pyexpect.inc