diff options
author | Khem Raj <raj.khem@gmail.com> | 2024-08-14 21:41:13 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-08-15 10:28:12 -0700 |
commit | 55bfe466db4e1489968f5b4841827ba6023e052c (patch) | |
tree | 4c9cd6c708d1ed6857598e8e8878078b494d1f24 | |
parent | 181409fef4042d0e67060e3c36448d124958f109 (diff) | |
download | meta-openembedded-55bfe466db4e1489968f5b4841827ba6023e052c.tar.gz |
blueman: Fix buildpathe issue with cython generated code
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Cc: Markus Volk <f_l_k@t-online.de>
-rw-r--r-- | meta-networking/recipes-connectivity/blueman/blueman/0001-meson-DO-not-emit-absolute-path-when-S-B.patch | 38 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/blueman/blueman_2.4.3.bb | 3 |
2 files changed, 40 insertions, 1 deletions
diff --git a/meta-networking/recipes-connectivity/blueman/blueman/0001-meson-DO-not-emit-absolute-path-when-S-B.patch b/meta-networking/recipes-connectivity/blueman/blueman/0001-meson-DO-not-emit-absolute-path-when-S-B.patch new file mode 100644 index 000000000..10f89a124 --- /dev/null +++ b/meta-networking/recipes-connectivity/blueman/blueman/0001-meson-DO-not-emit-absolute-path-when-S-B.patch | |||
@@ -0,0 +1,38 @@ | |||
1 | From 18af739fd96960bbc8c5db5dd290d2f9134cd347 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 14 Aug 2024 21:26:24 -0700 | ||
4 | Subject: [PATCH] meson: DO not emit absolute path when S != B | ||
5 | |||
6 | build systems like OE build outside sourcetree in such cases it works | ||
7 | ok but cython resolves the input file to absolute path and that gets | ||
8 | emitted into genetate _blueman.c as module name, renders the build | ||
9 | non-reproducible, wish cython had a better way to handle this but there | ||
10 | is not, therefore tweak the meson build rule to account for specifying | ||
11 | workdir to cython which will search the inputs correctly, and use | ||
12 | meson's build_root to emit the output into build dir. This ensures that | ||
13 | it becomes independent of source or build directories and cython does | ||
14 | not generate the absolute paths into generate C code. | ||
15 | |||
16 | See cython discussion on [1] | ||
17 | |||
18 | [1] https://github.com/cython/cython/issues/5949 | ||
19 | |||
20 | Upstream-Status: Submitted [https://github.com/blueman-project/blueman/pull/2461] | ||
21 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
22 | --- | ||
23 | module/meson.build | 2 +- | ||
24 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
25 | |||
26 | diff --git a/module/meson.build b/module/meson.build | ||
27 | index 096ad7c8..e3d96f17 100644 | ||
28 | --- a/module/meson.build | ||
29 | +++ b/module/meson.build | ||
30 | @@ -4,7 +4,7 @@ blueman_c = custom_target( | ||
31 | 'blueman_c', | ||
32 | output: '_blueman.c', | ||
33 | input: '_blueman.pyx', | ||
34 | - command: [cython, '--output-file', '@OUTPUT@', '@INPUT@']) | ||
35 | + command: [cython, '-w', meson.source_root(), '--output-file', meson.build_root() + '/' + '@OUTPUT@', '@INPUT@']) | ||
36 | |||
37 | sources = [ | ||
38 | blueman_c, | ||
diff --git a/meta-networking/recipes-connectivity/blueman/blueman_2.4.3.bb b/meta-networking/recipes-connectivity/blueman/blueman_2.4.3.bb index df2a226f0..c2bb4d24c 100644 --- a/meta-networking/recipes-connectivity/blueman/blueman_2.4.3.bb +++ b/meta-networking/recipes-connectivity/blueman/blueman_2.4.3.bb | |||
@@ -8,7 +8,8 @@ inherit meson gettext systemd gsettings pkgconfig python3native gtk-icon-cache u | |||
8 | 8 | ||
9 | REQUIRED_DISTRO_FEATURES = "gobject-introspection-data" | 9 | REQUIRED_DISTRO_FEATURES = "gobject-introspection-data" |
10 | 10 | ||
11 | SRC_URI = "git://github.com/blueman-project/blueman.git;protocol=https;branch=2-4-stable" | 11 | SRC_URI = "git://github.com/blueman-project/blueman.git;protocol=https;branch=2-4-stable \ |
12 | file://0001-meson-DO-not-emit-absolute-path-when-S-B.patch" | ||
12 | S = "${WORKDIR}/git" | 13 | S = "${WORKDIR}/git" |
13 | SRCREV = "7bcf919ad6ac0ee9a8c66b18b0ca98af877d4c8f" | 14 | SRCREV = "7bcf919ad6ac0ee9a8c66b18b0ca98af877d4c8f" |
14 | 15 | ||