diff options
author | Tim Orling <ticotimo@gmail.com> | 2024-02-16 16:14:54 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-02-16 16:42:31 -0800 |
commit | 5218051879264ccc8010a9686b940bc585ef0c6f (patch) | |
tree | 5e2ec59694fa62b52fff462f12f1cbd1a34a14e8 | |
parent | 19412dc78d8a6f170bb255972033c27ee3c90a76 (diff) | |
download | meta-openembedded-5218051879264ccc8010a9686b940bc585ef0c6f.tar.gz |
python3-ujson: switch to pytest --automake
* Also replace ${PYTHON_PN} with python3
Signed-off-by: Tim Orling <tim.orling@konsulko.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-python/recipes-devtools/python/python3-ujson/run-ptest | 2 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-ujson_5.9.0.bb | 13 |
2 files changed, 8 insertions, 7 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ujson/run-ptest b/meta-python/recipes-devtools/python/python3-ujson/run-ptest index b63c4de0d..8d2017d39 100644 --- a/meta-python/recipes-devtools/python/python3-ujson/run-ptest +++ b/meta-python/recipes-devtools/python/python3-ujson/run-ptest | |||
@@ -1,3 +1,3 @@ | |||
1 | #!/bin/sh | 1 | #!/bin/sh |
2 | 2 | ||
3 | pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' | 3 | pytest --automake |
diff --git a/meta-python/recipes-devtools/python/python3-ujson_5.9.0.bb b/meta-python/recipes-devtools/python/python3-ujson_5.9.0.bb index 8de9b030d..b5f6be9f2 100644 --- a/meta-python/recipes-devtools/python/python3-ujson_5.9.0.bb +++ b/meta-python/recipes-devtools/python/python3-ujson_5.9.0.bb | |||
@@ -13,17 +13,18 @@ SRC_URI += " \ | |||
13 | file://0001-setup.py-Do-not-strip-debugging-symbols.patch \ | 13 | file://0001-setup.py-Do-not-strip-debugging-symbols.patch \ |
14 | " | 14 | " |
15 | 15 | ||
16 | DEPENDS += "${PYTHON_PN}-setuptools-scm-native" | 16 | DEPENDS += "python3-setuptools-scm-native" |
17 | 17 | ||
18 | RDEPENDS:${PN} += "\ | 18 | RDEPENDS:${PN} += "\ |
19 | ${PYTHON_PN}-datetime \ | 19 | python3-datetime \ |
20 | ${PYTHON_PN}-numbers \ | 20 | python3-numbers \ |
21 | " | 21 | " |
22 | 22 | ||
23 | RDEPENDS:${PN}-ptest += " \ | 23 | RDEPENDS:${PN}-ptest += " \ |
24 | ${PYTHON_PN}-json \ | 24 | python3-json \ |
25 | ${PYTHON_PN}-pytest \ | 25 | python3-pytest \ |
26 | ${PYTHON_PN}-pytz \ | 26 | python3-pytz \ |
27 | python3-unittest-automake-output \ | ||
27 | " | 28 | " |
28 | 29 | ||
29 | do_install_ptest() { | 30 | do_install_ptest() { |