summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2025-04-01 20:38:33 -0700
committerKhem Raj <raj.khem@gmail.com>2025-04-01 21:54:56 -0700
commit52138d7faf1d869381725e70a94b927c1d99b94c (patch)
treeb17e42c7c2b7d152f89b1a400946450ef784a714
parentd9468fad734a4a31c323324f9ba552ed052d040e (diff)
downloadmeta-openembedded-52138d7faf1d869381725e70a94b927c1d99b94c.tar.gz
python3-typing-inspection: Add recipe
This is needed by new versions of lief and pydantic python modules Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/conf/include/ptest-packagelists-meta-python.inc1
-rw-r--r--meta-python/recipes-devtools/python/python3-typing-inspection_0.4.0.bb15
2 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/conf/include/ptest-packagelists-meta-python.inc b/meta-python/conf/include/ptest-packagelists-meta-python.inc
index fc71eb4003..fc6c164c3e 100644
--- a/meta-python/conf/include/ptest-packagelists-meta-python.inc
+++ b/meta-python/conf/include/ptest-packagelists-meta-python.inc
@@ -84,6 +84,7 @@ PTESTS_FAST_META_PYTHON = "\
84 python3-tomlkit \ 84 python3-tomlkit \
85 python3-trustme \ 85 python3-trustme \
86 python3-typeguard \ 86 python3-typeguard \
87 python3-typing-inspection \
87 python3-tzdata \ 88 python3-tzdata \
88 python3-ujson \ 89 python3-ujson \
89 python3-u-msgpack-python \ 90 python3-u-msgpack-python \
diff --git a/meta-python/recipes-devtools/python/python3-typing-inspection_0.4.0.bb b/meta-python/recipes-devtools/python/python3-typing-inspection_0.4.0.bb
new file mode 100644
index 0000000000..52d846f799
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-typing-inspection_0.4.0.bb
@@ -0,0 +1,15 @@
1SUMMARY = "Runtime typing introspection tools"
2HOMEPAGE = "https://github.com/pydantic/typing-inspection"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=07cbaa23fc9dd504fc1ea5acc23b0add"
5
6DEPENDS = "python3-hatchling-native"
7SRC_URI[sha256sum] = "9765c87de36671694a67904bf2c96e395be9c6439bb6c87b5142569dcdd65122"
8
9inherit pypi python_hatchling ptest-python-pytest
10
11RDEPENDS:${PN}-ptest += "python3-typing-extensions"
12
13PYPI_PACKAGE = "typing_inspection"
14
15BBCLASSEXTEND += "native nativesdk"