summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-04-11 23:26:44 -0700
committerKhem Raj <raj.khem@gmail.com>2024-04-11 23:32:36 -0700
commit51b38953a6e7f2769b5f4ac021f55299f3c68b99 (patch)
tree7c5a1a63e93095be1c1e2d65fa27d990359df0ed
parentdf35bef3ae6411900efdfc3ea5ade23820e9af2f (diff)
downloadmeta-openembedded-51b38953a6e7f2769b5f4ac021f55299f3c68b99.tar.gz
oprofile: Fix failing ptests
Files need to be in right directory structure Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-kernel/oprofile/oprofile_1.4.0.bb9
1 files changed, 6 insertions, 3 deletions
diff --git a/meta-oe/recipes-kernel/oprofile/oprofile_1.4.0.bb b/meta-oe/recipes-kernel/oprofile/oprofile_1.4.0.bb
index 335ab48bb..092d22746 100644
--- a/meta-oe/recipes-kernel/oprofile/oprofile_1.4.0.bb
+++ b/meta-oe/recipes-kernel/oprofile/oprofile_1.4.0.bb
@@ -58,16 +58,18 @@ do_install_ptest() {
58 find ${tooltest} -perm /u=x -type f| cpio -pvdu ${D}${PTEST_PATH} 58 find ${tooltest} -perm /u=x -type f| cpio -pvdu ${D}${PTEST_PATH}
59 done 59 done
60 60
61 # needed by some libop tests 61 install -d ${D}${PTEST_PATH}/../${BP}/events ${D}${PTEST_PATH}/../${BP}/libutil++/tests
62 cp -r events ${D}${PTEST_PATH}
63
64 # needed by libregex regex_test 62 # needed by libregex regex_test
65 cp libregex/stl.pat ${D}${PTEST_PATH}/libregex 63 cp libregex/stl.pat ${D}${PTEST_PATH}/libregex
66 cp libregex/tests/mangled-name ${D}${PTEST_PATH}/libregex/tests 64 cp libregex/tests/mangled-name ${D}${PTEST_PATH}/libregex/tests
67 65
68 # needed by litutil++ file_manip_tests 66 # needed by litutil++ file_manip_tests
69 cp ${S}/libutil++/tests/file_manip_tests.cpp \ 67 cp ${S}/libutil++/tests/file_manip_tests.cpp \
68 libutil++/tests/file_manip_tests.o ${D}${PTEST_PATH}/../${BP}/libutil++/tests
69 cp ${S}/libutil++/tests/file_manip_tests.cpp \
70 libutil++/tests/file_manip_tests.o ${D}${PTEST_PATH}/libutil++/tests 70 libutil++/tests/file_manip_tests.o ${D}${PTEST_PATH}/libutil++/tests
71 # needed by some libop tests
72 cp -R --no-dereference --preserve=mode,links -v ${S}/events ${D}${PTEST_PATH}/../${BP}
71} 73}
72 74
73RDEPENDS:${PN} = "binutils-symlinks" 75RDEPENDS:${PN} = "binutils-symlinks"
@@ -75,3 +77,4 @@ RDEPENDS:${PN} = "binutils-symlinks"
75FILES:${PN} = "${bindir} ${libdir}/${BPN}/lib*${SOLIBS} ${datadir}/${BPN}" 77FILES:${PN} = "${bindir} ${libdir}/${BPN}/lib*${SOLIBS} ${datadir}/${BPN}"
76FILES:${PN}-dev += "${libdir}/${BPN}/lib*${SOLIBSDEV} ${libdir}/${BPN}/lib*.la" 78FILES:${PN}-dev += "${libdir}/${BPN}/lib*${SOLIBSDEV} ${libdir}/${BPN}/lib*.la"
77FILES:${PN}-staticdev += "${libdir}/${BPN}/lib*.a" 79FILES:${PN}-staticdev += "${libdir}/${BPN}/lib*.a"
80FILES:${PN}-ptest += "${libdir}/${BPN}/${BP}"