diff options
author | Avinash Reddy Palleti <avinash.reddy.palleti@intel.com> | 2018-08-17 09:47:39 +0530 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-08-19 16:09:28 -0700 |
commit | 4dfe0fe8ed9a02aed37a9503cd8da70de64be906 (patch) | |
tree | 4d59912e4d375be087f2e54de9fca3256f12a4e1 | |
parent | 8a2a36e66ba392317acab180b6cefa8139ef8fa2 (diff) | |
download | meta-openembedded-4dfe0fe8ed9a02aed37a9503cd8da70de64be906.tar.gz |
cpuid: Fix build with glibc 2.28+
Include sys/sysmacros.h for cpuid.c
Upstream-Status:Pending
Signed-off-by: Avinash Reddy Palleti <avinash.reddy.palleti@intel.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/recipes-devtools/cpuid/cpuid_20170122.bb | 3 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/cpuid/files/0001-Fix-Add-sys-sysmacros.h-to-fix-build-issue.patch | 24 |
2 files changed, 26 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/cpuid/cpuid_20170122.bb b/meta-oe/recipes-devtools/cpuid/cpuid_20170122.bb index 7a70f75763..5dd1bdd4ee 100644 --- a/meta-oe/recipes-devtools/cpuid/cpuid_20170122.bb +++ b/meta-oe/recipes-devtools/cpuid/cpuid_20170122.bb | |||
@@ -6,7 +6,8 @@ UMC, NexGen, Rise, and SiS CPUs" | |||
6 | LICENSE = "GPLv2" | 6 | LICENSE = "GPLv2" |
7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263" | 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
8 | 8 | ||
9 | SRC_URI = "http://www.etallen.com/${BPN}/${BP}.src.tar.gz" | 9 | SRC_URI = "http://www.etallen.com/${BPN}/${BP}.src.tar.gz \ |
10 | file://0001-Fix-Add-sys-sysmacros.h-to-fix-build-issue.patch" | ||
10 | SRC_URI[md5sum] = "1c46a6662626c5a6eaca626f23a5a7d7" | 11 | SRC_URI[md5sum] = "1c46a6662626c5a6eaca626f23a5a7d7" |
11 | SRC_URI[sha256sum] = "667612aae6704341dd10844e97c84c5c5c8700817a5937a3c293b55013bc4865" | 12 | SRC_URI[sha256sum] = "667612aae6704341dd10844e97c84c5c5c8700817a5937a3c293b55013bc4865" |
12 | 13 | ||
diff --git a/meta-oe/recipes-devtools/cpuid/files/0001-Fix-Add-sys-sysmacros.h-to-fix-build-issue.patch b/meta-oe/recipes-devtools/cpuid/files/0001-Fix-Add-sys-sysmacros.h-to-fix-build-issue.patch new file mode 100644 index 0000000000..985182e3bd --- /dev/null +++ b/meta-oe/recipes-devtools/cpuid/files/0001-Fix-Add-sys-sysmacros.h-to-fix-build-issue.patch | |||
@@ -0,0 +1,24 @@ | |||
1 | From 2693a499d4eec4504962e85a9713fa6431d3025f Mon Sep 17 00:00:00 2001 | ||
2 | From: Avinash Reddy Palleti <avinash.reddy.palleti@intel.com> | ||
3 | Date: Thu, 16 Aug 2018 22:36:31 +0530 | ||
4 | Subject: [PATCH] Fix: Add sys/sysmacros.h to fix build issue | ||
5 | |||
6 | --- | ||
7 | cpuid.c | 1 + | ||
8 | 1 file changed, 1 insertion(+) | ||
9 | |||
10 | diff --git a/cpuid.c b/cpuid.c | ||
11 | index 3c94837..0a98616 100644 | ||
12 | --- a/cpuid.c | ||
13 | +++ b/cpuid.c | ||
14 | @@ -31,6 +31,7 @@ | ||
15 | #include <stdio.h> | ||
16 | #include <sys/types.h> | ||
17 | #include <sys/stat.h> | ||
18 | +#include <sys/sysmacros.h> | ||
19 | #include <fcntl.h> | ||
20 | #include <errno.h> | ||
21 | #include <unistd.h> | ||
22 | -- | ||
23 | 2.7.4 | ||
24 | |||