summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2024-02-28 20:14:18 +0100
committerKhem Raj <raj.khem@gmail.com>2024-02-28 11:28:37 -0800
commit4b87fabf1210260e244ba6bb666b2554589702a2 (patch)
tree869ff27776d167df5791c3175dbcb696aa93ac29
parente569af1ff4b4dad0cf1d03255c9bb36e5f4e7dd9 (diff)
downloadmeta-openembedded-4b87fabf1210260e244ba6bb666b2554589702a2.tar.gz
ristretto: use python3native and depend on glib-2.0-native, python3-packaging-native
* it uses gdbus-codegen from glib-2.0-native which depended on python3-distutils-native until https://lists.openembedded.org/g/openembedded-core/message/196136 but distutils on host was enforced by sanity check only until mickledore with: https://git.openembedded.org/openembedded-core/commit/?id=8e3a5b0709384f2b455a82ac1e8e212686fe4456 so on hosts without distutils this was already failing and the glib-2.0-native change only changes the dependency from distutils to packaging which results in: https://errors.yoctoproject.org/Errors/Details/754996/ gdbus-codegen \ --c-namespace=Tumbler \ --interface-prefix=org.freedesktop.thumbnails. \ --generate-c-code=tumbler \ tumbler-service-dbus.xml Traceback (most recent call last): File "TOPDIR/build/tmp/work/riscv64-yoe-linux/ristretto/0.13.1/recipe-sysroot-native/usr/bin/gdbus-codegen", line 53, in <module> from codegen import codegen_main File "TOPDIR/build/tmp/work/riscv64-yoe-linux/ristretto/0.13.1/recipe-sysroot-native/usr/share/glib-2.0/codegen/codegen_main.py", line 29, in <module> from . import dbustypes File "TOPDIR/build/tmp/work/riscv64-yoe-linux/ristretto/0.13.1/recipe-sysroot-native/usr/share/glib-2.0/codegen/dbustypes.py", line 22, in <module> from . import utils File "TOPDIR/build/tmp/work/riscv64-yoe-linux/ristretto/0.13.1/recipe-sysroot-native/usr/share/glib-2.0/codegen/utils.py", line 22, in <module> import packaging.version ModuleNotFoundError: No module named 'packaging' * packaging probably isn't as wide spread on host distros as old distutils was, so make sure it's available by using python3-native with python3-packaging-native from OE build Signed-off-by: Martin Jansa <martin.jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-xfce/recipes-apps/ristretto/ristretto_0.13.1.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-xfce/recipes-apps/ristretto/ristretto_0.13.1.bb b/meta-xfce/recipes-apps/ristretto/ristretto_0.13.1.bb
index 4aac89fe7..dcae982ce 100644
--- a/meta-xfce/recipes-apps/ristretto/ristretto_0.13.1.bb
+++ b/meta-xfce/recipes-apps/ristretto/ristretto_0.13.1.bb
@@ -4,9 +4,9 @@ SECTION = "x11/application"
4LICENSE = "GPL-2.0-only" 4LICENSE = "GPL-2.0-only"
5LIC_FILES_CHKSUM = "file://COPYING;md5=35d145429ad3cbf5308d1dc93f66376b" 5LIC_FILES_CHKSUM = "file://COPYING;md5=35d145429ad3cbf5308d1dc93f66376b"
6 6
7DEPENDS = "exo libexif libxfce4ui libxfce4util xfconf cairo file" 7DEPENDS = "exo libexif libxfce4ui libxfce4util xfconf cairo file glib-2.0-native python3-packaging-native"
8 8
9inherit xfce-app mime-xdg 9inherit xfce-app mime-xdg python3native
10 10
11RRECOMMENDS:${PN} += "tumbler" 11RRECOMMENDS:${PN} += "tumbler"
12 12