summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKang Kai <kai.kang@windriver.com>2014-10-29 08:30:59 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-11-07 15:05:46 +0100
commit47cc7a8d1640d9128e2eaf3cc79cdef41e85881c (patch)
tree75eccdd3c788afe620bd2b54e5a86fcc5b9a3da7
parentffb649d04322db8c3e218ee1a4499e202657375d (diff)
downloadmeta-openembedded-47cc7a8d1640d9128e2eaf3cc79cdef41e85881c.tar.gz
libyaml: add fix for CVE-2014-2525 Security Advisory
Heap-based buffer overflow in the yaml_parser_scan_uri_escapes function in LibYAML before 0.1.6 allows context-dependent attackers to execute arbitrary code via a long sequence of percent-encoded characters in a URI in a YAML file. http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-2525 Signed-off-by: Yue Tao <Yue.Tao@windriver.com> Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-support/libyaml/files/libyaml-CVE-2014-2525.patch42
-rw-r--r--meta-oe/recipes-support/libyaml/libyaml_0.1.5.bb4
2 files changed, 45 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/libyaml/files/libyaml-CVE-2014-2525.patch b/meta-oe/recipes-support/libyaml/files/libyaml-CVE-2014-2525.patch
new file mode 100644
index 000000000..2fdcba3ec
--- /dev/null
+++ b/meta-oe/recipes-support/libyaml/files/libyaml-CVE-2014-2525.patch
@@ -0,0 +1,42 @@
1Heap-based buffer overflow in the yaml_parser_scan_uri_escapes function
2in LibYAML before 0.1.6 allows context-dependent attackers to execute
3arbitrary code via a long sequence of percent-encoded characters in a
4URI in a YAML file.
5
6Upstream-Status: Backport
7
8Signed-off-by: Kai Kang <kai.kang@windriver.com>
9---
10diff --git a/src/scanner.c.old b/src/scanner.c
11index a2e8619..c6cde3b 100644
12--- a/src/scanner.c.old
13+++ b/src/scanner.c
14@@ -2619,6 +2619,9 @@ yaml_parser_scan_tag_uri(yaml_parser_t *parser, int directive,
15 /* Check if it is a URI-escape sequence. */
16
17 if (CHECK(parser->buffer, '%')) {
18+ if (!STRING_EXTEND(parser, string))
19+ goto error;
20+
21 if (!yaml_parser_scan_uri_escapes(parser,
22 directive, start_mark, &string)) goto error;
23 }
24diff --git a/src/yaml_private.h.old b/src/yaml_private.h
25index ed5ea66..d72acb4 100644
26--- a/src/yaml_private.h.old
27+++ b/src/yaml_private.h
28@@ -132,9 +132,12 @@ yaml_string_join(
29 (string).start = (string).pointer = (string).end = 0)
30
31 #define STRING_EXTEND(context,string) \
32- (((string).pointer+5 < (string).end) \
33+ ((((string).pointer+5 < (string).end) \
34 || yaml_string_extend(&(string).start, \
35- &(string).pointer, &(string).end))
36+ &(string).pointer, &(string).end)) ? \
37+ 1 : \
38+ ((context)->error = YAML_MEMORY_ERROR, \
39+ 0))
40
41 #define CLEAR(context,string) \
42 ((string).pointer = (string).start, \
diff --git a/meta-oe/recipes-support/libyaml/libyaml_0.1.5.bb b/meta-oe/recipes-support/libyaml/libyaml_0.1.5.bb
index c44eda4ee..127954196 100644
--- a/meta-oe/recipes-support/libyaml/libyaml_0.1.5.bb
+++ b/meta-oe/recipes-support/libyaml/libyaml_0.1.5.bb
@@ -7,7 +7,9 @@ SECTION = "libs/devel"
7LICENSE = "MIT" 7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=6015f088759b10e0bc2bf64898d4ae17" 8LIC_FILES_CHKSUM = "file://LICENSE;md5=6015f088759b10e0bc2bf64898d4ae17"
9 9
10SRC_URI = "http://pyyaml.org/download/libyaml/yaml-${PV}.tar.gz" 10SRC_URI = "http://pyyaml.org/download/libyaml/yaml-${PV}.tar.gz \
11 file://libyaml-CVE-2014-2525.patch \
12 "
11 13
12SRC_URI[md5sum] = "24f6093c1e840ca5df2eb09291a1dbf1" 14SRC_URI[md5sum] = "24f6093c1e840ca5df2eb09291a1dbf1"
13SRC_URI[sha256sum] = "fa87ee8fb7b936ec04457bc044cd561155e1000a4d25029867752e543c2d3bef" 15SRC_URI[sha256sum] = "fa87ee8fb7b936ec04457bc044cd561155e1000a4d25029867752e543c2d3bef"