summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2019-07-02 16:16:21 +0800
committerKhem Raj <raj.khem@gmail.com>2019-07-10 09:24:32 -0700
commit455bf879801fad433b99aeea4b63d857d051152b (patch)
tree41149bc34dea22b0f78e9a4ea621bd5dd22f15c4
parent2cdc4e72975aa1c2fc402bd4893ec264eb6bc54b (diff)
downloadmeta-openembedded-455bf879801fad433b99aeea4b63d857d051152b.tar.gz
thin-provisioning-tools: 0.7.6 -> 0.8.5
- Rebase use-sh-on-path.patch - Drop 0001-fix-compile-failed-with-libc-musl.patch which upstream has merged it Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/thin-provisioning-tools/files/0001-fix-compile-failed-with-libc-musl.patch42
-rw-r--r--meta-oe/recipes-support/thin-provisioning-tools/files/use-sh-on-path.patch21
-rw-r--r--meta-oe/recipes-support/thin-provisioning-tools/thin-provisioning-tools_0.8.5.bb (renamed from meta-oe/recipes-support/thin-provisioning-tools/thin-provisioning-tools_0.7.6.bb)3
3 files changed, 18 insertions, 48 deletions
diff --git a/meta-oe/recipes-support/thin-provisioning-tools/files/0001-fix-compile-failed-with-libc-musl.patch b/meta-oe/recipes-support/thin-provisioning-tools/files/0001-fix-compile-failed-with-libc-musl.patch
deleted file mode 100644
index 28b44da56..000000000
--- a/meta-oe/recipes-support/thin-provisioning-tools/files/0001-fix-compile-failed-with-libc-musl.patch
+++ /dev/null
@@ -1,42 +0,0 @@
1From fcbcf9c494cca166106ae4cb03c1dd135ee4f25c Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Wed, 1 Aug 2018 09:34:00 +0800
4Subject: [PATCH] fix compile failed with libc musl
5
6There is a failure while compiling with libc musl:
7[snip]
8|./block-cache/io_engine.h:18:17: error: expected
9unqualified-id before numeric constant
10| unsigned const PAGE_SIZE = 4096;
11[snip]
12
13The musl defeines macro PAGE_SIZE, undef it conditionally
14could fix the issue.
15
16http://musl.openwall.narkive.com/tO8vrHdP/why-musl-define-page-size
17
18Upstream-Status: Submitted [git://github.com/jthornber/thin-provisioning-tools]
19
20Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
21---
22 block-cache/io_engine.h | 4 ++++
23 1 file changed, 4 insertions(+)
24
25diff --git a/block-cache/io_engine.h b/block-cache/io_engine.h
26index 1704251..e36b932 100644
27--- a/block-cache/io_engine.h
28+++ b/block-cache/io_engine.h
29@@ -12,6 +12,10 @@
30
31 //----------------------------------------------------------------
32
33+// Musl defines
34+#ifdef PAGE_SIZE
35+#undef PAGE_SIZE
36+#endif
37 namespace bcache {
38 using sector_t = uint64_t;
39
40--
412.7.4
42
diff --git a/meta-oe/recipes-support/thin-provisioning-tools/files/use-sh-on-path.patch b/meta-oe/recipes-support/thin-provisioning-tools/files/use-sh-on-path.patch
index 8cb16decb..de934c19a 100644
--- a/meta-oe/recipes-support/thin-provisioning-tools/files/use-sh-on-path.patch
+++ b/meta-oe/recipes-support/thin-provisioning-tools/files/use-sh-on-path.patch
@@ -1,5 +1,7 @@
1 1From 38397b42e2c3450c2aee20e6fb92f362db4e35ef Mon Sep 17 00:00:00 2001
2thin-provisioning-tools: use sh on path when invoking txt2man 2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Tue, 2 Jul 2019 13:20:39 +0800
4Subject: [PATCH] thin-provisioning-tools: use sh on path when invoking txt2man
3 5
4txt2man contains a test which might try to use ksh to run the script, so we 6txt2man contains a test which might try to use ksh to run the script, so we
5avoid running /bin/sh. 7avoid running /bin/sh.
@@ -8,14 +10,25 @@ Upstream-Status: Inappropriate [oe specific]
8 10
9Signed-off-by: joe.slater <joe.slater@windriver.com> 11Signed-off-by: joe.slater <joe.slater@windriver.com>
10 12
13Rebase to 0.8.5
14Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
15---
16 Makefile.in | 2 +-
17 1 file changed, 1 insertion(+), 1 deletion(-)
18
19diff --git a/Makefile.in b/Makefile.in
20index 7c867b2..5303994 100644
11--- a/Makefile.in 21--- a/Makefile.in
12+++ b/Makefile.in 22+++ b/Makefile.in
13@@ -210,7 +210,7 @@ endif 23@@ -223,7 +223,7 @@ endif
14
15 %.8: %.txt bin/txt2man 24 %.8: %.txt bin/txt2man
16 @echo " [txt2man] $<" 25 @echo " [txt2man] $<"
26 @mkdir -p $(dir $@)
17- $(V) bin/txt2man -p -t $(basename $(notdir $<)) $< > $@ 27- $(V) bin/txt2man -p -t $(basename $(notdir $<)) $< > $@
18+ $(V) sh bin/txt2man -p -t $(basename $(notdir $<)) $< > $@ 28+ $(V) sh bin/txt2man -p -t $(basename $(notdir $<)) $< > $@
19 29
20 #---------------------------------------------------------------- 30 #----------------------------------------------------------------
21 31
32--
332.7.4
34
diff --git a/meta-oe/recipes-support/thin-provisioning-tools/thin-provisioning-tools_0.7.6.bb b/meta-oe/recipes-support/thin-provisioning-tools/thin-provisioning-tools_0.8.5.bb
index 5f6ba9e37..9f89bac22 100644
--- a/meta-oe/recipes-support/thin-provisioning-tools/thin-provisioning-tools_0.7.6.bb
+++ b/meta-oe/recipes-support/thin-provisioning-tools/thin-provisioning-tools_0.8.5.bb
@@ -9,11 +9,10 @@ S = "${WORKDIR}/git"
9 9
10SRC_URI = "git://github.com/jthornber/thin-provisioning-tools \ 10SRC_URI = "git://github.com/jthornber/thin-provisioning-tools \
11 file://0001-do-not-strip-pdata_tools-at-do_install.patch \ 11 file://0001-do-not-strip-pdata_tools-at-do_install.patch \
12 file://0001-fix-compile-failed-with-libc-musl.patch \
13 file://use-sh-on-path.patch \ 12 file://use-sh-on-path.patch \
14" 13"
15 14
16SRCREV = "6f936992b8e6208a7838fcf1ec87c5bd3a694a77" 15SRCREV = "5e5409f48b5403d2c6dffd9919b35ad77d6fb7b4"
17 16
18UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)" 17UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
19 18