summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2013-08-13 22:30:04 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-08-16 12:58:30 +0200
commit440d3fd3d62bdb390806a834324c31920c5c409e (patch)
treed7c3ffa013c768e852fb49f2fe41b49092590b79
parent30ba23377ec568a58c43e466582506980b67baad (diff)
downloadmeta-openembedded-440d3fd3d62bdb390806a834324c31920c5c409e.tar.gz
x264: remove
This is now in OE-Core. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-multimedia/x264/x264/don-t-default-to-cortex-a9-with-neon.patch20
-rw-r--r--meta-oe/recipes-multimedia/x264/x264_git.bb47
2 files changed, 0 insertions, 67 deletions
diff --git a/meta-oe/recipes-multimedia/x264/x264/don-t-default-to-cortex-a9-with-neon.patch b/meta-oe/recipes-multimedia/x264/x264/don-t-default-to-cortex-a9-with-neon.patch
deleted file mode 100644
index b844d88fe..000000000
--- a/meta-oe/recipes-multimedia/x264/x264/don-t-default-to-cortex-a9-with-neon.patch
+++ /dev/null
@@ -1,20 +0,0 @@
1-march flag is not in CFLAGS so this will always default to -mcpu=cortex-a8
2-mfpu=neon.
3
4Upstream-Status: Pending
5Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
6
7Index: git/configure
8===================================================================
9--- git.orig/configure 2013-02-10 16:26:40.666343682 +0200
10+++ git/configure 2013-02-10 16:27:49.198341677 +0200
11@@ -703,9 +703,6 @@
12 fi
13
14 if [ $asm = auto -a $ARCH = ARM ] ; then
15- # set flags so neon is built by default
16- echo $CFLAGS | grep -Eq '(-mcpu|-march|-mfpu)' || CFLAGS="$CFLAGS -mcpu=cortex-a8 -mfpu=neon"
17-
18 if cc_check '' '' '__asm__("rev ip, ip");' ; then define HAVE_ARMV6
19 cc_check '' '' '__asm__("movt r0, #0");' && define HAVE_ARMV6T2
20 cc_check '' '' '__asm__("vadd.i16 q0, q0, q0");' && define HAVE_NEON
diff --git a/meta-oe/recipes-multimedia/x264/x264_git.bb b/meta-oe/recipes-multimedia/x264/x264_git.bb
deleted file mode 100644
index c767ffd6b..000000000
--- a/meta-oe/recipes-multimedia/x264/x264_git.bb
+++ /dev/null
@@ -1,47 +0,0 @@
1SUMMARY = "x264 is a free software library and application for encoding video streams into the H.264/MPEG-4 AVC format"
2HOMEPAGE = "http://www.videolan.org/developers/x264.html"
3
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
6
7PR = "r1"
8
9DEPENDS = "yasm-native"
10
11SRC_URI = "git://git.videolan.org/x264.git \
12 file://don-t-default-to-cortex-a9-with-neon.patch \
13"
14SRCREV = "1cffe9f406cc54f4759fc9eeb85598fb8cae66c7"
15
16PV = "r2230+git"
17
18S = "${WORKDIR}/git"
19
20inherit lib_package pkgconfig
21
22X264_DISABLE_ASM = ""
23X264_DISABLE_ASM_armv4 = "--disable-asm"
24X264_DISABLE_ASM_armv5 = "--disable-asm"
25
26EXTRA_OECONF = '--prefix=${prefix} \
27 --host=${HOST_SYS} \
28 --cross-prefix=${TARGET_PREFIX} \
29 --sysroot=${STAGING_DIR_TARGET} \
30 --enable-shared \
31 --enable-static \
32 --disable-lavf \
33 --disable-swscale \
34 ${X264_DISABLE_ASM} \
35 '
36
37do_configure() {
38 ./configure ${EXTRA_OECONF}
39}
40
41# Get rid of -e
42EXTRA_OEMAKE = ""
43AS = "${TARGET_PREFIX}gcc"
44
45do_install() {
46 oe_runmake install DESTDIR=${D}
47}