summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-07-04 13:55:21 -0700
committerKhem Raj <raj.khem@gmail.com>2023-07-04 13:56:19 -0700
commit41123b82dd46c08d9fa3f9c296980ac3f922ded7 (patch)
tree9110012fdea9e2f768513dc5f30fec925988bdd4
parentd79a28bc7f9b99d373d3551f58ada0a39cb5cf19 (diff)
downloadmeta-openembedded-41123b82dd46c08d9fa3f9c296980ac3f922ded7.tar.gz
geos: Upgrade to 3.12.0
Drop upstreamed patch Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-navigation/geos/geos/0001-include-missing-cstdint.patch82
-rw-r--r--meta-oe/recipes-navigation/geos/geos_3.12.0.bb (renamed from meta-oe/recipes-navigation/geos/geos_3.9.4.bb)5
2 files changed, 2 insertions, 85 deletions
diff --git a/meta-oe/recipes-navigation/geos/geos/0001-include-missing-cstdint.patch b/meta-oe/recipes-navigation/geos/geos/0001-include-missing-cstdint.patch
deleted file mode 100644
index 6cfd2e81b..000000000
--- a/meta-oe/recipes-navigation/geos/geos/0001-include-missing-cstdint.patch
+++ /dev/null
@@ -1,82 +0,0 @@
1From 11b9ef265a942cb3fdd373520d0c3fce67d3cdf9 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 26 Jan 2023 18:05:33 -0800
4Subject: [PATCH] include missing <cstdint>
5
6gcc 13 moved some includes around and as a result <cstdint> is no longer transitively included [1]. Explicitly include it for uint{32,64}_t.
7
8[1] https://gcc.gnu.org/gcc-13/porting_to.html#header-dep-changes
9
10Upstream-Status: Backport [https://github.com/kraj/geos/commit/0e8d4368b]
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 include/geos/geomgraph/TopologyLocation.h | 1 +
14 include/geos/io/WKTWriter.h | 1 +
15 include/geos/shape/fractal/HilbertCode.h | 1 +
16 include/geos/shape/fractal/HilbertEncoder.h | 1 +
17 include/geos/shape/fractal/MortonCode.h | 1 +
18 5 files changed, 5 insertions(+)
19
20diff --git a/include/geos/geomgraph/TopologyLocation.h b/include/geos/geomgraph/TopologyLocation.h
21index 4cbbacb3..a3ecd212 100644
22--- a/include/geos/geomgraph/TopologyLocation.h
23+++ b/include/geos/geomgraph/TopologyLocation.h
24@@ -25,6 +25,7 @@
25 #include <geos/inline.h>
26 #include <geos/geom/Location.h>
27
28+#include <cstdint>
29 #include <vector>
30 #include <array>
31 #include <string>
32diff --git a/include/geos/io/WKTWriter.h b/include/geos/io/WKTWriter.h
33index c0af8e71..0d60e975 100644
34--- a/include/geos/io/WKTWriter.h
35+++ b/include/geos/io/WKTWriter.h
36@@ -25,6 +25,7 @@
37
38 #include <string>
39 #include <cctype>
40+#include <cstdint>
41
42 #ifdef _MSC_VER
43 #pragma warning(push)
44diff --git a/include/geos/shape/fractal/HilbertCode.h b/include/geos/shape/fractal/HilbertCode.h
45index 46012efc..beeb28c6 100644
46--- a/include/geos/shape/fractal/HilbertCode.h
47+++ b/include/geos/shape/fractal/HilbertCode.h
48@@ -17,6 +17,7 @@
49
50 #include <geos/export.h>
51 #include <string>
52+#include <cstdint>
53
54 // Forward declarations
55 namespace geos {
56diff --git a/include/geos/shape/fractal/HilbertEncoder.h b/include/geos/shape/fractal/HilbertEncoder.h
57index 61c0010d..0126d3d9 100644
58--- a/include/geos/shape/fractal/HilbertEncoder.h
59+++ b/include/geos/shape/fractal/HilbertEncoder.h
60@@ -16,6 +16,7 @@
61 #pragma once
62
63 #include <geos/export.h>
64+#include <cstdint>
65 #include <string>
66 #include <vector>
67
68diff --git a/include/geos/shape/fractal/MortonCode.h b/include/geos/shape/fractal/MortonCode.h
69index 6743f87c..ad4a42e7 100644
70--- a/include/geos/shape/fractal/MortonCode.h
71+++ b/include/geos/shape/fractal/MortonCode.h
72@@ -17,6 +17,7 @@
73
74 #include <geos/export.h>
75 #include <string>
76+#include <cstdint>
77
78 // Forward declarations
79 namespace geos {
80--
812.39.1
82
diff --git a/meta-oe/recipes-navigation/geos/geos_3.9.4.bb b/meta-oe/recipes-navigation/geos/geos_3.12.0.bb
index 558acd92b..b77f3af2a 100644
--- a/meta-oe/recipes-navigation/geos/geos_3.9.4.bb
+++ b/meta-oe/recipes-navigation/geos/geos_3.12.0.bb
@@ -5,9 +5,8 @@ SECTION = "libs"
5LICENSE = "LGPL-2.1-or-later" 5LICENSE = "LGPL-2.1-or-later"
6LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" 6LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
7 7
8SRC_URI = "http://download.osgeo.org/${BPN}/${BP}.tar.bz2 \ 8SRC_URI = "http://download.osgeo.org/${BPN}/${BP}.tar.bz2"
9 file://0001-include-missing-cstdint.patch" 9SRC_URI[sha256sum] = "d96db96011259178a35555a0f6d6e75a739e52a495a6b2aa5efb3d75390fbc39"
10SRC_URI[sha256sum] = "70dff2530d8cd2dfaeeb91a5014bd17afb1baee8f0e3eb18e44d5b4dbea47b14"
11 10
12inherit autotools pkgconfig binconfig 11inherit autotools pkgconfig binconfig
13 12