summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2018-03-16 20:12:33 +0000
committerArmin Kuster <akuster808@gmail.com>2018-03-16 19:57:03 -0700
commit41038a71396d1edd58558a5b110cafdc7b1b1762 (patch)
tree9e23d7d5858b39c1bd6a115bf7ace2a799422987
parent61914441e8b69e99907a05e190a8d90641b99190 (diff)
downloadmeta-openembedded-41038a71396d1edd58558a5b110cafdc7b1b1762.tar.gz
gperftools: refresh the patches
WARNING: gperftools-2.6.1-r0 do_patch: Some of the context lines in patches were ignored. This can lead to incorrectly applied patches. The context lines in the patches can be updated with devtool: devtool modify <recipe> devtool finish --force-patch-refresh <recipe> <layer_path> Then the updated patches and the source tree (in devtool's workspace) should be reviewed to make sure the patches apply in the correct place and don't introduce duplicate lines (which can, and does happen when some of the context is ignored). Further information: http://lists.openembedded.org/pipermail/openembedded-core/2018-March/148675.html https://bugzilla.yoctoproject.org/show_bug.cgi?id=10450 Details: Applying patch 0001-Support-Atomic-ops-on-clang.patch patching file src/base/atomicops.h Hunk #1 succeeded at 124 with fuzz 2 (offset 6 lines). Now at patch 0001-Support-Atomic-ops-on-clang.patch Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/gperftools/gperftools/0001-Support-Atomic-ops-on-clang.patch16
-rw-r--r--meta-oe/recipes-support/gperftools/gperftools/0001-Use-ucontext_t-instead-of-struct-ucontext.patch8
-rw-r--r--meta-oe/recipes-support/gperftools/gperftools/0001-disbale-heap-checkers-and-debug-allocator-on-musl.patch13
-rw-r--r--meta-oe/recipes-support/gperftools/gperftools/0001-fix-build-with-musl-libc.patch6
-rw-r--r--meta-oe/recipes-support/gperftools/gperftools/0001-include-fcntl.h-for-loff_t-definition.patch6
-rw-r--r--meta-oe/recipes-support/gperftools/gperftools/disable_libunwind_aarch64.patch19
-rw-r--r--meta-oe/recipes-support/gperftools/gperftools/sgidef.patch18
7 files changed, 47 insertions, 39 deletions
diff --git a/meta-oe/recipes-support/gperftools/gperftools/0001-Support-Atomic-ops-on-clang.patch b/meta-oe/recipes-support/gperftools/gperftools/0001-Support-Atomic-ops-on-clang.patch
index e582c0da6..2fd21c278 100644
--- a/meta-oe/recipes-support/gperftools/gperftools/0001-Support-Atomic-ops-on-clang.patch
+++ b/meta-oe/recipes-support/gperftools/gperftools/0001-Support-Atomic-ops-on-clang.patch
@@ -1,4 +1,4 @@
1From ea9f64eb2cdf3be6c4dc65fa1472d854616e43ca Mon Sep 17 00:00:00 2001 1From aa0a63209af6813d87255ec3ab339f2dbbf27d6d Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 6 Mar 2017 13:38:46 -0800 3Date: Mon, 6 Mar 2017 13:38:46 -0800
4Subject: [PATCH] Support Atomic ops on clang 4Subject: [PATCH] Support Atomic ops on clang
@@ -9,25 +9,23 @@ gcc 4.2, here it depends on gcc 4.7 to enable
9the atomics and fails for clang 9the atomics and fails for clang
10 10
11Signed-off-by: Khem Raj <raj.khem@gmail.com> 11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12--- 12
13Upstream-Status: Pending 13Upstream-Status: Pending
14 14
15---
15 src/base/atomicops.h | 2 +- 16 src/base/atomicops.h | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-) 17 1 file changed, 1 insertion(+), 1 deletion(-)
17 18
18diff --git a/src/base/atomicops.h b/src/base/atomicops.h 19diff --git a/src/base/atomicops.h b/src/base/atomicops.h
19index be038f3..f1a21ff 100644 20index dac95be..390733c 100644
20--- a/src/base/atomicops.h 21--- a/src/base/atomicops.h
21+++ b/src/base/atomicops.h 22+++ b/src/base/atomicops.h
22@@ -118,7 +118,7 @@ 23@@ -124,7 +124,7 @@
23 #include "base/atomicops-internals-linuxppc.h" 24 #include "base/atomicops-internals-linuxppc.h"
24 #elif defined(__GNUC__) && defined(__mips__) 25 #elif defined(__GNUC__) && defined(__mips__)
25 #include "base/atomicops-internals-mips.h" 26 #include "base/atomicops-internals-mips.h"
26-#elif defined(__GNUC__) && GCC_VERSION >= 40700 27-#elif defined(__GNUC__) && GCC_VERSION >= 40700
27+#elif defined(__GNUC__) && GCC_VERSION >= 40700 || defined(__clang__) 28+#elif defined(__GNUC__) && GCC_VERSION >= 40700 || defined(__clang__)
28 #include "base/atomicops-internals-gcc.h" 29 #include "base/atomicops-internals-gcc.h"
29 #else 30 #elif defined(__clang__) && CLANG_VERSION >= 30400
30 #error You need to implement atomic operations for this architecture 31 #include "base/atomicops-internals-gcc.h"
31--
322.12.0
33
diff --git a/meta-oe/recipes-support/gperftools/gperftools/0001-Use-ucontext_t-instead-of-struct-ucontext.patch b/meta-oe/recipes-support/gperftools/gperftools/0001-Use-ucontext_t-instead-of-struct-ucontext.patch
index 5bd0b6fa4..b3033621b 100644
--- a/meta-oe/recipes-support/gperftools/gperftools/0001-Use-ucontext_t-instead-of-struct-ucontext.patch
+++ b/meta-oe/recipes-support/gperftools/gperftools/0001-Use-ucontext_t-instead-of-struct-ucontext.patch
@@ -1,4 +1,4 @@
1From 12ac0dc6742e1bcdfaf1842186c9002f0820a5e8 Mon Sep 17 00:00:00 2001 1From 230cd84486145c5bb1d69d4c9a544e00adbcc9b5 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 1 Jul 2017 13:21:21 -0700 3Date: Sat, 1 Jul 2017 13:21:21 -0700
4Subject: [PATCH] Use ucontext_t instead of struct ucontext 4Subject: [PATCH] Use ucontext_t instead of struct ucontext
@@ -6,12 +6,13 @@ Subject: [PATCH] Use ucontext_t instead of struct ucontext
6Newer glibc has dropped the ucontext tag from exposing 6Newer glibc has dropped the ucontext tag from exposing
7 7
8Signed-off-by: Khem Raj <raj.khem@gmail.com> 8Signed-off-by: Khem Raj <raj.khem@gmail.com>
9
9--- 10---
10 src/stacktrace_powerpc-linux-inl.h | 3 +-- 11 src/stacktrace_powerpc-linux-inl.h | 3 +--
11 1 file changed, 1 insertion(+), 2 deletions(-) 12 1 file changed, 1 insertion(+), 2 deletions(-)
12 13
13diff --git a/src/stacktrace_powerpc-linux-inl.h b/src/stacktrace_powerpc-linux-inl.h 14diff --git a/src/stacktrace_powerpc-linux-inl.h b/src/stacktrace_powerpc-linux-inl.h
14index a9bf775..47ff2d7 100644 15index 3b3843b..a301a46 100644
15--- a/src/stacktrace_powerpc-linux-inl.h 16--- a/src/stacktrace_powerpc-linux-inl.h
16+++ b/src/stacktrace_powerpc-linux-inl.h 17+++ b/src/stacktrace_powerpc-linux-inl.h
17@@ -53,7 +53,6 @@ 18@@ -53,7 +53,6 @@
@@ -31,6 +32,3 @@ index a9bf775..47ff2d7 100644
31 // We don't care about the rest, since IP value is at 'uc' field.A 32 // We don't care about the rest, since IP value is at 'uc' field.A
32 } *sigframe = reinterpret_cast<rt_signal_frame_32*>(current); 33 } *sigframe = reinterpret_cast<rt_signal_frame_32*>(current);
33 result[n] = (void*) sigframe->uc.uc_mcontext.uc_regs->gregs[PT_NIP]; 34 result[n] = (void*) sigframe->uc.uc_mcontext.uc_regs->gregs[PT_NIP];
34--
352.13.2
36
diff --git a/meta-oe/recipes-support/gperftools/gperftools/0001-disbale-heap-checkers-and-debug-allocator-on-musl.patch b/meta-oe/recipes-support/gperftools/gperftools/0001-disbale-heap-checkers-and-debug-allocator-on-musl.patch
index 99127e11a..ab3ceb964 100644
--- a/meta-oe/recipes-support/gperftools/gperftools/0001-disbale-heap-checkers-and-debug-allocator-on-musl.patch
+++ b/meta-oe/recipes-support/gperftools/gperftools/0001-disbale-heap-checkers-and-debug-allocator-on-musl.patch
@@ -1,19 +1,20 @@
1From b5961f17e9d7f2bc44da611b3e4b27c8a641fc72 Mon Sep 17 00:00:00 2001 1From 06605158852f9364519391fa11070ba5ec4303e9 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 2 Sep 2017 08:07:17 -0700 3Date: Sat, 2 Sep 2017 08:07:17 -0700
4Subject: [PATCH] disbale heap checkers and debug allocator on musl 4Subject: [PATCH] disbale heap checkers and debug allocator on musl
5 5
6Signed-off-by: Khem Raj <raj.khem@gmail.com> 6Signed-off-by: Khem Raj <raj.khem@gmail.com>
7--- 7
8Upstream-Status: Pending 8Upstream-Status: Pending
9 9
10---
10 configure.ac | 2 ++ 11 configure.ac | 2 ++
11 1 file changed, 2 insertions(+) 12 1 file changed, 2 insertions(+)
12 13
13Index: git/configure.ac 14diff --git a/configure.ac b/configure.ac
14=================================================================== 15index 70b49a3..8154c5c 100644
15--- git.orig/configure.ac 16--- a/configure.ac
16+++ git/configure.ac 17+++ b/configure.ac
17@@ -51,6 +51,8 @@ case "$host" in 18@@ -51,6 +51,8 @@ case "$host" in
18 *-cygwin*) default_enable_heap_checker=no; default_enable_cpu_profiler=no;; 19 *-cygwin*) default_enable_heap_checker=no; default_enable_cpu_profiler=no;;
19 *-freebsd*) default_enable_heap_checker=no;; 20 *-freebsd*) default_enable_heap_checker=no;;
diff --git a/meta-oe/recipes-support/gperftools/gperftools/0001-fix-build-with-musl-libc.patch b/meta-oe/recipes-support/gperftools/gperftools/0001-fix-build-with-musl-libc.patch
index 78621c7fe..0a72ff27c 100644
--- a/meta-oe/recipes-support/gperftools/gperftools/0001-fix-build-with-musl-libc.patch
+++ b/meta-oe/recipes-support/gperftools/gperftools/0001-fix-build-with-musl-libc.patch
@@ -1,4 +1,4 @@
1From 157914941bd38f1a38bb6bd7294ca6c2bc1b8dcb Mon Sep 17 00:00:00 2001 1From 034e7da08c3fbffcba8cf8d4e24a71a16558db5a Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 16 Jul 2017 15:51:28 -0700 3Date: Sun, 16 Jul 2017 15:51:28 -0700
4Subject: [PATCH] fix build with musl libc 4Subject: [PATCH] fix build with musl libc
@@ -6,6 +6,7 @@ Subject: [PATCH] fix build with musl libc
6Patch from https://github.com/gperftools/gperftools/pull/765/ 6Patch from https://github.com/gperftools/gperftools/pull/765/
7 7
8Signed-off-by: Khem Raj <raj.khem@gmail.com> 8Signed-off-by: Khem Raj <raj.khem@gmail.com>
9
9--- 10---
10 configure.ac | 1 + 11 configure.ac | 1 +
11 src/malloc_hook_mmap_linux.h | 8 ++++++-- 12 src/malloc_hook_mmap_linux.h | 8 ++++++--
@@ -56,6 +57,3 @@ index 79ac4e3..d444635 100755
56 // libc's version: 57 // libc's version:
57 extern "C" void* __sbrk(ptrdiff_t increment); 58 extern "C" void* __sbrk(ptrdiff_t increment);
58 59
59--
602.13.3
61
diff --git a/meta-oe/recipes-support/gperftools/gperftools/0001-include-fcntl.h-for-loff_t-definition.patch b/meta-oe/recipes-support/gperftools/gperftools/0001-include-fcntl.h-for-loff_t-definition.patch
index 667008a5b..4c63e73b3 100644
--- a/meta-oe/recipes-support/gperftools/gperftools/0001-include-fcntl.h-for-loff_t-definition.patch
+++ b/meta-oe/recipes-support/gperftools/gperftools/0001-include-fcntl.h-for-loff_t-definition.patch
@@ -1,4 +1,4 @@
1From 04ea8e001501931f4dbf20288aca78469617b08a Mon Sep 17 00:00:00 2001 1From a16a73f0819d26219ee83cd98eea82786d7c1755 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 16 Jul 2017 19:28:17 -0700 3Date: Sun, 16 Jul 2017 19:28:17 -0700
4Subject: [PATCH] include fcntl.h for loff_t definition 4Subject: [PATCH] include fcntl.h for loff_t definition
@@ -7,6 +7,7 @@ Fixes
7linux_syscall_support.h:2641:26: error: 'loff_t' has not been declared 7linux_syscall_support.h:2641:26: error: 'loff_t' has not been declared
8 8
9Signed-off-by: Khem Raj <raj.khem@gmail.com> 9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10
10--- 11---
11 src/base/linux_syscall_support.h | 1 + 12 src/base/linux_syscall_support.h | 1 +
12 1 file changed, 1 insertion(+) 13 1 file changed, 1 insertion(+)
@@ -23,6 +24,3 @@ index 85347a2..70431ca 100644
23 24
24 #ifdef __mips__ 25 #ifdef __mips__
25 /* Include definitions of the ABI currently in use. */ 26 /* Include definitions of the ABI currently in use. */
26--
272.13.3
28
diff --git a/meta-oe/recipes-support/gperftools/gperftools/disable_libunwind_aarch64.patch b/meta-oe/recipes-support/gperftools/gperftools/disable_libunwind_aarch64.patch
index f2647404b..c3c578418 100644
--- a/meta-oe/recipes-support/gperftools/gperftools/disable_libunwind_aarch64.patch
+++ b/meta-oe/recipes-support/gperftools/gperftools/disable_libunwind_aarch64.patch
@@ -1,15 +1,22 @@
1Disable libunwind on aarch64 1From 564f800e3e24647c095f7a321bf3ebdccfbf762d Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 2 Sep 2017 12:02:04 -0700
4Subject: [PATCH] Disable libunwind on aarch64
2 5
3Fixes hangs when using libtcmalloc.so 6Fixes hangs when using libtcmalloc.so
4 7
5Upstream-Status: Pending 8Upstream-Status: Pending
6Signed-off-by: Khem Raj <raj.khem@gmail.com> 9Signed-off-by: Khem Raj <raj.khem@gmail.com>
7 10
8Index: git/configure.ac 11---
9=================================================================== 12 configure.ac | 5 +++++
10--- git.orig/configure.ac 13 1 file changed, 5 insertions(+)
11+++ git/configure.ac 14
12@@ -69,6 +69,11 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM(, [re 15diff --git a/configure.ac b/configure.ac
16index 8154c5c..063b260 100644
17--- a/configure.ac
18+++ b/configure.ac
19@@ -69,6 +69,11 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM(, [return __PPC64__])],
13 [default_enable_libunwind=yes 20 [default_enable_libunwind=yes
14 default_tcmalloc_pagesize=8]) 21 default_tcmalloc_pagesize=8])
15 22
diff --git a/meta-oe/recipes-support/gperftools/gperftools/sgidef.patch b/meta-oe/recipes-support/gperftools/gperftools/sgidef.patch
index 7e1a23bf6..10274a6de 100644
--- a/meta-oe/recipes-support/gperftools/gperftools/sgidef.patch
+++ b/meta-oe/recipes-support/gperftools/gperftools/sgidef.patch
@@ -1,11 +1,19 @@
1sgidef.h does not exist on musl and its not needed to compile 1From 259b420444c52463795b4b582a2ab7511149eea7 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 16 Oct 2017 21:26:40 -0700
4Subject: [PATCH] sgidef.h does not exist on musl and its not needed to compile
2 5
3Signed-off-by: Khem Raj <raj.khem@gmail.com> 6Signed-off-by: Khem Raj <raj.khem@gmail.com>
4Upstream-Status: Pending 7Upstream-Status: Pending
5Index: git/src/base/linux_syscall_support.h 8
6=================================================================== 9---
7--- git.orig/src/base/linux_syscall_support.h 10 src/base/linux_syscall_support.h | 2 +-
8+++ git/src/base/linux_syscall_support.h 11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/src/base/linux_syscall_support.h b/src/base/linux_syscall_support.h
14index 70431ca..b23ca59 100644
15--- a/src/base/linux_syscall_support.h
16+++ b/src/base/linux_syscall_support.h
9@@ -164,7 +164,7 @@ extern "C" { 17@@ -164,7 +164,7 @@ extern "C" {
10 #include <endian.h> 18 #include <endian.h>
11 #include <fcntl.h> 19 #include <fcntl.h>