summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRandy MacLeod <randy.macleod@windriver.com>2022-03-21 19:22:01 -0700
committerKhem Raj <raj.khem@gmail.com>2022-03-24 09:45:25 -0700
commit40ae8ca3f19939749083b389303db15e1c7135c4 (patch)
treebd8b6731078d5ced6670a245d3075c2605808a8b
parentfd8ccc80fb08b2aa7fbdb837d14094cb2237d71b (diff)
downloadmeta-openembedded-40ae8ca3f19939749083b389303db15e1c7135c4.tar.gz
pv: update from 1.6.6 to 1.6.20
Add the HOMEPAGE which isn't availabe via https and change the SRC_URI to use https. Drop the obsolete SRC_URI md5sum. Add ptest support. cksum is needed by the tests and it is currently not build for busybox so add coreutils as a ptest dependency. Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/pv/pv/run-ptest7
-rw-r--r--meta-oe/recipes-support/pv/pv_1.6.20.bb27
-rw-r--r--meta-oe/recipes-support/pv/pv_1.6.6.bb16
3 files changed, 34 insertions, 16 deletions
diff --git a/meta-oe/recipes-support/pv/pv/run-ptest b/meta-oe/recipes-support/pv/pv/run-ptest
new file mode 100644
index 000000000..3f5956f4c
--- /dev/null
+++ b/meta-oe/recipes-support/pv/pv/run-ptest
@@ -0,0 +1,7 @@
1#!/bin/sh
2
3rm -rf tests.log
4sh -e run-test.sh pv . > tests.log 2>&1
5sed -e 's|\(.*\):.*OK|PASS: \1|' \
6 -e 's|\(.*\):.*FAILED|FAIL: \1|' \
7 tests.log
diff --git a/meta-oe/recipes-support/pv/pv_1.6.20.bb b/meta-oe/recipes-support/pv/pv_1.6.20.bb
new file mode 100644
index 000000000..867a621d1
--- /dev/null
+++ b/meta-oe/recipes-support/pv/pv_1.6.20.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Terminal-based tool for monitoring the progress of data through a pipeline"
2HOMEPAGE = "http://www.ivarch.com/programs/pv.shtml"
3
4LICENSE = "Artistic-2.0"
5LIC_FILES_CHKSUM = "file://doc/COPYING;md5=9c50db2589ee3ef10a9b7b2e50ce1d02"
6
7SRC_URI = "https://www.ivarch.com/programs/sources/${BP}.tar.bz2 \
8 file://run-ptest \
9"
10SRC_URI[sha256sum] = "e831951eff0718fba9b1ef286128773b9d0e723e1fbfae88d5a3188814fdc603"
11
12UPSTREAM_CHECK_URI = "http://www.ivarch.com/programs/pv.shtml"
13UPSTREAM_CHECK_REGEX = "pv-(?P<pver>\d+(\.\d+)+).tar.bz2"
14
15inherit autotools ptest
16
17LDEMULATION:mipsarchn32 = "${@bb.utils.contains('TUNE_FEATURES', 'bigendian', 'elf32btsmipn32', 'elf32ltsmipn32', d)}"
18export LDEMULATION
19
20RDEPENDS:${PN}-ptest = "coreutils"
21
22do_install_ptest() {
23 install -d ${D}${PTEST_PATH}/tests
24 cp -r ${S}/tests/* ${D}${PTEST_PATH}/tests
25 cp -r ${S}/autoconf/scripts/run-test.sh ${D}${PTEST_PATH}
26 # sed -i -e 's@\$SRCDIR/@./@g' ${D}${PTEST_PATH}/run-ptest
27}
diff --git a/meta-oe/recipes-support/pv/pv_1.6.6.bb b/meta-oe/recipes-support/pv/pv_1.6.6.bb
deleted file mode 100644
index 244d14001..000000000
--- a/meta-oe/recipes-support/pv/pv_1.6.6.bb
+++ /dev/null
@@ -1,16 +0,0 @@
1SUMMARY = "Terminal-based tool for monitoring the progress of data through a pipeline"
2
3LICENSE = "Artistic-2.0"
4LIC_FILES_CHKSUM = "file://doc/COPYING;md5=9c50db2589ee3ef10a9b7b2e50ce1d02"
5
6SRC_URI = "http://www.ivarch.com/programs/sources/${BP}.tar.bz2"
7SRC_URI[md5sum] = "ff3564fddcc2b9bd4a9c1d143aba4b4c"
8SRC_URI[sha256sum] = "608ef935f7a377e1439c181c4fc188d247da10d51a19ef79bcdee5043b0973f1"
9
10UPSTREAM_CHECK_URI = "http://www.ivarch.com/programs/pv.shtml"
11UPSTREAM_CHECK_REGEX = "pv-(?P<pver>\d+(\.\d+)+).tar.bz2"
12
13inherit autotools
14
15LDEMULATION:mipsarchn32 = "${@bb.utils.contains('TUNE_FEATURES', 'bigendian', 'elf32btsmipn32', 'elf32ltsmipn32', d)}"
16export LDEMULATION