summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2025-04-09 15:01:13 -0700
committerKhem Raj <raj.khem@gmail.com>2025-04-10 18:39:31 -0700
commit4085ac5975f21874012b38c6952ab75af5deea58 (patch)
treec32b94c2048cf6c9033afbcdfc23545b48f6ab1c
parentcbe22302dfbe0659c59db9abddf3d7a3264c66c4 (diff)
downloadmeta-openembedded-4085ac5975f21874012b38c6952ab75af5deea58.tar.gz
python3-gpt-image: Use PEP-517 build backend
Switch to using ptest-python-pytest and add it to PTESTS_FAST_META_PYTHON Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/conf/include/ptest-packagelists-meta-python.inc1
-rwxr-xr-xmeta-python/recipes-extended/python3-gpt-image/python3-gpt-image/run-ptest3
-rw-r--r--meta-python/recipes-extended/python3-gpt-image/python3-gpt-image_0.9.0.bb15
3 files changed, 2 insertions, 17 deletions
diff --git a/meta-python/conf/include/ptest-packagelists-meta-python.inc b/meta-python/conf/include/ptest-packagelists-meta-python.inc
index bdb4482dc5..03b4d685f1 100644
--- a/meta-python/conf/include/ptest-packagelists-meta-python.inc
+++ b/meta-python/conf/include/ptest-packagelists-meta-python.inc
@@ -31,6 +31,7 @@ PTESTS_FAST_META_PYTHON = "\
31 python3-geojson \ 31 python3-geojson \
32 python3-google-auth-oauthlib \ 32 python3-google-auth-oauthlib \
33 python3-gpiod \ 33 python3-gpiod \
34 python3-gpt-image \
34 python3-gunicorn \ 35 python3-gunicorn \
35 python3-html2text \ 36 python3-html2text \
36 python3-httptools \ 37 python3-httptools \
diff --git a/meta-python/recipes-extended/python3-gpt-image/python3-gpt-image/run-ptest b/meta-python/recipes-extended/python3-gpt-image/python3-gpt-image/run-ptest
deleted file mode 100755
index b63c4de0d9..0000000000
--- a/meta-python/recipes-extended/python3-gpt-image/python3-gpt-image/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@
1#!/bin/sh
2
3pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
diff --git a/meta-python/recipes-extended/python3-gpt-image/python3-gpt-image_0.9.0.bb b/meta-python/recipes-extended/python3-gpt-image/python3-gpt-image_0.9.0.bb
index 01e8091f6f..941d92f55b 100644
--- a/meta-python/recipes-extended/python3-gpt-image/python3-gpt-image_0.9.0.bb
+++ b/meta-python/recipes-extended/python3-gpt-image/python3-gpt-image_0.9.0.bb
@@ -5,25 +5,12 @@ SUMMARY = "GPT Image (pure python)"
5LICENSE = "MIT" 5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=db5f8de88d13d0917db21293d0e82e1d" 6LIC_FILES_CHKSUM = "file://LICENSE;md5=db5f8de88d13d0917db21293d0e82e1d"
7 7
8SRC_URI += "\
9 file://run-ptest \
10"
11
12DEPENDS += "python3-pip" 8DEPENDS += "python3-pip"
13 9
14PYPI_PACKAGE = "gpt_image" 10PYPI_PACKAGE = "gpt_image"
15SRC_URI[sha256sum] = "c06d8efc7cf8d6f3954c1c3d8544f494aa95da37fe04e38a9699ad3f57455f7e" 11SRC_URI[sha256sum] = "c06d8efc7cf8d6f3954c1c3d8544f494aa95da37fe04e38a9699ad3f57455f7e"
16 12
17inherit pypi setuptools3 python3native ptest 13inherit pypi python3native python_setuptools_build_meta ptest-python-pytest
18
19do_install_ptest() {
20 install -d ${D}${PTEST_PATH}/tests
21 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
22}
23
24RDEPENDS:${PN}-ptest += " \
25 python3-pytest \
26"
27 14
28do_install:append() { 15do_install:append() {
29 rm -fr ${D}${libdir}/python*/site-packages/gpt-image/__pycache__ 16 rm -fr ${D}${libdir}/python*/site-packages/gpt-image/__pycache__