summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-11-09 21:05:57 +0100
committerKhem Raj <raj.khem@gmail.com>2022-11-10 10:41:35 -0800
commit4035dfc557c113f528322669959330ba9fe3a9d4 (patch)
treed0e4a5cf8c846ab470376e8a676cc4b7e5dd4044
parentd04444509a220fcb61496d7e64f3ba09c647543b (diff)
downloadmeta-openembedded-4035dfc557c113f528322669959330ba9fe3a9d4.tar.gz
frr: add a patch to correctly check presence of python from pkg-config
Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-protocols/frr/frr/0001-m4-ax_python.m4-check-for-python-x.y-emded.pc-not-py.patch28
-rw-r--r--meta-networking/recipes-protocols/frr/frr_8.3.1.bb3
2 files changed, 30 insertions, 1 deletions
diff --git a/meta-networking/recipes-protocols/frr/frr/0001-m4-ax_python.m4-check-for-python-x.y-emded.pc-not-py.patch b/meta-networking/recipes-protocols/frr/frr/0001-m4-ax_python.m4-check-for-python-x.y-emded.pc-not-py.patch
new file mode 100644
index 000000000..9e5cfd8f5
--- /dev/null
+++ b/meta-networking/recipes-protocols/frr/frr/0001-m4-ax_python.m4-check-for-python-x.y-emded.pc-not-py.patch
@@ -0,0 +1,28 @@
1From 6a2984718d7c47612b07be46d663e7b5e5b7c57d Mon Sep 17 00:00:00 2001
2From: Alexander Kanavin <alex@linutronix.de>
3Date: Wed, 9 Nov 2022 20:24:45 +0100
4Subject: [PATCH] m4/ax_python.m4: check for python-x.y-emded.pc, not
5 python-x.y.pc
6
7Only the embed version includes necessary linker flags to link
8with libpython.
9
10Upstream-Status: Submitted [https://github.com/FRRouting/frr/pull/12298]
11Signed-off-by: Alexander Kanavin <alex@linutronix.de>
12---
13 m4/ax_python.m4 | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-)
15
16diff --git a/m4/ax_python.m4 b/m4/ax_python.m4
17index 91d12b99b..f5e603b96 100644
18--- a/m4/ax_python.m4
19+++ b/m4/ax_python.m4
20@@ -206,7 +206,7 @@ AC_REQUIRE([PKG_PROG_PKG_CONFIG])dnl
21 AC_MSG_CHECKING([whether pkg-config python-${tryver} is available])
22 unset PYTHON_CFLAGS
23 unset PYTHON_LIBS
24- pkg="python-${tryver}"
25+ pkg="python-${tryver}-embed"
26 pkg="${pkg%-}"
27 _PKG_CONFIG([PYTHON_CFLAGS], [cflags], [${pkg}])
28 _PKG_CONFIG([PYTHON_LIBS], [libs], [${pkg}])
diff --git a/meta-networking/recipes-protocols/frr/frr_8.3.1.bb b/meta-networking/recipes-protocols/frr/frr_8.3.1.bb
index 1abea6345..67d50e3ed 100644
--- a/meta-networking/recipes-protocols/frr/frr_8.3.1.bb
+++ b/meta-networking/recipes-protocols/frr/frr_8.3.1.bb
@@ -15,7 +15,8 @@ SRC_URI = "git://github.com/FRRouting/frr.git;protocol=https;branch=stable/8.3 \
15 file://0001-bgpd-avoid-notify-race-between-io-and-main-pthreads.patch \ 15 file://0001-bgpd-avoid-notify-race-between-io-and-main-pthreads.patch \
16 file://0001-bgpd-Make-sure-hdr-length-is-at-a-minimum-of-what-is.patch \ 16 file://0001-bgpd-Make-sure-hdr-length-is-at-a-minimum-of-what-is.patch \
17 file://frr.pam \ 17 file://frr.pam \
18 " 18 file://0001-m4-ax_python.m4-check-for-python-x.y-emded.pc-not-py.patch \
19 "
19 20
20SRCREV = "a74f7a9ad9623e6f9654fe4a7177e5da0b194828" 21SRCREV = "a74f7a9ad9623e6f9654fe4a7177e5da0b194828"
21 22