diff options
author | Andreas Müller <schnitzeltony@googlemail.com> | 2016-09-09 00:36:22 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-09-15 10:22:47 +0200 |
commit | 3e9313cf257e6bb1bc9139df90dcf6ed7233458e (patch) | |
tree | 408c987c36e9bbd0f3fb27ec40d421d820b7007f | |
parent | d70ccece723ca735f6c333e5ed4b91ae82e13a4e (diff) | |
download | meta-openembedded-3e9313cf257e6bb1bc9139df90dcf6ed7233458e.tar.gz |
geany-plugins: unblacklist / fix known bugs / update to 1.28
* The python LICENSE_DEFAULT snippet was stolen at [1]
* disable plugins not builing due to missing- or not properly detected
dependencies
[1] https://github.com/MentorEmbedded/meta-mentor/pull/843/commits/d85285792fad41d80e7862cc276dfc22ddb06fde
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-oe/recipes-devtools/geany/geany-plugins_1.28.bb (renamed from meta-oe/recipes-devtools/geany/geany-plugins_1.27.bb) | 101 |
1 files changed, 71 insertions, 30 deletions
diff --git a/meta-oe/recipes-devtools/geany/geany-plugins_1.27.bb b/meta-oe/recipes-devtools/geany/geany-plugins_1.28.bb index 2347af18f7..781287a909 100644 --- a/meta-oe/recipes-devtools/geany/geany-plugins_1.27.bb +++ b/meta-oe/recipes-devtools/geany/geany-plugins_1.28.bb | |||
@@ -1,15 +1,32 @@ | |||
1 | DESCRIPTION = "A fast and lightweight IDE" | 1 | DESCRIPTION = "A fast and lightweight IDE" |
2 | HOMEPAGE = "http://plugins.geany.org/" | 2 | HOMEPAGE = "http://plugins.geany.org/" |
3 | # majority's default | ||
4 | LICENSE = "GPLv2" | ||
5 | 3 | ||
6 | DEPENDS = "geany lua libxml2 libsoup-2.4 vte enchant intltool-native libassuan gpgme" | 4 | LICENSE_DEFAULT = "GPLv2" |
5 | LICENSE = "${LICENSE_DEFAULT} & BSD-2-Clause & GPLv3" | ||
6 | |||
7 | python () { | ||
8 | for plugin in d.getVar('PLUGINS', True).split(): | ||
9 | if 'LICENSE_%s' % plugin not in d: | ||
10 | d.setVar('LICENSE_' + plugin, '${LICENSE_DEFAULT}') | ||
11 | } | ||
12 | |||
13 | DEPENDS = " \ | ||
14 | geany \ | ||
15 | libxml2 \ | ||
16 | libsoup-2.4 \ | ||
17 | enchant \ | ||
18 | intltool-native \ | ||
19 | libassuan \ | ||
20 | gpgme \ | ||
21 | vte9 \ | ||
22 | libgit2 \ | ||
23 | " | ||
7 | 24 | ||
8 | inherit autotools pkgconfig gtk-icon-cache | 25 | inherit autotools pkgconfig gtk-icon-cache |
9 | 26 | ||
10 | SRC_URI = "http://plugins.geany.org/${PN}/${PN}-${PV}.tar.bz2" | 27 | SRC_URI = "http://plugins.geany.org/${PN}/${PN}-${PV}.tar.bz2" |
11 | SRC_URI[md5sum] = "31e4aa4b771a4ff8ccfd74efe7ba7b44" | 28 | SRC_URI[md5sum] = "54ad042b6f91ff8e7a497c22faa2db4b" |
12 | SRC_URI[sha256sum] = "03195a0b7a361ddb2ee4138f46fa87b6d9b9801ff00657456ab9c8b8908c0ce0" | 29 | SRC_URI[sha256sum] = "b13471e0a4cb76d04a96bb21c965087b50c16390edee0c6b3bbd920d8ac17745" |
13 | 30 | ||
14 | do_configure_prepend() { | 31 | do_configure_prepend() { |
15 | rm -f ${S}/build/cache/glib-gettext.m4 | 32 | rm -f ${S}/build/cache/glib-gettext.m4 |
@@ -54,11 +71,13 @@ LIC_FILES_CHKSUM += "file://defineformat/COPYING;md5=751419260aa954499f7abaabaa8 | |||
54 | FILES_${PN}-defineformat = "${libdir}/geany/defineformat.so" | 71 | FILES_${PN}-defineformat = "${libdir}/geany/defineformat.so" |
55 | RDEPENDS_${PN}-defineformat = "${PN}" | 72 | RDEPENDS_${PN}-defineformat = "${PN}" |
56 | 73 | ||
57 | PLUGINS += "${PN}-devhelp" | 74 | # no gnome devhelp in some common layer |
58 | LIC_FILES_CHKSUM += "file://devhelp/COPYING;md5=d32239bcb673463ab874e80d47fae504" | 75 | EXTRA_OECONF += "--disable-devhelp" |
59 | LICENSE_${PN}-devhelp = "GPLv3" | 76 | #PLUGINS += "${PN}-devhelp" |
60 | FILES_${PN}-devhelp = "${libdir}/geany/devhelp.so" | 77 | #LIC_FILES_CHKSUM += "file://devhelp/COPYING;md5=d32239bcb673463ab874e80d47fae504" |
61 | RDEPENDS_${PN}-devhelp = "${PN}" | 78 | #LICENSE_${PN}-devhelp = "GPLv3" |
79 | #FILES_${PN}-devhelp = "${libdir}/geany/devhelp.so" | ||
80 | #RDEPENDS_${PN}-devhelp = "${PN}" | ||
62 | 81 | ||
63 | PLUGINS += "${PN}-geanyctags" | 82 | PLUGINS += "${PN}-geanyctags" |
64 | LIC_FILES_CHKSUM += "file://geanyctags/COPYING;md5=c107cf754550e65755c42985a5d4e9c9" | 83 | LIC_FILES_CHKSUM += "file://geanyctags/COPYING;md5=c107cf754550e65755c42985a5d4e9c9" |
@@ -91,10 +110,12 @@ LIC_FILES_CHKSUM += "file://geanylipsum/COPYING;md5=4325afd396febcb659c36b495331 | |||
91 | FILES_${PN}-geanylipsum = "${libdir}/geany/geanylipsum.so" | 110 | FILES_${PN}-geanylipsum = "${libdir}/geany/geanylipsum.so" |
92 | RDEPENDS_${PN}-geanylipsum = "${PN}" | 111 | RDEPENDS_${PN}-geanylipsum = "${PN}" |
93 | 112 | ||
94 | PLUGINS += "${PN}-geanylua" | 113 | # no lua: max supported version is 5.2 |
95 | LIC_FILES_CHKSUM += "file://geanylua/COPYING;md5=4325afd396febcb659c36b49533135d4" | 114 | EXTRA_OECONF += "--disable-geanylua" |
96 | FILES_${PN}-geanylua = "${libdir}/geany/geanylua.so ${libdir}/${PN}/geanylua/*.so" | 115 | #PLUGINS += "${PN}-geanylua" |
97 | RDEPENDS_${PN}-geanylua = "${PN}" | 116 | #LIC_FILES_CHKSUM += "file://geanylua/COPYING;md5=4325afd396febcb659c36b49533135d4" |
117 | #FILES_${PN}-geanylua = "${libdir}/geany/geanylua.so ${libdir}/${PN}/geanylua/*.so" | ||
118 | #RDEPENDS_${PN}-geanylua = "${PN}" | ||
98 | 119 | ||
99 | PLUGINS += "${PN}-geanymacro" | 120 | PLUGINS += "${PN}-geanymacro" |
100 | LIC_FILES_CHKSUM += "file://geanymacro/COPYING;md5=c107cf754550e65755c42985a5d4e9c9" | 121 | LIC_FILES_CHKSUM += "file://geanymacro/COPYING;md5=c107cf754550e65755c42985a5d4e9c9" |
@@ -122,10 +143,12 @@ LICENSE_${PN}-geanyprj = "GPLv3" | |||
122 | FILES_${PN}-geanyprj = "${libdir}/geany/geanyprj.so" | 143 | FILES_${PN}-geanyprj = "${libdir}/geany/geanyprj.so" |
123 | RDEPENDS_${PN}-geanyprj = "${PN}" | 144 | RDEPENDS_${PN}-geanyprj = "${PN}" |
124 | 145 | ||
125 | PLUGINS += "${PN}-geanysendmail" | 146 | # no gnome pygtk |
126 | LIC_FILES_CHKSUM += "file://geanysendmail/COPYING;md5=c107cf754550e65755c42985a5d4e9c9" | 147 | EXTRA_OECONF += "--disable-geanypy" |
127 | FILES_${PN}-geanysendmail = "${libdir}/geany/geanysendmail.so" | 148 | #PLUGINS += "${PN}-geanypy" |
128 | RDEPENDS_${PN}-geanysendmail = "${PN}" | 149 | #LIC_FILES_CHKSUM += "file://geanypy/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
150 | #FILES_${PN}-geanypy = "${libdir}/geany/geanypy.so" | ||
151 | #RDEPENDS_${PN}-geanypy = "${PN}" | ||
129 | 152 | ||
130 | PLUGINS += "${PN}-geanyvc" | 153 | PLUGINS += "${PN}-geanyvc" |
131 | LIC_FILES_CHKSUM += "file://geanyvc/COPYING;md5=c107cf754550e65755c42985a5d4e9c9" | 154 | LIC_FILES_CHKSUM += "file://geanyvc/COPYING;md5=c107cf754550e65755c42985a5d4e9c9" |
@@ -137,11 +160,24 @@ LIC_FILES_CHKSUM += "file://geniuspaste/COPYING;md5=bfc203269f8862ebfc1198cdc809 | |||
137 | FILES_${PN}-geniuspaste = "${libdir}/geany/geniuspaste.so ${datadir}/${PN}/geniuspaste" | 160 | FILES_${PN}-geniuspaste = "${libdir}/geany/geniuspaste.so ${datadir}/${PN}/geniuspaste" |
138 | RDEPENDS_${PN}-geniuspaste = "${PN}" | 161 | RDEPENDS_${PN}-geniuspaste = "${PN}" |
139 | 162 | ||
163 | PLUGINS += "${PN}-git-changebar" | ||
164 | LIC_FILES_CHKSUM += "file://git-changebar/COPYING;md5=d32239bcb673463ab874e80d47fae504" | ||
165 | LICENSE_${PN}-git-changebar = "GPLv3" | ||
166 | FILES_${PN}-git-changebar = "${libdir}/geany/git-changebar.so" | ||
167 | RDEPENDS_${PN}-git-changebar = "${PN}" | ||
168 | |||
140 | PLUGINS += "${PN}-lineoperations" | 169 | PLUGINS += "${PN}-lineoperations" |
141 | LIC_FILES_CHKSUM += "file://lineoperations/COPYING;md5=c107cf754550e65755c42985a5d4e9c9" | 170 | LIC_FILES_CHKSUM += "file://lineoperations/COPYING;md5=c107cf754550e65755c42985a5d4e9c9" |
142 | FILES_${PN}-lineoperations = "${libdir}/geany/lineoperations.so" | 171 | FILES_${PN}-lineoperations = "${libdir}/geany/lineoperations.so" |
143 | RDEPENDS_${PN}-lineoperations = "${PN}" | 172 | RDEPENDS_${PN}-lineoperations = "${PN}" |
144 | 173 | ||
174 | # no markdown - avoid floating dependencies | ||
175 | EXTRA_OECONF += " --disable-peg-markdown" | ||
176 | #PLUGINS += "${PN}-markdown" | ||
177 | #LIC_FILES_CHKSUM += "file://markdown/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" | ||
178 | #FILES_${PN}-markdown = "${libdir}/geany/markdown.so" | ||
179 | #RDEPENDS_${PN}-markdown = "${PN}" | ||
180 | |||
145 | PLUGINS += "${PN}-multiterm" | 181 | PLUGINS += "${PN}-multiterm" |
146 | LIC_FILES_CHKSUM += "file://multiterm/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" | 182 | LIC_FILES_CHKSUM += "file://multiterm/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
147 | FILES_${PN}-multiterm = "${libdir}/geany/multiterm.so" | 183 | FILES_${PN}-multiterm = "${libdir}/geany/multiterm.so" |
@@ -174,16 +210,21 @@ LIC_FILES_CHKSUM += "file://projectorganizer/COPYING;md5=c107cf754550e65755c4298 | |||
174 | FILES_${PN}-projectorganizer = "${libdir}/geany/projectorganizer.so" | 210 | FILES_${PN}-projectorganizer = "${libdir}/geany/projectorganizer.so" |
175 | RDEPENDS_${PN}-projectorganizer = "${PN}" | 211 | RDEPENDS_${PN}-projectorganizer = "${PN}" |
176 | 212 | ||
177 | PLUGINS += "${PN}-shiftcolumn" | ||
178 | LIC_FILES_CHKSUM += "file://shiftcolumn/COPYING;md5=751419260aa954499f7abaabaa882bbe" | ||
179 | FILES_${PN}-shiftcolumn = "${libdir}/geany/shiftcolumn.so" | ||
180 | RDEPENDS_${PN}-shiftcolumn = "${PN}" | ||
181 | |||
182 | PLUGINS += "${PN}-scope" | 213 | PLUGINS += "${PN}-scope" |
183 | LIC_FILES_CHKSUM += "file://scope/COPYING;md5=c107cf754550e65755c42985a5d4e9c9" | 214 | LIC_FILES_CHKSUM += "file://scope/COPYING;md5=c107cf754550e65755c42985a5d4e9c9" |
184 | FILES_${PN}-scope = "${libdir}/geany/scope.so" | 215 | FILES_${PN}-scope = "${libdir}/geany/scope.so" |
185 | RDEPENDS_${PN}-scope = "${PN}" | 216 | RDEPENDS_${PN}-scope = "${PN}" |
186 | 217 | ||
218 | PLUGINS += "${PN}-sendmail" | ||
219 | LIC_FILES_CHKSUM += "file://sendmail/COPYING;md5=c107cf754550e65755c42985a5d4e9c9" | ||
220 | FILES_${PN}-sendmail = "${libdir}/geany/sendmail.so" | ||
221 | RDEPENDS_${PN}-sendmail = "${PN}" | ||
222 | |||
223 | PLUGINS += "${PN}-shiftcolumn" | ||
224 | LIC_FILES_CHKSUM += "file://shiftcolumn/COPYING;md5=751419260aa954499f7abaabaa882bbe" | ||
225 | FILES_${PN}-shiftcolumn = "${libdir}/geany/shiftcolumn.so" | ||
226 | RDEPENDS_${PN}-shiftcolumn = "${PN}" | ||
227 | |||
187 | PLUGINS += "${PN}-spellcheck" | 228 | PLUGINS += "${PN}-spellcheck" |
188 | LIC_FILES_CHKSUM += "file://spellcheck/COPYING;md5=4325afd396febcb659c36b49533135d4" | 229 | LIC_FILES_CHKSUM += "file://spellcheck/COPYING;md5=4325afd396febcb659c36b49533135d4" |
189 | FILES_${PN}-spellcheck = "${libdir}/geany/spellcheck.so" | 230 | FILES_${PN}-spellcheck = "${libdir}/geany/spellcheck.so" |
@@ -204,11 +245,13 @@ LIC_FILES_CHKSUM += "file://updatechecker/COPYING;md5=4325afd396febcb659c36b4953 | |||
204 | FILES_${PN}-updatechecker = "${libdir}/geany/updatechecker.so" | 245 | FILES_${PN}-updatechecker = "${libdir}/geany/updatechecker.so" |
205 | RDEPENDS_${PN}-updatechecker = "${PN}" | 246 | RDEPENDS_${PN}-updatechecker = "${PN}" |
206 | 247 | ||
207 | PLUGINS += "${PN}-webhelper" | 248 | # no webkit - lasts ages and is not properly detected |
208 | LIC_FILES_CHKSUM += "file://webhelper/COPYING;md5=d32239bcb673463ab874e80d47fae504" | 249 | EXTRA_OECONF += " --disable-webhelper" |
209 | LICENSE_${PN}-webhelper = "GPLv3" | 250 | #PLUGINS += "${PN}-webhelper" |
210 | FILES_${PN}-webhelper = "${libdir}/geany/webhelper.so" | 251 | #LIC_FILES_CHKSUM += "file://webhelper/COPYING;md5=d32239bcb673463ab874e80d47fae504" |
211 | RDEPENDS_${PN}-webhelper = "${PN}" | 252 | #LICENSE_${PN}-webhelper = "GPLv3" |
253 | #FILES_${PN}-webhelper = "${libdir}/geany/webhelper.so" | ||
254 | #RDEPENDS_${PN}-webhelper = "${PN}" | ||
212 | 255 | ||
213 | PLUGINS += "${PN}-xmlsnippets" | 256 | PLUGINS += "${PN}-xmlsnippets" |
214 | LIC_FILES_CHKSUM += "file://xmlsnippets/COPYING;md5=4325afd396febcb659c36b49533135d4" | 257 | LIC_FILES_CHKSUM += "file://xmlsnippets/COPYING;md5=4325afd396febcb659c36b49533135d4" |
@@ -218,5 +261,3 @@ RDEPENDS_${PN}-xmlsnippets = "${PN}" | |||
218 | PACKAGES =+ "${PLUGINS}" | 261 | PACKAGES =+ "${PLUGINS}" |
219 | RDEPENDS_${PN} = "${PLUGINS}" | 262 | RDEPENDS_${PN} = "${PLUGINS}" |
220 | ALLOW_EMPTY_${PN} = "1" | 263 | ALLOW_EMPTY_${PN} = "1" |
221 | |||
222 | PNBLACKLIST[geany-plugins] ?= "Causes multiple QA errors and LICENSE warnings" | ||