diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2021-03-10 19:17:48 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-03-11 00:12:55 -0800 |
commit | 3c4e5440074a246c3a84f96416d38be46e0ca227 (patch) | |
tree | b17728720a941ab157cf79d63a185f51fd64632e | |
parent | 9e20a2f41a1504217b5c1345e53dfe93380a1a09 (diff) | |
download | meta-openembedded-3c4e5440074a246c3a84f96416d38be46e0ca227.tar.gz |
glog: fix searching for Libunwind
* it used to be part of 0003-installation-path-fix.patch which was removed during
the upgrade to 0.4.0 and now some recipes (e.g. mtp-server from meta-luneos) are
failing like:
CMake Error at /OE/build/luneos-hardknott/webos-ports/tmp-glibc/work/tissot-webos-linux/mtp-server/0.0.3+gitAUTOINC+bb4a81e61b-r0/recipe-sysroot-native/usr/share/cmake-3.19/Modules/CMakeFindDependencyMacro.cmake:47 (find_package):
By not providing "FindLibunwind.cmake" in CMAKE_MODULE_PATH this project
has asked CMake to find a package configuration file provided by
"Libunwind", but CMake did not find one.
Could not find a package configuration file provided by "Libunwind" with
any of the following names:
LibunwindConfig.cmake
libunwind-config.cmake
Add the installation prefix of "Libunwind" to CMAKE_PREFIX_PATH or set
"Libunwind_DIR" to a directory containing one of the above files. If
"Libunwind" provides a separate development package or SDK, be sure it has
been installed.
Call Stack (most recent call first):
/OE/build/luneos-hardknott/webos-ports/tmp-glibc/work/tissot-webos-linux/mtp-server/0.0.3+gitAUTOINC+bb4a81e61b-r0/recipe-sysroot/usr/lib/cmake/glog/glog-config.cmake:35 (find_dependency)
CMakeLists.txt:17 (find_package)
because LibunwindConfig.cmake is provided by glog as:
recipe-sysroot/usr/lib/cmake/glog/FindLibunwind.cmake
but this directory wasn't searched by CMake.
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/recipes-support/glog/glog/0001-Find-Libunwind-during-configure.patch | 3 |
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/glog/glog/0001-Find-Libunwind-during-configure.patch b/meta-oe/recipes-support/glog/glog/0001-Find-Libunwind-during-configure.patch index 577007a62e..4c0861cca1 100644 --- a/meta-oe/recipes-support/glog/glog/0001-Find-Libunwind-during-configure.patch +++ b/meta-oe/recipes-support/glog/glog/0001-Find-Libunwind-during-configure.patch | |||
@@ -109,10 +109,11 @@ | |||
109 | install (EXPORT glog-targets NAMESPACE glog:: DESTINATION | 109 | install (EXPORT glog-targets NAMESPACE glog:: DESTINATION |
110 | --- a/glog-config.cmake.in | 110 | --- a/glog-config.cmake.in |
111 | +++ b/glog-config.cmake.in | 111 | +++ b/glog-config.cmake.in |
112 | @@ -8,4 +8,6 @@ include (CMakeFindDependencyMacro) | 112 | @@ -8,4 +8,7 @@ include (CMakeFindDependencyMacro) |
113 | 113 | ||
114 | @gflags_DEPENDENCY@ | 114 | @gflags_DEPENDENCY@ |
115 | 115 | ||
116 | +list (APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_LIST_DIR}") | ||
116 | +find_dependency (Libunwind) | 117 | +find_dependency (Libunwind) |
117 | + | 118 | + |
118 | include ("${CMAKE_CURRENT_LIST_DIR}/glog-targets.cmake") | 119 | include ("${CMAKE_CURRENT_LIST_DIR}/glog-targets.cmake") |