summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuðni Már Gilbert <gudnimar@noxmedical.com>2024-04-13 21:05:56 +0000
committerKhem Raj <raj.khem@gmail.com>2024-04-14 08:32:42 -0700
commit3c1ad6fe52c61ddb987551580713f5bbece22568 (patch)
tree641e0d972ef9f123fe26f40c93cc33d4b6277030
parenta7c8ce7f674008db4d7013557ec375a35226f43f (diff)
downloadmeta-openembedded-3c1ad6fe52c61ddb987551580713f5bbece22568.tar.gz
python3-twisted: cleanup FILES and recipe in general
Changes are made to prepare upgrading Twisted to a newer version in a later commit. Summary of changes: Remove python3-twisted-bin since there is no FILES defined for bin Use PYTHON_SITEPACKAGES_DIR when refering to the site-packages directory Remove ALOT of files from FILES list which no longer exist. Many of these files were deprecated and removed a long time ago. Removed redundant :append to FILES packages, they can simply be in the first definition of it. Signed-off-by: Guðni Már Gilbert <gudnimar@noxmedical.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-twisted_22.10.0.bb265
1 files changed, 77 insertions, 188 deletions
diff --git a/meta-python/recipes-devtools/python/python3-twisted_22.10.0.bb b/meta-python/recipes-devtools/python/python3-twisted_22.10.0.bb
index 72a173e6f..20b9ce254 100644
--- a/meta-python/recipes-devtools/python/python3-twisted_22.10.0.bb
+++ b/meta-python/recipes-devtools/python/python3-twisted_22.10.0.bb
@@ -3,7 +3,6 @@ Twisted supports TCP, UDP, SSL/TLS, multicast, Unix sockets, a large number of p
3(including HTTP, NNTP, IMAP, SSH, IRC, FTP, and others), and much more." 3(including HTTP, NNTP, IMAP, SSH, IRC, FTP, and others), and much more."
4HOMEPAGE = "http://www.twistedmatrix.com" 4HOMEPAGE = "http://www.twistedmatrix.com"
5 5
6#twisted/topfiles/NEWS:655: - Relicensed: Now under the MIT license, rather than LGPL.
7LICENSE = "MIT" 6LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=0f8d67f84b6e178c92d471011b2245fc" 7LIC_FILES_CHKSUM = "file://LICENSE;md5=0f8d67f84b6e178c92d471011b2245fc"
9 8
@@ -34,16 +33,11 @@ PACKAGES += "\
34 ${PN}-core \ 33 ${PN}-core \
35" 34"
36 35
37PACKAGES =+ "\
38 ${PN}-bin \
39"
40
41DEPENDS += " \ 36DEPENDS += " \
42 python3-incremental-native \ 37 python3-incremental-native \
43" 38"
44 39
45RDEPENDS:${PN} = "\ 40RDEPENDS:${PN} = "\
46 ${PN}-bin \
47 ${PN}-core \ 41 ${PN}-core \
48 ${PN}-conch \ 42 ${PN}-conch \
49 ${PN}-mail \ 43 ${PN}-mail \
@@ -84,229 +78,124 @@ RDEPENDS:${PN}-pair += "${PN}-core"
84FILES:${PN} = "${PYTHON_SITEPACKAGES_DIR}/${PYPI_PACKAGE}-${PV}.dist-info/*" 78FILES:${PN} = "${PYTHON_SITEPACKAGES_DIR}/${PYPI_PACKAGE}-${PV}.dist-info/*"
85 79
86FILES:${PN}-test = " \ 80FILES:${PN}-test = " \
87 ${libdir}/${PYTHON_DIR}/site-packages/twisted/test \ 81 ${PYTHON_SITEPACKAGES_DIR}/twisted/test \
88 ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/test \ 82 ${PYTHON_SITEPACKAGES_DIR}/twisted/*/test \
89 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/haproxy/test/ \ 83 ${PYTHON_SITEPACKAGES_DIR}/twisted/protocols/haproxy/test/ \
90" 84"
91 85
92FILES:${PN}-protocols = " \ 86FILES:${PN}-protocols = " \
93 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/*.py* \ 87 ${PYTHON_SITEPACKAGES_DIR}/twisted/protocols/*.py* \
94 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/gps/ \ 88 ${PYTHON_SITEPACKAGES_DIR}/twisted/protocols/gps/ \
95 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/mice/ \ 89 ${PYTHON_SITEPACKAGES_DIR}/twisted/protocols/mice/ \
96 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/haproxy \ 90 ${PYTHON_SITEPACKAGES_DIR}/twisted/protocols/haproxy \
91 ${PYTHON_SITEPACKAGES_DIR}/twisted/protocols/__pycache__/*pyc \
97" 92"
98 93
99FILES:${PN}-zsh = " \ 94FILES:${PN}-zsh = " \
100 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zsh \ 95 ${PYTHON_SITEPACKAGES_DIR}/twisted/python/twisted-completion.zsh \
101 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zshcomp.* \
102 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/twisted-completion.zsh \
103" 96"
104 97
105FILES:${PN}-conch = " \ 98FILES:${PN}-conch = " \
106 ${bindir}/ckeygen \ 99 ${bindir}/ckeygen \
107 ${bindir}/tkconch \ 100 ${bindir}/tkconch \
108 ${bindir}/conch \ 101 ${bindir}/conch \
109 ${bindir}/conchftp \
110 ${bindir}/cftp \ 102 ${bindir}/cftp \
111 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_conch.py* \ 103 ${PYTHON_SITEPACKAGES_DIR}/twisted/plugins/twisted_conch.py* \
112 ${libdir}/${PYTHON_DIR}/site-packages/twisted/conch \ 104 ${PYTHON_SITEPACKAGES_DIR}/twisted/plugins/__pycache__/twisted_conch*.pyc \
105 ${PYTHON_SITEPACKAGES_DIR}/twisted/conch \
113" 106"
114 107
115FILES:${PN}-core = " \ 108FILES:${PN}-core = " \
116${bindir}/manhole \ 109 ${bindir}/twist \
117${bindir}/mktap \ 110 ${bindir}/twistd \
118${bindir}/twistd \ 111 ${bindir}/trial \
119${bindir}/tap2deb \ 112 ${bindir}/pyhtmlizer \
120${bindir}/tap2rpm \ 113 ${PYTHON_SITEPACKAGES_DIR}/twisted/*.py* \
121${bindir}/tapconvert \ 114 ${PYTHON_SITEPACKAGES_DIR}/twisted/application \
122${bindir}/tkmktap \ 115 ${PYTHON_SITEPACKAGES_DIR}/twisted/cred \
123${bindir}/trial \ 116 ${PYTHON_SITEPACKAGES_DIR}/twisted/enterprise \
124${bindir}/easy_install* \ 117 ${PYTHON_SITEPACKAGES_DIR}/twisted/internet \
125${bindir}/pyhtmlizer \ 118 ${PYTHON_SITEPACKAGES_DIR}/twisted/persisted \
126${libdir}/${PYTHON_DIR}/site-packages/twisted/python/*.so \ 119 ${PYTHON_SITEPACKAGES_DIR}/twisted/protocols \
127${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py* \ 120 ${PYTHON_SITEPACKAGES_DIR}/twisted/scripts \
128${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__init__.py* \ 121 ${PYTHON_SITEPACKAGES_DIR}/twisted/spread \
129${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/notestplugin.py* \ 122 ${PYTHON_SITEPACKAGES_DIR}/twisted/tap \
130${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/testplugin.py* \ 123 ${PYTHON_SITEPACKAGES_DIR}/twisted/trial \
131${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_ftp.py* \ 124 ${PYTHON_SITEPACKAGES_DIR}/twisted/*.py* \
132${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_inet.py* \ 125 ${PYTHON_SITEPACKAGES_DIR}/twisted/python/*.py* \
133${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_manhole.py* \ 126 ${PYTHON_SITEPACKAGES_DIR}/twisted/plugins/*.py* \
134${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_portforward.py* \ 127 ${PYTHON_SITEPACKAGES_DIR}/Twisted*egg-info \
135${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_socks.py* \ 128 ${PYTHON_SITEPACKAGES_DIR}/twisted/logger \
136${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_telnet.py* \ 129 ${PYTHON_SITEPACKAGES_DIR}/twisted/_threads \
137${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_trial.py* \ 130 ${PYTHON_SITEPACKAGES_DIR}/twisted/positioning \
138${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/dropin.cache \ 131 ${PYTHON_SITEPACKAGES_DIR}/twisted/py.typed \
139${libdir}/${PYTHON_DIR}/site-packages/twisted/application \ 132 ${PYTHON_SITEPACKAGES_DIR}/twisted/__pycache__/*pyc \
140${libdir}/${PYTHON_DIR}/site-packages/twisted/cred \ 133 ${PYTHON_SITEPACKAGES_DIR}/twisted/python/__pycache__/*pyc \
141${libdir}/${PYTHON_DIR}/site-packages/twisted/enterprise \ 134 ${PYTHON_SITEPACKAGES_DIR}/twisted/plugins/__pycache__/__init__*.pyc \
142${libdir}/${PYTHON_DIR}/site-packages/twisted/internet \ 135 ${PYTHON_SITEPACKAGES_DIR}/twisted/plugins/__pycache__/cred_anonymous*.pyc \
143${libdir}/${PYTHON_DIR}/site-packages/twisted/manhole \ 136 ${PYTHON_SITEPACKAGES_DIR}/twisted/plugins/__pycache__/cred_file*.pyc \
144${libdir}/${PYTHON_DIR}/site-packages/twisted/manhole \ 137 ${PYTHON_SITEPACKAGES_DIR}/twisted/plugins/__pycache__/cred_memory*.pyc \
145${libdir}/${PYTHON_DIR}/site-packages/twisted/persisted \ 138 ${PYTHON_SITEPACKAGES_DIR}/twisted/plugins/__pycache__/cred_sshkeys*.pyc \
146${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols\ 139 ${PYTHON_SITEPACKAGES_DIR}/twisted/plugins/__pycache__/cred_unix*.pyc \
147${libdir}/${PYTHON_DIR}/site-packages/twisted/python\ 140 ${PYTHON_SITEPACKAGES_DIR}/twisted/plugins/__pycache__/twisted_core*.pyc \
148${libdir}/${PYTHON_DIR}/site-packages/twisted/python/timeoutqueue.py* \ 141 ${PYTHON_SITEPACKAGES_DIR}/twisted/plugins/__pycache__/twisted_ftp*.pyc \
149${libdir}/${PYTHON_DIR}/site-packages/twisted/python/filepath.py* \ 142 ${PYTHON_SITEPACKAGES_DIR}/twisted/plugins/__pycache__/twisted_inet*.pyc \
150${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dxprofile.py* \ 143 ${PYTHON_SITEPACKAGES_DIR}/twisted/plugins/__pycache__/twisted_portforward*.pyc \
151${libdir}/${PYTHON_DIR}/site-packages/twisted/python/plugin.py* \ 144 ${PYTHON_SITEPACKAGES_DIR}/twisted/plugins/__pycache__/twisted_reactors*.pyc \
152${libdir}/${PYTHON_DIR}/site-packages/twisted/python/htmlizer.py* \ 145 ${PYTHON_SITEPACKAGES_DIR}/twisted/plugins/__pycache__/twisted_socks*.pyc \
153${libdir}/${PYTHON_DIR}/site-packages/twisted/python/__init__.py* \ 146 ${PYTHON_SITEPACKAGES_DIR}/twisted/plugins/__pycache__/twisted_trial*.pyc \
154${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dispatch.py* \
155${libdir}/${PYTHON_DIR}/site-packages/twisted/python/hook.py* \
156${libdir}/${PYTHON_DIR}/site-packages/twisted/python/threadpool.py* \
157${libdir}/${PYTHON_DIR}/site-packages/twisted/python/otp.py* \
158${libdir}/${PYTHON_DIR}/site-packages/twisted/python/usage.py* \
159${libdir}/${PYTHON_DIR}/site-packages/twisted/python/roots.py* \
160${libdir}/${PYTHON_DIR}/site-packages/twisted/python/versions.py* \
161${libdir}/${PYTHON_DIR}/site-packages/twisted/python/urlpath.py* \
162${libdir}/${PYTHON_DIR}/site-packages/twisted/python/util.py* \
163${libdir}/${PYTHON_DIR}/site-packages/twisted/python/components.py* \
164${libdir}/${PYTHON_DIR}/site-packages/twisted/python/logfile.py* \
165${libdir}/${PYTHON_DIR}/site-packages/twisted/python/runtime.py* \
166${libdir}/${PYTHON_DIR}/site-packages/twisted/python/reflect.py* \
167${libdir}/${PYTHON_DIR}/site-packages/twisted/python/context.py* \
168${libdir}/${PYTHON_DIR}/site-packages/twisted/python/threadable.py* \
169${libdir}/${PYTHON_DIR}/site-packages/twisted/python/rebuild.py* \
170${libdir}/${PYTHON_DIR}/site-packages/twisted/python/failure.py* \
171${libdir}/${PYTHON_DIR}/site-packages/twisted/python/lockfile.py* \
172${libdir}/${PYTHON_DIR}/site-packages/twisted/python/formmethod.py* \
173${libdir}/${PYTHON_DIR}/site-packages/twisted/python/finalize.py* \
174${libdir}/${PYTHON_DIR}/site-packages/twisted/python/win32.py* \
175${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dist.py* \
176${libdir}/${PYTHON_DIR}/site-packages/twisted/python/shortcut.py* \
177${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zipstream.py* \
178${libdir}/${PYTHON_DIR}/site-packages/twisted/python/release.py* \
179${libdir}/${PYTHON_DIR}/site-packages/twisted/python/syslog.py* \
180${libdir}/${PYTHON_DIR}/site-packages/twisted/python/log.py* \
181${libdir}/${PYTHON_DIR}/site-packages/twisted/python/compat.py* \
182${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zshcomp.py* \
183${libdir}/${PYTHON_DIR}/site-packages/twisted/python/procutils.py* \
184${libdir}/${PYTHON_DIR}/site-packages/twisted/python/text.py* \
185${libdir}/${PYTHON_DIR}/site-packages/twisted/python/_twisted_zsh_stub \
186${libdir}/${PYTHON_DIR}/site-packages/twisted/scripts/ \
187${libdir}/${PYTHON_DIR}/site-packages/twisted/spread/ \
188${libdir}/${PYTHON_DIR}/site-packages/twisted/tap/ \
189${libdir}/${PYTHON_DIR}/site-packages/twisted/trial/ \
190${libdir}/${PYTHON_DIR}/site-packages/twisted/__init__.py* \
191${libdir}/${PYTHON_DIR}/site-packages/twisted/_version.py* \
192${libdir}/${PYTHON_DIR}/site-packages/twisted/copyright.py* \
193${libdir}/${PYTHON_DIR}/site-packages/twisted/im.py* \
194${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py* \
195${libdir}/${PYTHON_DIR}/site-packages/twisted/python/*.py* \
196${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/*.py* \
197${libdir}/${PYTHON_DIR}/site-packages/twisted/topfiles \
198${libdir}/${PYTHON_DIR}/site-packages/Twisted*egg-info \
199${libdir}/${PYTHON_DIR}/site-packages/twisted/logger/ \
200${libdir}/${PYTHON_DIR}/site-packages/twisted/_threads/ \
201${libdir}/${PYTHON_DIR}/site-packages/twisted/positioning/ \
202${libdir}/${PYTHON_DIR}/site-packages/twisted/py.typed \
203" 147"
204 148
205FILES:${PN}-mail = " \ 149FILES:${PN}-mail = " \
206${bindir}/mailmail \ 150 ${bindir}/mailmail \
207${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_mail.py* \ 151 ${PYTHON_SITEPACKAGES_DIR}/twisted/plugins/twisted_mail.py* \
208${libdir}/${PYTHON_DIR}/site-packages/twisted/mail \ 152 ${PYTHON_SITEPACKAGES_DIR}/twisted/plugins/__pycache__/twisted_mail*.pyc \
153 ${PYTHON_SITEPACKAGES_DIR}/twisted/mail \
209" 154"
210 155
211FILES:${PN}-names = " \ 156FILES:${PN}-names = " \
212${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_names.py* \ 157 ${PYTHON_SITEPACKAGES_DIR}/twisted/plugins/twisted_names.py* \
213${libdir}/${PYTHON_DIR}/site-packages/twisted/names \ 158 ${PYTHON_SITEPACKAGES_DIR}/twisted/plugins/__pycache__/twisted_names*.pyc \
159 ${PYTHON_SITEPACKAGES_DIR}/twisted/names \
214" 160"
215 161
216FILES:${PN}-news = " \ 162FILES:${PN}-news = " \
217${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_news.py* \ 163 ${PYTHON_SITEPACKAGES_DIR}/twisted/plugins/twisted_news.py* \
218${libdir}/${PYTHON_DIR}/site-packages/twisted/news \ 164 ${PYTHON_SITEPACKAGES_DIR}/twisted/plugins/__pycache__/twisted_news*.pyc \
165 ${PYTHON_SITEPACKAGES_DIR}/twisted/news \
219" 166"
220 167
221FILES:${PN}-runner = " \ 168FILES:${PN}-runner = " \
222${libdir}/site-packages/twisted/runner/portmap.so \ 169 ${PYTHON_SITEPACKAGES_DIR}/twisted/plugins/twisted_runner.py* \
223${libdir}/${PYTHON_DIR}/site-packages/twisted/runner\ 170 ${PYTHON_SITEPACKAGES_DIR}/twisted/plugins/__pycache__/twisted_runner*.pyc \
171 ${PYTHON_SITEPACKAGES_DIR}/twisted/runner \
224" 172"
225 173
226FILES:${PN}-web = " \ 174FILES:${PN}-web = " \
227${bindir}/websetroot \ 175 ${PYTHON_SITEPACKAGES_DIR}/twisted/plugins/twisted_web.py* \
228${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_web.py* \ 176 ${PYTHON_SITEPACKAGES_DIR}/twisted/plugins/__pycache__/twisted_web*.pyc \
229${libdir}/${PYTHON_DIR}/site-packages/twisted/web\ 177 ${PYTHON_SITEPACKAGES_DIR}/twisted/web \
230" 178"
231 179
232FILES:${PN}-words = " \ 180FILES:${PN}-words = " \
233${bindir}/im \ 181 ${PYTHON_SITEPACKAGES_DIR}/twisted/plugins/twisted_words.py* \
234${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_words.py* \ 182 ${PYTHON_SITEPACKAGES_DIR}/twisted/plugins/__pycache__/twisted_words*.pyc \
235${libdir}/${PYTHON_DIR}/site-packages/twisted/words\ 183 ${PYTHON_SITEPACKAGES_DIR}/twisted/words \
236" 184"
237 185
238FILES:${PN}-flow = " \ 186FILES:${PN}-flow = " \
239${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_flow.py* \ 187 ${PYTHON_SITEPACKAGES_DIR}/twisted/plugins/twisted_flow.py* \
240${libdir}/${PYTHON_DIR}/site-packages/twisted/flow \" 188 ${PYTHON_SITEPACKAGES_DIR}/twisted/plugins/__pycache__/twisted_flow*.pyc \
189 ${PYTHON_SITEPACKAGES_DIR}/twisted/flow \
190"
241 191
242FILES:${PN}-pair = " \ 192FILES:${PN}-pair = " \
243${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_pair.py* \ 193 ${PYTHON_SITEPACKAGES_DIR}/twisted/plugins/twisted_pair.py* \
244${libdir}/${PYTHON_DIR}/site-packages/twisted/pair \ 194 ${PYTHON_SITEPACKAGES_DIR}/twisted/plugins/__pycache__/twisted_pair*.pyc \
195 ${PYTHON_SITEPACKAGES_DIR}/twisted/pair \
245" 196"
246 197
247FILES:${PN}-doc += " \ 198FILES:${PN}-doc += " \
248 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/_pydoctortemplates/ \ 199 ${PYTHON_SITEPACKAGES_DIR}/twisted/python/_pydoctortemplates \
249"
250
251FILES:${PN}-core:append = " \
252 ${libdir}/${PYTHON_DIR}/site-packages/twisted/__pycache__ \
253 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/__pycache__/*pyc \
254 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/__init__*.pyc \
255 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/notestplugin*.pyc \
256 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/testplugin*.pyc \
257 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_ftp*.pyc \
258 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_inet*.pyc \
259 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_manhole*.pyc \
260 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_portforward*.pyc \
261 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_socks*.pyc \
262 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_telnet*.pyc \
263 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_trial*.pyc \
264 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_core*.pyc \
265 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_qtstub*.pyc \
266 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_reactors*.pyc \
267 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/cred*.pyc \
268 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/dropin*.cache \
269"
270
271FILES:${PN}-names:append = " \
272 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_names*.pyc \
273"
274
275FILES:${PN}-news:append = " \
276 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_news*.pyc \
277"
278
279FILES:${PN}-protocols:append = " \
280 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/__pycache__/*pyc \
281"
282
283FILES:${PN}-conch:append = " \
284 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_conch*.pyc \
285" 200"
286 201
287FILES:${PN}-lore:append = " \
288 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_lore*.pyc \
289"
290FILES:${PN}-mail:append = " \
291 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_mail*.pyc \
292"
293
294FILES:${PN}-web:append = " \
295 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_web*.pyc \
296"
297
298FILES:${PN}-words:append = " \
299 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_words*.pyc \
300"
301
302FILES:${PN}-flow:append = " \
303 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_flow*.pyc \
304"
305
306FILES:${PN}-pair:append = " \
307 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_pair*.pyc \
308"
309
310FILES:${PN}-runner:append = " \
311 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_runner*.pyc \
312"