summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-07-21 23:28:43 -0700
committerKhem Raj <raj.khem@gmail.com>2019-07-23 07:31:56 -0700
commit3a7abb175ae149b1949f8a2559f77647498c91df (patch)
tree67d6db14cf4384367a363aeaa4975e1596a69e61
parent65ac4604b3e028df692eabf89669008676df4e7b (diff)
downloadmeta-openembedded-3a7abb175ae149b1949f8a2559f77647498c91df.tar.gz
log4cplus: Fix build with gold linker
Fixes a potential linker error and eventual linker crash when using gold linker arm-yoe-linux-gnueabi/9.1.0/ld: internal error in add_output_section_to_load, at ../../gold/output.cc:4149 collect2: error: ld returned 1 exit status Makefile:1979: recipe for target 'liblog4cplusU.la' failed make[2]: *** [liblog4cplusU.la] Error 1 Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Adrian Bunk <bunk@stusta.de> Cc: Mingli Yu <mingli.yu@windriver.com>
-rw-r--r--meta-oe/recipes-devtools/log4cplus/log4cplus/0001-Remove-log4cplus-version-entry-from-ELF-.comment-sec.patch40
-rw-r--r--meta-oe/recipes-devtools/log4cplus/log4cplus_2.0.4.bb6
2 files changed, 45 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/log4cplus/log4cplus/0001-Remove-log4cplus-version-entry-from-ELF-.comment-sec.patch b/meta-oe/recipes-devtools/log4cplus/log4cplus/0001-Remove-log4cplus-version-entry-from-ELF-.comment-sec.patch
new file mode 100644
index 000000000..44a835c35
--- /dev/null
+++ b/meta-oe/recipes-devtools/log4cplus/log4cplus/0001-Remove-log4cplus-version-entry-from-ELF-.comment-sec.patch
@@ -0,0 +1,40 @@
1From da5338e68f146efadab7c221291ba4c949d8f12f Mon Sep 17 00:00:00 2001
2From: Vaclav Haisman <vhaisman@gmail.com>
3Date: Sun, 21 Jul 2019 23:23:16 -0700
4Subject: [PATCH] Remove log4cplus version entry from ELF .comment section
5
6Reverts
7https://github.com/log4cplus/log4cplus/commit/9cb0d4ade619da4e40628c9b95ff51de3df29f1b
8
9Upstream-Status: Backport [https://github.com/log4cplus/log4cplus/commit/7e6addc70dffd2e30e902efd18eb845c5d5dd7bb]
10
11Suggested-by: Adrian Bunk <bunk@stusta.de>
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13---
14 src/version.cxx | 12 ------------
15 1 file changed, 12 deletions(-)
16
17diff --git a/src/version.cxx b/src/version.cxx
18index ce18212..e002de9 100644
19--- a/src/version.cxx
20+++ b/src/version.cxx
21@@ -34,16 +34,4 @@ namespace log4cplus
22 unsigned const version = LOG4CPLUS_VERSION;
23 char const versionStr[] = LOG4CPLUS_VERSION_STR LOG4CPLUS_VERSION_STR_SUFFIX;
24
25-namespace
26-{
27-
28-#if defined (__ELF__) && (defined (__GNUC__) || defined (__clang__))
29-char const versionStrComment[]
30- __attribute__ ((__used__, __section__ ((".comment"))))
31- = "log4cplus " LOG4CPLUS_VERSION_STR LOG4CPLUS_VERSION_STR_SUFFIX;
32-#endif
33-
34-
35-} // namespace
36-
37 } // namespace log4cplus
38--
392.22.0
40
diff --git a/meta-oe/recipes-devtools/log4cplus/log4cplus_2.0.4.bb b/meta-oe/recipes-devtools/log4cplus/log4cplus_2.0.4.bb
index d86521aba..b396cabf3 100644
--- a/meta-oe/recipes-devtools/log4cplus/log4cplus_2.0.4.bb
+++ b/meta-oe/recipes-devtools/log4cplus/log4cplus_2.0.4.bb
@@ -6,7 +6,9 @@ BUGTRACKER = "http://sourceforge.net/p/log4cplus/bugs/"
6LICENSE = "Apache-2.0 & BSD-2-Clause" 6LICENSE = "Apache-2.0 & BSD-2-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=41e8e060c26822886b592ab4765c756b" 7LIC_FILES_CHKSUM = "file://LICENSE;md5=41e8e060c26822886b592ab4765c756b"
8 8
9SRC_URI = "${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}-stable/${PV}/${BP}.tar.gz" 9SRC_URI = "${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}-stable/${PV}/${BP}.tar.gz \
10 file://0001-Remove-log4cplus-version-entry-from-ELF-.comment-sec.patch \
11 "
10SRC_URI[md5sum] = "2b5b7bc294698bf30a315a259ef9eec2" 12SRC_URI[md5sum] = "2b5b7bc294698bf30a315a259ef9eec2"
11SRC_URI[sha256sum] = "196eedbc7f2dd792dae721b1159c7ac132255bb368226353c24d4d5fa7c7797a" 13SRC_URI[sha256sum] = "196eedbc7f2dd792dae721b1159c7ac132255bb368226353c24d4d5fa7c7797a"
12 14
@@ -16,3 +18,5 @@ UPSTREAM_CHECK_REGEX = "log4cplus-stable/(?P<pver>\d+(\.\d+)+)/"
16inherit autotools pkgconfig 18inherit autotools pkgconfig
17 19
18BBCLASSEXTEND = "native" 20BBCLASSEXTEND = "native"
21
22CXXFLAGS += "-fuse-ld=gold"