summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2014-03-18 13:28:22 -0300
committerMartin Jansa <Martin.Jansa@gmail.com>2014-03-23 21:49:02 +0100
commit3a41db396dcf787a2167dad101cd2ebf084c5ee0 (patch)
treebdd4062363f71432e3fc56fd0243c5e080beb6d1
parentdee876f0e5a6412ba3e6bd7ab778761bd6491850 (diff)
downloadmeta-openembedded-3a41db396dcf787a2167dad101cd2ebf084c5ee0.tar.gz
glmark2: Rework recipe to use the 'waf' class
This removes the duplicated code and uses the OE-Core waf class. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-benchmark/glmark2/glmark2_2012.12.bb14
1 files changed, 1 insertions, 13 deletions
diff --git a/meta-oe/recipes-benchmark/glmark2/glmark2_2012.12.bb b/meta-oe/recipes-benchmark/glmark2/glmark2_2012.12.bb
index 9edee149f..031e3b3d4 100644
--- a/meta-oe/recipes-benchmark/glmark2/glmark2_2012.12.bb
+++ b/meta-oe/recipes-benchmark/glmark2/glmark2_2012.12.bb
@@ -15,21 +15,9 @@ SRC_URI = "https://launchpad.net/${BPN}/trunk/${PV}/+download/${BP}.tar.gz"
15SRC_URI[md5sum] = "4f306664aa3886fa0cf93853603603f8" 15SRC_URI[md5sum] = "4f306664aa3886fa0cf93853603603f8"
16SRC_URI[sha256sum] = "bea6f9de2cdce376195bd91e4a2fdfdf80bf3e480abff8e05b90a6458c1deb47" 16SRC_URI[sha256sum] = "bea6f9de2cdce376195bd91e4a2fdfdf80bf3e480abff8e05b90a6458c1deb47"
17 17
18inherit pkgconfig 18inherit waf pkgconfig
19 19
20PACKAGECONFIG ?= "gl gles2" 20PACKAGECONFIG ?= "gl gles2"
21 21
22PACKAGECONFIG[gl] = "--enable-gl,,virtual/libgl" 22PACKAGECONFIG[gl] = "--enable-gl,,virtual/libgl"
23PACKAGECONFIG[gles2] = "--enable-glesv2,,virtual/libgles2" 23PACKAGECONFIG[gles2] = "--enable-glesv2,,virtual/libgles2"
24
25do_configure() {
26 ./waf configure --prefix=${prefix} ${EXTRA_OECONF}
27}
28
29do_compile() {
30 ./waf build ${PARALLEL_MAKE}
31}
32
33do_install() {
34 ./waf install --destdir=${D}
35}