summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan McGregor <dan.mcgregor@usask.ca>2024-04-17 17:33:27 -0600
committerKhem Raj <raj.khem@gmail.com>2024-04-17 23:47:22 -0700
commit392b8447223d05db28d306319980fc37594ede46 (patch)
tree0a09ed12df52e2ada53f60208710cffe49ab31e6
parent61bcec12151de17a53c1f6bda155cfcbcc0467b8 (diff)
downloadmeta-openembedded-392b8447223d05db28d306319980fc37594ede46.tar.gz
libcbor: use shared libraries
libfido2 requires cbor be position independent. When PIE's the default this isn't a problem, but not all build configurations do that. Instead of relying on that, just make shared libraries. Signed-off-by: Dan McGregor <dan.mcgregor@usask.ca> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rwxr-xr-xmeta-oe/recipes-extended/libcbor/libcbor_0.11.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/libcbor/libcbor_0.11.0.bb b/meta-oe/recipes-extended/libcbor/libcbor_0.11.0.bb
index 28bd5b5ae..0e15393dd 100755
--- a/meta-oe/recipes-extended/libcbor/libcbor_0.11.0.bb
+++ b/meta-oe/recipes-extended/libcbor/libcbor_0.11.0.bb
@@ -11,4 +11,4 @@ S = "${WORKDIR}/git"
11 11
12inherit cmake 12inherit cmake
13 13
14EXTRA_OECMAKE += " -DCMAKE_BUILD_TYPE=Release" 14EXTRA_OECMAKE += "-DCMAKE_BUILD_TYPE=Release -DBUILD_SHARED_LIBS:BOOL=ON"