summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2013-11-14 19:14:11 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2013-11-18 23:12:19 +0100
commit381c941594752465d08967f3567c7a63e4cc3170 (patch)
tree4386735eee705205535a3117c552595b3c15a244
parent8a56dc88faceb0b1f6e1dfad84203a976a887890 (diff)
downloadmeta-openembedded-381c941594752465d08967f3567c7a63e4cc3170.tar.gz
uhd: Remove from meta-oe. Now lives in meta-sdr.
https://github.com/balister/meta-sdr Signed-off-by: Philip Balister <philip@balister.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-connectivity/uhd/uhd-firmware_003.005.003.bb27
-rw-r--r--meta-oe/recipes-connectivity/uhd/uhd.inc35
-rw-r--r--meta-oe/recipes-connectivity/uhd/uhd/0001-HACK-work-around-Wl-as-needed-problems.patch40
-rw-r--r--meta-oe/recipes-connectivity/uhd/uhd/0001-use-uint8_t-from-boost-namespace.patch29
-rw-r--r--meta-oe/recipes-connectivity/uhd/uhd_git.bb11
5 files changed, 0 insertions, 142 deletions
diff --git a/meta-oe/recipes-connectivity/uhd/uhd-firmware_003.005.003.bb b/meta-oe/recipes-connectivity/uhd/uhd-firmware_003.005.003.bb
deleted file mode 100644
index 43699074a..000000000
--- a/meta-oe/recipes-connectivity/uhd/uhd-firmware_003.005.003.bb
+++ /dev/null
@@ -1,27 +0,0 @@
1DESCRIPTION = "Universal Hardware Driver Firmware"
2HOMEPAGE = "http://www.ettus.com"
3
4PE = "1"
5
6LICENSE = "GPLv3"
7LIC_FILES_CHKSUM = "file://share/uhd/images/usrp_e100_fpga_v2.bin;md5=e86f2186823b264efc627aafc0ad60a2"
8
9inherit allarch
10
11SRC_URI = "http://files.ettus.com/binaries/uhd_stable/releases/uhd_${PV}-release/uhd-images_${PV}-release.tar.gz"
12SRC_URI[md5sum] = "65cf76fd363d576ceff9c1527ade297b"
13SRC_URI[sha256sum] = "9079586def30b6805053092673d942c0051f1f99eebc676b871f070c04b66e35"
14
15S = "${WORKDIR}/uhd-images_${PV}-release"
16
17do_install() {
18 install -d ${D}${datadir}/uhd/images
19 install -d ${D}${datadir}/uhd/images/bit
20 install -m 0644 ${S}/share/uhd/images/bit/* ${D}${datadir}/uhd/images/bit
21 rm -rf ${S}/share/uhd/images/bit
22 install -m 0644 ${S}/share/uhd/images/* ${D}${datadir}/uhd/images
23}
24
25PACKAGES = "${PN}"
26FILES_${PN} = "${datadir}/uhd/images"
27
diff --git a/meta-oe/recipes-connectivity/uhd/uhd.inc b/meta-oe/recipes-connectivity/uhd/uhd.inc
deleted file mode 100644
index da1fbd8c7..000000000
--- a/meta-oe/recipes-connectivity/uhd/uhd.inc
+++ /dev/null
@@ -1,35 +0,0 @@
1DESCRIPTION = "Universal Hardware Driver for Ettus Research products."
2HOMEPAGE = "http://www.ettus.com"
3LICENSE = "GPLv3+"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=51b35d652c070d136bf20244494be2d3"
5
6DEPENDS = "git-native python-cheetah-native boost libusb1 uhd-firmware orc-native ncurses"
7RDEPENDS_${PN} += "uhd-firmware"
8
9PE = "1"
10INC_PR = "r3"
11
12inherit cmake pythonnative
13
14PACKAGES =+ "${PN}-tests ${PN}-examples ${PN}-e1xx"
15
16INSANE_SKIP_${PN} = "dev-so"
17
18FILES_${PN} += "${libdir}/libuhd.so \
19 ${datadir}/uhd/utils/*"
20FILES_${PN}-tests += "${datadir}/uhd/tests/*"
21FILES_${PN}-dbg += "${datadir}/uhd/examples/.debug/* \
22 ${datadir}/uhd/utils/.debug/* \
23 ${datadir}/uhd/tests/.debug/* \
24 ${datadir}/uhd/usrp_e_utils/.debug/*"
25FILES_${PN}-examples = "${datadir}/uhd/examples/*"
26
27OECMAKE_BUILDPATH = "${S}/build"
28OECMAKE_SOURCEPATH = "${S}"
29
30PACKAGECONFIG ??= ""
31PACKAGECONFIG[orc] = "-DENABLE_ORC=ON,-DENABLE_ORC=OFF,orc"
32
33EXTRA_OECMAKE = "-DENABLE_E100=TRUE"
34
35EXTRA_OEMAKE = "-C ${OECMAKE_BUILDPATH}"
diff --git a/meta-oe/recipes-connectivity/uhd/uhd/0001-HACK-work-around-Wl-as-needed-problems.patch b/meta-oe/recipes-connectivity/uhd/uhd/0001-HACK-work-around-Wl-as-needed-problems.patch
deleted file mode 100644
index eb05cc0a0..000000000
--- a/meta-oe/recipes-connectivity/uhd/uhd/0001-HACK-work-around-Wl-as-needed-problems.patch
+++ /dev/null
@@ -1,40 +0,0 @@
1From 77be3026cbfe77b3ee1aaa549a27f5ad50320f9d Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Fri, 17 Jun 2011 19:44:04 +0200
4Subject: [PATCH] HACK: work around -Wl,as-needed problems
5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7---
8 host/lib/types/CMakeLists.txt | 2 +-
9 host/usrp_e_utils/CMakeLists.txt | 2 +-
10 2 files changed, 2 insertions(+), 2 deletions(-)
11
12diff --git a/host/lib/types/CMakeLists.txt b/host/lib/types/CMakeLists.txt
13index 957dfd3..3147747 100644
14--- a/host/lib/types/CMakeLists.txt
15+++ b/host/lib/types/CMakeLists.txt
16@@ -59,7 +59,7 @@ CHECK_CXX_SOURCE_COMPILES("
17 IF(HAVE_CLOCK_GETTIME)
18 MESSAGE(STATUS " High resolution timing supported through clock_gettime.")
19 SET(TIME_SPEC_DEFS HAVE_CLOCK_GETTIME)
20- LIBUHD_APPEND_LIBS("-lrt")
21+ LIBUHD_APPEND_LIBS("-lrt -lpthread -lncurses")
22 ELSEIF(HAVE_MACH_ABSOLUTE_TIME)
23 MESSAGE(STATUS " High resolution timing supported through mach_absolute_time.")
24 SET(TIME_SPEC_DEFS HAVE_MACH_ABSOLUTE_TIME)
25diff --git a/host/usrp_e_utils/CMakeLists.txt b/host/usrp_e_utils/CMakeLists.txt
26index 9162a20..18414ad 100644
27--- a/host/usrp_e_utils/CMakeLists.txt
28+++ b/host/usrp_e_utils/CMakeLists.txt
29@@ -38,7 +38,7 @@ IF(ENABLE_USRP_E_UTILS)
30 FOREACH(util_source ${usrp_e_utils_sources})
31 GET_FILENAME_COMPONENT(util_name ${util_source} NAME_WE)
32 ADD_EXECUTABLE(${util_name} ${util_source})
33- TARGET_LINK_LIBRARIES(${util_name} ${Boost_LIBRARIES})
34+ TARGET_LINK_LIBRARIES(${util_name} ${Boost_LIBRARIES} -lpthread -lncurses)
35 INSTALL(TARGETS ${util_name} RUNTIME DESTINATION ${PKG_DATA_DIR}/usrp_e_utils)
36 ENDFOREACH(util_source)
37
38--
391.6.6.1
40
diff --git a/meta-oe/recipes-connectivity/uhd/uhd/0001-use-uint8_t-from-boost-namespace.patch b/meta-oe/recipes-connectivity/uhd/uhd/0001-use-uint8_t-from-boost-namespace.patch
deleted file mode 100644
index 8978ddcc4..000000000
--- a/meta-oe/recipes-connectivity/uhd/uhd/0001-use-uint8_t-from-boost-namespace.patch
+++ /dev/null
@@ -1,29 +0,0 @@
1From 317f6f08cedf005ce1f2d6f0d04cfb2659863423 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 30 Jun 2013 22:10:50 -0700
4Subject: [PATCH] use uint8_t from boost namespace
5
6Fixes errors like
7codec_ctrl.cpp:113:10: error: 'uint8_t' was not declared in this scope
8
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 host/lib/usrp/e100/codec_ctrl.cpp | 2 +-
12 1 file changed, 1 insertion(+), 1 deletion(-)
13
14diff --git a/host/lib/usrp/e100/codec_ctrl.cpp b/host/lib/usrp/e100/codec_ctrl.cpp
15index 13b3bc9..2c13176 100644
16--- a/host/lib/usrp/e100/codec_ctrl.cpp
17+++ b/host/lib/usrp/e100/codec_ctrl.cpp
18@@ -110,7 +110,7 @@ e100_codec_ctrl_impl::e100_codec_ctrl_impl(spi_iface::sptr iface){
19 //_ad9862_regs.dis2 = ad9862_regs_t::DIS2_DIS; needed for transmit
20
21 //write the register settings to the codec
22- for (uint8_t addr = 0; addr <= 25; addr++){
23+ for (boost::uint8_t addr = 0; addr <= 25; addr++){
24 this->send_reg(addr);
25 }
26
27--
281.7.9.5
29
diff --git a/meta-oe/recipes-connectivity/uhd/uhd_git.bb b/meta-oe/recipes-connectivity/uhd/uhd_git.bb
deleted file mode 100644
index ee02cc7c2..000000000
--- a/meta-oe/recipes-connectivity/uhd/uhd_git.bb
+++ /dev/null
@@ -1,11 +0,0 @@
1require uhd.inc
2
3PV = "3.5.3"
4PR = "${INC_PR}.0"
5
6SRC_URI = "git://ettus.sourcerepo.com/ettus/uhd.git;branch=maint \
7 file://0001-use-uint8_t-from-boost-namespace.patch;striplevel=2 \
8 "
9S = "${WORKDIR}/git/host"
10
11SRCREV = "f4c58120dc1e3674ee0228213f0f0011a0f80dcf"