diff options
author | Derek Straka <derek@asterius.io> | 2017-11-01 11:37:51 -0400 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2017-11-15 16:31:30 -0800 |
commit | 378b8a6a8aa65fae704e9ceddc3f2e2b07585953 (patch) | |
tree | c0b15f5e19977fd20a87470796ac27e9ae51020b | |
parent | 63791edb3f69269fc6e0b83863e76f6a4a35965c (diff) | |
download | meta-openembedded-378b8a6a8aa65fae704e9ceddc3f2e2b07585953.tar.gz |
python-hyperlink: add a recipe for version 17.3.1
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
3 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-hyperlink.inc b/meta-python/recipes-devtools/python/python-hyperlink.inc new file mode 100644 index 000000000..2b5b0a0ff --- /dev/null +++ b/meta-python/recipes-devtools/python/python-hyperlink.inc | |||
@@ -0,0 +1,17 @@ | |||
1 | DESCRIPTION = "A featureful, correct URL for Python" | ||
2 | HOMEPAGE = "https://github.com/python-hyper/hyperlink" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3893d4ed05dcc823f8ed685a9ea19bcb" | ||
5 | |||
6 | SRC_URI[md5sum] = "eaccb9845b559817e838846669cbc68a" | ||
7 | SRC_URI[sha256sum] = "bc4ffdbde9bdad204d507bd8f554f16bba82dd356f6130cb16f41422909c33bc" | ||
8 | |||
9 | inherit pypi | ||
10 | |||
11 | RDEPENDS_${PN} += "${PYTHON_PN}-stringold ${PYTHON_PN}-netclient" | ||
12 | |||
13 | PACKAGES =. "${PN}-test " | ||
14 | |||
15 | FILES_${PN}-test += " \ | ||
16 | ${PYTHON_SITEPACKAGES_DIR}/hyperlinkt/test \ | ||
17 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-hyperlink_17.3.1.bb b/meta-python/recipes-devtools/python/python-hyperlink_17.3.1.bb new file mode 100644 index 000000000..59a9a5c8d --- /dev/null +++ b/meta-python/recipes-devtools/python/python-hyperlink_17.3.1.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools | ||
2 | require python-hyperlink.inc | ||
diff --git a/meta-python/recipes-devtools/python/python3-hyperlink_17.3.1.bb b/meta-python/recipes-devtools/python/python3-hyperlink_17.3.1.bb new file mode 100644 index 000000000..3d30af29a --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-hyperlink_17.3.1.bb | |||
@@ -0,0 +1,4 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-hyperlink.inc | ||
3 | |||
4 | RDEPENDS_${PN} += "${PYTHON_PN}-selectors ${PYTHON_PN}-enum" | ||