diff options
author | Andreas Müller <schnitzeltony@googlemail.com> | 2016-05-17 01:04:42 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-05-19 12:02:42 +0200 |
commit | 35c3f12876d82a878ca58a63a7fe27b5a19e78fb (patch) | |
tree | 0a127cbe02033f65f9cd2ac4e253fceac53c4ce9 | |
parent | 1d4d6e7f712894a768d2b434a68370aeaba025a1 (diff) | |
download | meta-openembedded-35c3f12876d82a878ca58a63a7fe27b5a19e78fb.tar.gz |
geany-plugins: initial add 1.27
geany-plugins comes around as a loose collection of modules. I thought about
using PACKAGES_DYNAMIC but this way seems better maintainable:
* a removed plugin will at least complain for license file missing
* a new plugin will complain for unpacked files
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-oe/recipes-devtools/geany/geany-plugins_1.27.bb | 216 |
1 files changed, 216 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/geany/geany-plugins_1.27.bb b/meta-oe/recipes-devtools/geany/geany-plugins_1.27.bb new file mode 100644 index 0000000000..08f79bb69e --- /dev/null +++ b/meta-oe/recipes-devtools/geany/geany-plugins_1.27.bb | |||
@@ -0,0 +1,216 @@ | |||
1 | DESCRIPTION = "A fast and lightweight IDE" | ||
2 | HOMEPAGE = "http://plugins.geany.org/" | ||
3 | # majority's default | ||
4 | LICENSE = "GPLv2" | ||
5 | |||
6 | DEPENDS = "geany lua libxml2 libsoup-2.4 vte enchant intltool-native libassuan gpgme" | ||
7 | |||
8 | inherit autotools pkgconfig gtk-icon-cache | ||
9 | |||
10 | SRC_URI = "http://plugins.geany.org/${PN}/${PN}-${PV}.tar.bz2" | ||
11 | SRC_URI[md5sum] = "31e4aa4b771a4ff8ccfd74efe7ba7b44" | ||
12 | SRC_URI[sha256sum] = "03195a0b7a361ddb2ee4138f46fa87b6d9b9801ff00657456ab9c8b8908c0ce0" | ||
13 | |||
14 | FILES_${PN} += "${datadir}/icons" | ||
15 | FILES_${PN}-dev += "${libdir}/geany/*.la ${libdir}/${PN}/*/*.la" | ||
16 | |||
17 | PLUGINS += "${PN}-addons" | ||
18 | LIC_FILES_CHKSUM += "file://addons/COPYING;md5=4325afd396febcb659c36b49533135d4" | ||
19 | FILES_${PN}-addons = "${libdir}/geany/addons.so" | ||
20 | RDEPENDS_${PN}-addons = "${PN}" | ||
21 | |||
22 | PLUGINS += "${PN}-autoclose" | ||
23 | LIC_FILES_CHKSUM += "file://autoclose/COPYING;md5=751419260aa954499f7abaabaa882bbe" | ||
24 | FILES_${PN}-autoclose = "${libdir}/geany/autoclose.so" | ||
25 | RDEPENDS_${PN}-autoclose = "${PN}" | ||
26 | |||
27 | PLUGINS += "${PN}-automark" | ||
28 | LIC_FILES_CHKSUM += "file://automark/COPYING;md5=751419260aa954499f7abaabaa882bbe" | ||
29 | FILES_${PN}-automark = "${libdir}/geany/automark.so" | ||
30 | RDEPENDS_${PN}-automark = "${PN}" | ||
31 | |||
32 | PLUGINS += "${PN}-codenav" | ||
33 | LIC_FILES_CHKSUM += "file://codenav/COPYING;md5=751419260aa954499f7abaabaa882bbe" | ||
34 | FILES_${PN}-codenav = "${libdir}/geany/codenav.so" | ||
35 | RDEPENDS_${PN}-codenav = "${PN}" | ||
36 | |||
37 | PLUGINS += "${PN}-commander" | ||
38 | LIC_FILES_CHKSUM += "file://commander/COPYING;md5=d32239bcb673463ab874e80d47fae504" | ||
39 | LICENSE_${PN}-commander = "GPLv3" | ||
40 | FILES_${PN}-commander = "${libdir}/geany/commander.so" | ||
41 | RDEPENDS_${PN}-commander = "${PN}" | ||
42 | |||
43 | PLUGINS += "${PN}-debugger" | ||
44 | LIC_FILES_CHKSUM += "file://debugger/COPYING;md5=4325afd396febcb659c36b49533135d4" | ||
45 | FILES_${PN}-debugger = "${libdir}/geany/debugger.so ${datadir}/${PN}/debugger" | ||
46 | RDEPENDS_${PN}-debugger = "${PN}" | ||
47 | |||
48 | PLUGINS += "${PN}-defineformat" | ||
49 | LIC_FILES_CHKSUM += "file://defineformat/COPYING;md5=751419260aa954499f7abaabaa882bbe" | ||
50 | FILES_${PN}-defineformat = "${libdir}/geany/defineformat.so" | ||
51 | RDEPENDS_${PN}-defineformat = "${PN}" | ||
52 | |||
53 | PLUGINS += "${PN}-devhelp" | ||
54 | LIC_FILES_CHKSUM += "file://devhelp/COPYING;md5=d32239bcb673463ab874e80d47fae504" | ||
55 | LICENSE_${PN}-devhelp = "GPLv3" | ||
56 | FILES_${PN}-devhelp = "${libdir}/geany/devhelp.so" | ||
57 | RDEPENDS_${PN}-devhelp = "${PN}" | ||
58 | |||
59 | PLUGINS += "${PN}-geanyctags" | ||
60 | LIC_FILES_CHKSUM += "file://geanyctags/COPYING;md5=c107cf754550e65755c42985a5d4e9c9" | ||
61 | FILES_${PN}-geanyctags = "${libdir}/geany/geanyctags.so" | ||
62 | RDEPENDS_${PN}-geanyctags = "${PN}" | ||
63 | |||
64 | PLUGINS += "${PN}-geanydoc" | ||
65 | LIC_FILES_CHKSUM += "file://geanydoc/COPYING;md5=d32239bcb673463ab874e80d47fae504" | ||
66 | LICENSE_${PN}-geanydoc = "GPLv3" | ||
67 | FILES_${PN}-geanydoc = "${libdir}/geany/geanydoc.so" | ||
68 | RDEPENDS_${PN}-geanydoc = "${PN}" | ||
69 | |||
70 | PLUGINS += "${PN}-geanyextrasel" | ||
71 | LIC_FILES_CHKSUM += "file://geanyextrasel/COPYING;md5=c107cf754550e65755c42985a5d4e9c9" | ||
72 | FILES_${PN}-geanyextrasel = "${libdir}/geany/geanyextrasel.so" | ||
73 | RDEPENDS_${PN}-geanyextrasel = "${PN}" | ||
74 | |||
75 | PLUGINS += "${PN}-geanyinsertnum" | ||
76 | LIC_FILES_CHKSUM += "file://geanyinsertnum/COPYING;md5=c107cf754550e65755c42985a5d4e9c9" | ||
77 | FILES_${PN}-geanyinsertnum = "${libdir}/geany/geanyinsertnum.so" | ||
78 | RDEPENDS_${PN}-geanyinsertnum = "${PN}" | ||
79 | |||
80 | PLUGINS += "${PN}-geanylatex" | ||
81 | LIC_FILES_CHKSUM += "file://geanylatex/COPYING;md5=c107cf754550e65755c42985a5d4e9c9" | ||
82 | FILES_${PN}-geanylatex = "${libdir}/geany/geanylatex.so" | ||
83 | RDEPENDS_${PN}-geanylatex = "${PN}" | ||
84 | |||
85 | PLUGINS += "${PN}-geanylipsum" | ||
86 | LIC_FILES_CHKSUM += "file://geanylipsum/COPYING;md5=4325afd396febcb659c36b49533135d4" | ||
87 | FILES_${PN}-geanylipsum = "${libdir}/geany/geanylipsum.so" | ||
88 | RDEPENDS_${PN}-geanylipsum = "${PN}" | ||
89 | |||
90 | PLUGINS += "${PN}-geanylua" | ||
91 | LIC_FILES_CHKSUM += "file://geanylua/COPYING;md5=4325afd396febcb659c36b49533135d4" | ||
92 | FILES_${PN}-geanylua = "${libdir}/geany/geanylua.so ${libdir}/${PN}/geanylua/*.so" | ||
93 | RDEPENDS_${PN}-geanylua = "${PN}" | ||
94 | |||
95 | PLUGINS += "${PN}-geanymacro" | ||
96 | LIC_FILES_CHKSUM += "file://geanymacro/COPYING;md5=c107cf754550e65755c42985a5d4e9c9" | ||
97 | FILES_${PN}-geanymacro = "${libdir}/geany/geanymacro.so" | ||
98 | RDEPENDS_${PN}-geanymacro = "${PN}" | ||
99 | |||
100 | PLUGINS += "${PN}-geanyminiscript" | ||
101 | LIC_FILES_CHKSUM += "file://geanyminiscript/COPYING;md5=4325afd396febcb659c36b49533135d4" | ||
102 | FILES_${PN}-geanyminiscript = "${libdir}/geany/geanyminiscript.so" | ||
103 | RDEPENDS_${PN}-geanyminiscript = "${PN}" | ||
104 | |||
105 | PLUGINS += "${PN}-geanynumberedbookmarks" | ||
106 | LIC_FILES_CHKSUM += "file://geanynumberedbookmarks/COPYING;md5=c107cf754550e65755c42985a5d4e9c9" | ||
107 | FILES_${PN}-geanynumberedbookmarks = "${libdir}/geany/geanynumberedbookmarks.so" | ||
108 | RDEPENDS_${PN}-geanynumberedbookmarks = "${PN}" | ||
109 | |||
110 | PLUGINS += "${PN}-geanypg" | ||
111 | LIC_FILES_CHKSUM += "file://geanypg/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" | ||
112 | FILES_${PN}-geanypg = "${libdir}/geany/geanypg.so" | ||
113 | RDEPENDS_${PN}-geanypg = "${PN}" | ||
114 | |||
115 | PLUGINS += "${PN}-geanyprj" | ||
116 | LIC_FILES_CHKSUM += "file://geanyprj/COPYING;md5=d32239bcb673463ab874e80d47fae504" | ||
117 | LICENSE_${PN}-geanyprj = "GPLv3" | ||
118 | FILES_${PN}-geanyprj = "${libdir}/geany/geanyprj.so" | ||
119 | RDEPENDS_${PN}-geanyprj = "${PN}" | ||
120 | |||
121 | PLUGINS += "${PN}-geanysendmail" | ||
122 | LIC_FILES_CHKSUM += "file://geanysendmail/COPYING;md5=c107cf754550e65755c42985a5d4e9c9" | ||
123 | FILES_${PN}-geanysendmail = "${libdir}/geany/geanysendmail.so" | ||
124 | RDEPENDS_${PN}-geanysendmail = "${PN}" | ||
125 | |||
126 | PLUGINS += "${PN}-geanyvc" | ||
127 | LIC_FILES_CHKSUM += "file://geanyvc/COPYING;md5=c107cf754550e65755c42985a5d4e9c9" | ||
128 | FILES_${PN}-geanyvc = "${libdir}/geany/geanyvc.so" | ||
129 | RDEPENDS_${PN}-geanyvc = "${PN}" | ||
130 | |||
131 | PLUGINS += "${PN}-geniuspaste" | ||
132 | LIC_FILES_CHKSUM += "file://geniuspaste/COPYING;md5=bfc203269f8862ebfc1198cdc809a95a" | ||
133 | FILES_${PN}-geniuspaste = "${libdir}/geany/geniuspaste.so ${datadir}/${PN}/geniuspaste" | ||
134 | RDEPENDS_${PN}-geniuspaste = "${PN}" | ||
135 | |||
136 | PLUGINS += "${PN}-lineoperations" | ||
137 | LIC_FILES_CHKSUM += "file://lineoperations/COPYING;md5=c107cf754550e65755c42985a5d4e9c9" | ||
138 | FILES_${PN}-lineoperations = "${libdir}/geany/lineoperations.so" | ||
139 | RDEPENDS_${PN}-lineoperations = "${PN}" | ||
140 | |||
141 | PLUGINS += "${PN}-multiterm" | ||
142 | LIC_FILES_CHKSUM += "file://multiterm/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" | ||
143 | FILES_${PN}-multiterm = "${libdir}/geany/multiterm.so" | ||
144 | RDEPENDS_${PN}-multiterm = "${PN}" | ||
145 | |||
146 | PLUGINS += "${PN}-overview" | ||
147 | LIC_FILES_CHKSUM += "file://overview/overview/overviewplugin.c;beginline=4;endline=20;md5=1aa33522916cdeb46cccac0c629da0d0" | ||
148 | FILES_${PN}-overview = "${libdir}/geany/overview.so ${datadir}/${PN}/overview" | ||
149 | RDEPENDS_${PN}-overview = "${PN}" | ||
150 | |||
151 | PLUGINS += "${PN}-pairtaghighlighter" | ||
152 | LICENSE_${PN}-pairtaghighlighter = "BSD-2-Clause" | ||
153 | LIC_FILES_CHKSUM += "file://pairtaghighlighter/COPYING;md5=d6d927525a612b3a8dbebc4b2e9b47c1" | ||
154 | FILES_${PN}-pairtaghighlighter = "${libdir}/geany/pairtaghighlighter.so" | ||
155 | RDEPENDS_${PN}-pairtaghighlighter = "${PN}" | ||
156 | |||
157 | PLUGINS += "${PN}-pohelper" | ||
158 | LICENSE_${PN}-pohelper = "GPLv3" | ||
159 | LIC_FILES_CHKSUM += "file://pohelper/COPYING;md5=d32239bcb673463ab874e80d47fae504" | ||
160 | FILES_${PN}-pohelper = "${libdir}/geany/pohelper.so" | ||
161 | RDEPENDS_${PN}-pohelper = "${PN}" | ||
162 | |||
163 | PLUGINS += "${PN}-pretty-printer" | ||
164 | LIC_FILES_CHKSUM += "file://pretty-printer/src/PrettyPrinter.c;beginline=1;endline=17;md5=1665115c2fadb17c1b53cdb4e43b2440" | ||
165 | FILES_${PN}-pretty-printer = "${libdir}/geany/pretty-printer.so" | ||
166 | RDEPENDS_${PN}-pretty-printer = "${PN}" | ||
167 | |||
168 | PLUGINS += "${PN}-projectorganizer" | ||
169 | LIC_FILES_CHKSUM += "file://projectorganizer/COPYING;md5=c107cf754550e65755c42985a5d4e9c9" | ||
170 | FILES_${PN}-projectorganizer = "${libdir}/geany/projectorganizer.so" | ||
171 | RDEPENDS_${PN}-projectorganizer = "${PN}" | ||
172 | |||
173 | PLUGINS += "${PN}-shiftcolumn" | ||
174 | LIC_FILES_CHKSUM += "file://shiftcolumn/COPYING;md5=751419260aa954499f7abaabaa882bbe" | ||
175 | FILES_${PN}-shiftcolumn = "${libdir}/geany/shiftcolumn.so" | ||
176 | RDEPENDS_${PN}-shiftcolumn = "${PN}" | ||
177 | |||
178 | PLUGINS += "${PN}-scope" | ||
179 | LIC_FILES_CHKSUM += "file://scope/COPYING;md5=c107cf754550e65755c42985a5d4e9c9" | ||
180 | FILES_${PN}-scope = "${libdir}/geany/scope.so" | ||
181 | RDEPENDS_${PN}-scope = "${PN}" | ||
182 | |||
183 | PLUGINS += "${PN}-spellcheck" | ||
184 | LIC_FILES_CHKSUM += "file://spellcheck/COPYING;md5=4325afd396febcb659c36b49533135d4" | ||
185 | FILES_${PN}-spellcheck = "${libdir}/geany/spellcheck.so" | ||
186 | RDEPENDS_${PN}-spellcheck = "${PN}" | ||
187 | |||
188 | PLUGINS += "${PN}-tableconvert" | ||
189 | LIC_FILES_CHKSUM += "file://tableconvert/COPYING;md5=6753686878d090a1f3f9445661d3dfbc" | ||
190 | FILES_${PN}-tableconvert = "${libdir}/geany/tableconvert.so" | ||
191 | RDEPENDS_${PN}-tableconvert = "${PN}" | ||
192 | |||
193 | PLUGINS += "${PN}-treebrowser" | ||
194 | LIC_FILES_CHKSUM += "file://treebrowser/README;beginline=67;endline=67;md5=52f90857fd1a9672111e472dd056a0d8" | ||
195 | FILES_${PN}-treebrowser = "${libdir}/geany/treebrowser.so" | ||
196 | RDEPENDS_${PN}-treebrowser = "${PN}" | ||
197 | |||
198 | PLUGINS += "${PN}-updatechecker" | ||
199 | LIC_FILES_CHKSUM += "file://updatechecker/COPYING;md5=4325afd396febcb659c36b49533135d4" | ||
200 | FILES_${PN}-updatechecker = "${libdir}/geany/updatechecker.so" | ||
201 | RDEPENDS_${PN}-updatechecker = "${PN}" | ||
202 | |||
203 | PLUGINS += "${PN}-webhelper" | ||
204 | LIC_FILES_CHKSUM += "file://webhelper/COPYING;md5=d32239bcb673463ab874e80d47fae504" | ||
205 | LICENSE_${PN}-webhelper = "GPLv3" | ||
206 | FILES_${PN}-webhelper = "${libdir}/geany/webhelper.so" | ||
207 | RDEPENDS_${PN}-webhelper = "${PN}" | ||
208 | |||
209 | PLUGINS += "${PN}-xmlsnippets" | ||
210 | LIC_FILES_CHKSUM += "file://xmlsnippets/COPYING;md5=4325afd396febcb659c36b49533135d4" | ||
211 | FILES_${PN}-xmlsnippets = "${libdir}/geany/xmlsnippets.so" | ||
212 | RDEPENDS_${PN}-xmlsnippets = "${PN}" | ||
213 | |||
214 | PACKAGES =+ "${PLUGINS}" | ||
215 | RDEPENDS_${PN} = "${PLUGINS}" | ||
216 | ALLOW_EMPTY_${PN} = "1" | ||