summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-08-31 20:10:21 -0700
committerKhem Raj <raj.khem@gmail.com>2022-09-05 22:49:34 -0700
commit31e19562f6b9a097e18a5c41a0be546ded4a3a20 (patch)
treecc0c2945ad0dabb0ba994ef09a85f9a52ed8c021
parentb487187a933d429fa947cd1c083f052bf153e0c8 (diff)
downloadmeta-openembedded-31e19562f6b9a097e18a5c41a0be546ded4a3a20.tar.gz
android-tools: Add protoype declaration for b64_pton
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/android-tools/android-tools/core/b64_pton_function_decl.patch14
-rw-r--r--meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb1
2 files changed, 15 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/android-tools/android-tools/core/b64_pton_function_decl.patch b/meta-oe/recipes-devtools/android-tools/android-tools/core/b64_pton_function_decl.patch
new file mode 100644
index 000000000..80410f1d2
--- /dev/null
+++ b/meta-oe/recipes-devtools/android-tools/android-tools/core/b64_pton_function_decl.patch
@@ -0,0 +1,14 @@
1Add protoype declaration for b64_pton
2
3Upstream-Status: Pending
4Signed-off-by: Khem Raj <raj.khem@gmail.com>
5--- a/adb/adb_auth_client.c
6+++ b/adb/adb_auth_client.c
7@@ -29,6 +29,7 @@
8
9 #define TRACE_TAG TRACE_AUTH
10
11+extern int b64_pton(const char* src, uint8_t* target, size_t targsize);
12
13 struct adb_public_key {
14 struct listnode node;
diff --git a/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb b/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb
index 26393605d..37e72de2a 100644
--- a/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb
+++ b/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb
@@ -39,6 +39,7 @@ SRC_URI = " \
39 file://core/0011-Remove-bionic-specific-calls.patch;patchdir=system/core \ 39 file://core/0011-Remove-bionic-specific-calls.patch;patchdir=system/core \
40 file://core/0012-Fix-implicit-declaration-of-stlcat-strlcopy-function.patch;patchdir=system/core \ 40 file://core/0012-Fix-implicit-declaration-of-stlcat-strlcopy-function.patch;patchdir=system/core \
41 file://core/adb_libssl_11.diff;patchdir=system/core \ 41 file://core/adb_libssl_11.diff;patchdir=system/core \
42 file://core/b64_pton_function_decl.patch;patchdir=system/core \
42 file://core/0013-adb-Support-riscv64.patch;patchdir=system/core \ 43 file://core/0013-adb-Support-riscv64.patch;patchdir=system/core \
43 file://core/0014-add-u3-ss-descriptor-support-for-adb.patch;patchdir=system/core \ 44 file://core/0014-add-u3-ss-descriptor-support-for-adb.patch;patchdir=system/core \
44 file://core/0015-libsparse-Split-off-most-of-sparse_file_read_normal-.patch;patchdir=system/core \ 45 file://core/0015-libsparse-Split-off-most-of-sparse_file_read_normal-.patch;patchdir=system/core \