summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2021-03-24 16:23:07 +0800
committerKhem Raj <raj.khem@gmail.com>2021-03-26 10:34:21 -0700
commit301a0a2cd930f292a31bdb58b5e66882eff8a3e4 (patch)
tree158ffe16757dce7fec2e4989b46336bae29b608b
parenta81380029ef5fa730a292ce203c973fee9e42f6a (diff)
downloadmeta-openembedded-301a0a2cd930f292a31bdb58b5e66882eff8a3e4.tar.gz
tclap: add pkg-config file
The tclap switched from autotools to CMake in 1.4.0 and drop the pkg-config file tclap.pc. Some projects (e.g. ima-inspect) still require it. So add it back. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/tclap/files/0001-tclap-add-pkg-config-file.patch50
-rw-r--r--meta-oe/recipes-devtools/tclap/tclap_1.4.0.bb1
2 files changed, 51 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/tclap/files/0001-tclap-add-pkg-config-file.patch b/meta-oe/recipes-devtools/tclap/files/0001-tclap-add-pkg-config-file.patch
new file mode 100644
index 000000000..58c9aec08
--- /dev/null
+++ b/meta-oe/recipes-devtools/tclap/files/0001-tclap-add-pkg-config-file.patch
@@ -0,0 +1,50 @@
1From 9d47d2fd45c455339759dbfe9a0d6fd24b0a0fa1 Mon Sep 17 00:00:00 2001
2From: Yi Zhao <yi.zhao@windriver.com>
3Date: Wed, 24 Mar 2021 15:39:36 +0800
4Subject: [PATCH] tclap: add pkg-config file
5
6The tclap switched from autotools to CMake in 1.4.0 and drop the
7pkg-config file tclap.pc. Some projects (e.g. ima-inspect) still require
8it. So add it back.
9
10Upstream-Status: Pending
11
12Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
13---
14 CMakeLists.txt | 5 +++++
15 tclap.pc.in | 7 +++++++
16 2 files changed, 12 insertions(+)
17 create mode 100644 tclap.pc.in
18
19diff --git a/CMakeLists.txt b/CMakeLists.txt
20index c2c9a26..b56eac7 100644
21--- a/CMakeLists.txt
22+++ b/CMakeLists.txt
23@@ -25,6 +25,11 @@ install(FILES "${PROJECT_BINARY_DIR}/tclap/TCLAPConfig.h"
24 DESTINATION include/tclap
25 )
26
27+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/tclap.pc.in
28+ ${CMAKE_CURRENT_BINARY_DIR}/tclap.pc @ONLY)
29+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/tclap.pc
30+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
31+
32 add_subdirectory(docs)
33 add_subdirectory(examples)
34 add_subdirectory(tests)
35diff --git a/tclap.pc.in b/tclap.pc.in
36new file mode 100644
37index 0000000..ef51c94
38--- /dev/null
39+++ b/tclap.pc.in
40@@ -0,0 +1,7 @@
41+prefix=@CMAKE_INSTALL_PREFIX@
42+includedir=${prefix}/@CMAKE_INSTALL_INCLUDEDIR@
43+
44+Name: tclap
45+Description: Templatized C++ Command Line Parser
46+Version: @PROJECT_VERSION@
47+Cflags: -I${includedir}
48--
492.17.1
50
diff --git a/meta-oe/recipes-devtools/tclap/tclap_1.4.0.bb b/meta-oe/recipes-devtools/tclap/tclap_1.4.0.bb
index 13f66e47d..7c8224b57 100644
--- a/meta-oe/recipes-devtools/tclap/tclap_1.4.0.bb
+++ b/meta-oe/recipes-devtools/tclap/tclap_1.4.0.bb
@@ -12,6 +12,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=5c64b2e8cc50917b2744a90950faa7cd"
12 12
13SRCREV = "799a8b1f99818e39fee19d0601030770af1221e1" 13SRCREV = "799a8b1f99818e39fee19d0601030770af1221e1"
14SRC_URI = "git://git.code.sf.net/p/tclap/code;branch=1.4 \ 14SRC_URI = "git://git.code.sf.net/p/tclap/code;branch=1.4 \
15 file://0001-tclap-add-pkg-config-file.patch \
15" 16"
16 17
17S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"