summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2025-01-17 18:59:38 +0000
committerKhem Raj <raj.khem@gmail.com>2025-01-17 11:29:12 -0800
commit2c9f19d7973647a638c0af5e0c2ae99fe0ebf8c9 (patch)
tree243dc6049da0850e65f0cf3c9661367d536dd23d
parenta3edd4f6d7b5fb4291db80dded74c810bb98c07c (diff)
downloadmeta-openembedded-2c9f19d7973647a638c0af5e0c2ae99fe0ebf8c9.tar.gz
python3-requests-file: update recipe to use the ptest-python-pytest class
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-requests-file/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-requests-file_2.1.0.bb16
2 files changed, 1 insertions, 18 deletions
diff --git a/meta-python/recipes-devtools/python/python3-requests-file/run-ptest b/meta-python/recipes-devtools/python/python3-requests-file/run-ptest
deleted file mode 100644
index 8d2017d39c..0000000000
--- a/meta-python/recipes-devtools/python/python3-requests-file/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@
1#!/bin/sh
2
3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-requests-file_2.1.0.bb b/meta-python/recipes-devtools/python/python3-requests-file_2.1.0.bb
index 670a36a64c..6e20a10f42 100644
--- a/meta-python/recipes-devtools/python/python3-requests-file_2.1.0.bb
+++ b/meta-python/recipes-devtools/python/python3-requests-file_2.1.0.bb
@@ -8,24 +8,10 @@ SRC_URI[sha256sum] = "0f549a3f3b0699415ac04d167e9cb39bccfb730cb832b4d20be3d98673
8PYPI_PACKAGE = "requests_file" 8PYPI_PACKAGE = "requests_file"
9UPSTREAM_CHECK_PYPI_PACKAGE = "${PYPI_PACKAGE}" 9UPSTREAM_CHECK_PYPI_PACKAGE = "${PYPI_PACKAGE}"
10 10
11inherit pypi python_setuptools_build_meta ptest 11inherit pypi python_setuptools_build_meta ptest-python-pytest
12
13SRC_URI += " \
14 file://run-ptest \
15"
16 12
17DEPENDS += "python3-setuptools-scm-native" 13DEPENDS += "python3-setuptools-scm-native"
18 14
19RDEPENDS:${PN}-ptest += " \
20 python3-pytest \
21 python3-unittest-automake-output \
22"
23
24do_install_ptest() {
25 install -d ${D}${PTEST_PATH}/tests
26 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
27}
28
29RDEPENDS:${PN} += " \ 15RDEPENDS:${PN} += " \
30 python3-requests \ 16 python3-requests \
31" 17"