summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-12-19 14:46:31 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2012-12-19 17:48:14 +0100
commit2b4ec7cd91de4620abe5694d5aac6407bb143835 (patch)
tree6212a3b51b86baf27793f49bee7a66bdc965754d
parentade2d4d35e1efdd83bb555949bcfb8c7a1970ff0 (diff)
downloadmeta-openembedded-2b4ec7cd91de4620abe5694d5aac6407bb143835.tar.gz
python-pyudev: upgrade to 0.16.1 and fix some issues
* RDEPENDing on libudev always selects udev as provider (even when systemd should be used), for details see: https://bugzilla.yoctoproject.org/show_bug.cgi?id=3622 * don't import pyudev from setup.py to get right pyudev version, this does not work without pyudev installed Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/python/python-pyudev_0.16.1.bb (renamed from meta-oe/recipes-devtools/python/python-pyudev_0.11.bb)11
1 files changed, 7 insertions, 4 deletions
diff --git a/meta-oe/recipes-devtools/python/python-pyudev_0.11.bb b/meta-oe/recipes-devtools/python/python-pyudev_0.16.1.bb
index 0e8d80aef..ec54b4403 100644
--- a/meta-oe/recipes-devtools/python/python-pyudev_0.11.bb
+++ b/meta-oe/recipes-devtools/python/python-pyudev_0.16.1.bb
@@ -3,20 +3,23 @@ HOMEPAGE = "http://pypi.python.org/pypi/pyudev"
3SECTION = "devel/python" 3SECTION = "devel/python"
4LICENSE = "GPLv2" 4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343" 5LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343"
6PR = "r2"
7 6
8SRCNAME = "pyudev" 7SRCNAME = "pyudev"
9SRC_URI = "http://pypi.python.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz" 8SRC_URI = "http://pypi.python.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
10SRC_URI[md5sum] = "dca4e69da387f9a6683ee4b5c27ca66a" 9SRC_URI[md5sum] = "4034de584b6d9efcbfc590a047c63285"
11SRC_URI[sha256sum] = "0acfa500219f4bcf711f35c1b2041d035b4bf5f302eca5038572ee788d9e584a" 10SRC_URI[sha256sum] = "765d1c14bd9bd031f64e2612225621984cb2bbb8cbc0c03538bcc4c735ff1c95"
12 11
13S = "${WORKDIR}/${SRCNAME}-${PV}" 12S = "${WORKDIR}/${SRCNAME}-${PV}"
14 13
15inherit setuptools 14inherit setuptools
16 15
16do_configure_prepend() {
17 sed -i "/import pyudev/d" ${S}/setup.py
18 sed -i "s/str(pyudev.__version__)/'${PV}'/g" ${S}/setup.py
19}
20
17RDEPENDS_${PN} = "\ 21RDEPENDS_${PN} = "\
18 python-ctypes \ 22 python-ctypes \
19 python-subprocess \ 23 python-subprocess \
20 python-misc \ 24 python-misc \
21 libudev \
22" 25"