summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-02-04 16:18:12 -0800
committerKhem Raj <raj.khem@gmail.com>2021-02-04 17:33:51 -0800
commit290d4ce30cc9da0d755b92dc9dbc44967a924d30 (patch)
tree5fada592aded2975cf30eb67c7cdcc8d47adc34c
parentf9f931719640503292fa429da12a082008d0056d (diff)
downloadmeta-openembedded-290d4ce30cc9da0d755b92dc9dbc44967a924d30.tar.gz
libsrtp: Update to 2.3.0
Drop the local patch, problem is fixed upstream a bit differently License-Update: Bumped Copyright years [1] [1] https://github.com/cisco/libsrtp/commit/445c1c94dc3df48fb633779d1b5d0b743bf522a4 Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-multimedia/recipes-support/libsrtp/libsrtp/0001-Rename-conflicting-variable-mips.patch73
-rw-r--r--meta-multimedia/recipes-support/libsrtp/libsrtp_1.6.0.bb18
-rw-r--r--meta-multimedia/recipes-support/libsrtp/libsrtp_2.3.0.bb16
3 files changed, 16 insertions, 91 deletions
diff --git a/meta-multimedia/recipes-support/libsrtp/libsrtp/0001-Rename-conflicting-variable-mips.patch b/meta-multimedia/recipes-support/libsrtp/libsrtp/0001-Rename-conflicting-variable-mips.patch
deleted file mode 100644
index b56c78959..000000000
--- a/meta-multimedia/recipes-support/libsrtp/libsrtp/0001-Rename-conflicting-variable-mips.patch
+++ /dev/null
@@ -1,73 +0,0 @@
1From 3dc8a678a844247d0afcf7e30fb3cbd5ccbd828f Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 29 Jun 2017 14:05:06 -0700
4Subject: [PATCH] Rename conflicting variable 'mips'
5
6Fixes
7test/srtp_driver.c:344:12: error: expected identifier or '(' before numeric constant
8 double mips = mips_estimate(1000000000, &ignore);
9
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 test/srtp_driver.c | 20 ++++++++++----------
13 1 file changed, 10 insertions(+), 10 deletions(-)
14
15diff --git a/test/srtp_driver.c b/test/srtp_driver.c
16index 8872971..d38ea19 100644
17--- a/test/srtp_driver.c
18+++ b/test/srtp_driver.c
19@@ -341,7 +341,7 @@ main (int argc, char *argv[]) {
20 if (do_codec_timing) {
21 srtp_policy_t policy;
22 int ignore;
23- double mips = mips_estimate(1000000000, &ignore);
24+ double est = mips_estimate(1000000000, &ignore);
25
26 crypto_policy_set_rtp_default(&policy.rtp);
27 crypto_policy_set_rtcp_default(&policy.rtcp);
28@@ -353,33 +353,33 @@ main (int argc, char *argv[]) {
29 policy.allow_repeat_tx = 0;
30 policy.next = NULL;
31
32- printf("mips estimate: %e\n", mips);
33+ printf("mips estimate: %e\n", est);
34
35 printf("testing srtp processing time for voice codecs:\n");
36 printf("codec\t\tlength (octets)\t\tsrtp instructions/second\n");
37 printf("G.711\t\t%d\t\t\t%e\n", 80,
38- (double) mips * (80 * 8) /
39+ (double) est * (80 * 8) /
40 srtp_bits_per_second(80, &policy) / .01 );
41 printf("G.711\t\t%d\t\t\t%e\n", 160,
42- (double) mips * (160 * 8) /
43+ (double) est * (160 * 8) /
44 srtp_bits_per_second(160, &policy) / .02);
45 printf("G.726-32\t%d\t\t\t%e\n", 40,
46- (double) mips * (40 * 8) /
47+ (double) est * (40 * 8) /
48 srtp_bits_per_second(40, &policy) / .01 );
49 printf("G.726-32\t%d\t\t\t%e\n", 80,
50- (double) mips * (80 * 8) /
51+ (double) est * (80 * 8) /
52 srtp_bits_per_second(80, &policy) / .02);
53 printf("G.729\t\t%d\t\t\t%e\n", 10,
54- (double) mips * (10 * 8) /
55+ (double) est * (10 * 8) /
56 srtp_bits_per_second(10, &policy) / .01 );
57 printf("G.729\t\t%d\t\t\t%e\n", 20,
58- (double) mips * (20 * 8) /
59+ (double) est * (20 * 8) /
60 srtp_bits_per_second(20, &policy) / .02 );
61 printf("Wideband\t%d\t\t\t%e\n", 320,
62- (double) mips * (320 * 8) /
63+ (double) est * (320 * 8) /
64 srtp_bits_per_second(320, &policy) / .01 );
65 printf("Wideband\t%d\t\t\t%e\n", 640,
66- (double) mips * (640 * 8) /
67+ (double) est * (640 * 8) /
68 srtp_bits_per_second(640, &policy) / .02 );
69 }
70
71--
722.13.2
73
diff --git a/meta-multimedia/recipes-support/libsrtp/libsrtp_1.6.0.bb b/meta-multimedia/recipes-support/libsrtp/libsrtp_1.6.0.bb
deleted file mode 100644
index 6c868185f..000000000
--- a/meta-multimedia/recipes-support/libsrtp/libsrtp_1.6.0.bb
+++ /dev/null
@@ -1,18 +0,0 @@
1DESCRIPTION = "library implementing Secure RTP (RFC 3711)"
2HOMEPAGE = "https://github.com/cisco/libsrtp"
3SECTION = "libs"
4
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=15bc16b9d2e305974dde47e733883714"
7
8S = "${WORKDIR}/git"
9SRCREV = "2b091a4fb21c9b06fc5d4b5763bdaec97542fcd7"
10SRC_URI = "git://github.com/cisco/libsrtp.git;protocol=https;branch=1_6_x_throttle; \
11 file://0001-Rename-conflicting-variable-mips.patch \
12 "
13
14inherit autotools pkgconfig
15
16EXTRA_OEMAKE += "shared_library"
17
18ALLOW_EMPTY_${PN} = "1"
diff --git a/meta-multimedia/recipes-support/libsrtp/libsrtp_2.3.0.bb b/meta-multimedia/recipes-support/libsrtp/libsrtp_2.3.0.bb
new file mode 100644
index 000000000..57b6108a9
--- /dev/null
+++ b/meta-multimedia/recipes-support/libsrtp/libsrtp_2.3.0.bb
@@ -0,0 +1,16 @@
1DESCRIPTION = "library implementing Secure RTP (RFC 3711)"
2HOMEPAGE = "https://github.com/cisco/libsrtp"
3SECTION = "libs"
4
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=2909fcf6f09ffff8430463d91c08c4e1"
7
8S = "${WORKDIR}/git"
9SRCREV = "d02d21111e379c297e93a9033d7b653135f732ee"
10SRC_URI = "git://github.com/cisco/libsrtp.git"
11
12inherit autotools pkgconfig
13
14EXTRA_OEMAKE += "shared_library"
15
16ALLOW_EMPTY_${PN} = "1"