diff options
author | wangmy <wangmy@fujitsu.com> | 2022-06-27 14:59:18 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-07-02 11:37:02 -0400 |
commit | 2866fc83fd1b93cff0874d1f6eae5bdf53a94aae (patch) | |
tree | adec719c6ba50314b91c226356972f5c3c699b4d | |
parent | 05cf0fdf464988c50e0559f864609f0aa8e44b58 (diff) | |
download | meta-openembedded-2866fc83fd1b93cff0874d1f6eae5bdf53a94aae.tar.gz |
gperftools: upgrade 2.9.1 -> 2.10
ppc-musl.patch
refreshed for new version.
Changelog:
==========
* Matt T. Proud contributed documentation fix to call Go programming language
by it's true name instead of golang.
* Robert Scott contributed debugallocator feature to use readable (PROT_READ)
fence pages. This is activated by TCMALLOC_PAGE_FENCE_READABLE environment veriable.
* User stdpain contributed fix for cmake detection of libunwind.
* Natale Patriciello contributed fix for OSX Monterey support.
* Volodymyr Nikolaichuk contributed support for returning memory back to OS by
using mmap with MAP_FIXED and PROT_NONE. It is off by default and enabled by
preprocessor define: FREE_MMAP_PROT_NONE. This should help OSes that don't
support Linux-style madvise MADV_DONTNEED or BSD-style MADV_FREE.
* Jingyun Hua has contributed basic support for LoongArch.
* Github issue #1338 of failing to build on some recent musl versions has been fixed.
* Github issue #1321 of failing to ship cmake bits with .tar.gz archive has been fixed.
Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/recipes-support/gperftools/gperftools/ppc-musl.patch | 19 | ||||
-rw-r--r-- | meta-oe/recipes-support/gperftools/gperftools_2.10.bb (renamed from meta-oe/recipes-support/gperftools/gperftools_2.9.1.bb) | 2 |
2 files changed, 18 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/gperftools/gperftools/ppc-musl.patch b/meta-oe/recipes-support/gperftools/gperftools/ppc-musl.patch index 4cf182ad64..d06b6af229 100644 --- a/meta-oe/recipes-support/gperftools/gperftools/ppc-musl.patch +++ b/meta-oe/recipes-support/gperftools/gperftools/ppc-musl.patch | |||
@@ -1,10 +1,21 @@ | |||
1 | Compatibility fixes for musl. | 1 | From 328805fd16930deefda400a77e9c2c5d17d04d29 Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 13 Mar 2021 00:42:25 -0800 | ||
4 | Subject: [PATCH] Compatibility fixes for musl. | ||
2 | 5 | ||
6 | --- | ||
7 | m4/pc_from_ucontext.m4 | 4 +++- | ||
8 | src/getpc.h | 3 +++ | ||
9 | src/stacktrace_powerpc-linux-inl.h | 8 ++++++-- | ||
10 | 3 files changed, 12 insertions(+), 3 deletions(-) | ||
11 | |||
12 | diff --git a/m4/pc_from_ucontext.m4 b/m4/pc_from_ucontext.m4 | ||
13 | index 7f09dd7..5f4ee8c 100644 | ||
3 | --- a/m4/pc_from_ucontext.m4 | 14 | --- a/m4/pc_from_ucontext.m4 |
4 | +++ b/m4/pc_from_ucontext.m4 | 15 | +++ b/m4/pc_from_ucontext.m4 |
5 | @@ -34,6 +34,7 @@ AC_DEFUN([AC_PC_FROM_UCONTEXT], | 16 | @@ -34,6 +34,7 @@ AC_DEFUN([AC_PC_FROM_UCONTEXT], |
17 | pc_fields="$pc_fields uc_mcontext.gregs[[R15]]" # Linux (arm old [untested]) | ||
6 | pc_fields="$pc_fields uc_mcontext.arm_pc" # Linux (arm arch 5) | 18 | pc_fields="$pc_fields uc_mcontext.arm_pc" # Linux (arm arch 5) |
7 | pc_fields="$pc_fields uc_mcontext.cr0_hi" # Linux (e2k) | ||
8 | pc_fields="$pc_fields uc_mcontext.gp_regs[[PT_NIP]]" # Suse SLES 11 (ppc64) | 19 | pc_fields="$pc_fields uc_mcontext.gp_regs[[PT_NIP]]" # Suse SLES 11 (ppc64) |
9 | + pc_fields="$pc_fields uc_mcontext.gregs[[PT_NIP]]" | 20 | + pc_fields="$pc_fields uc_mcontext.gregs[[PT_NIP]]" |
10 | pc_fields="$pc_fields uc_mcontext.mc_eip" # FreeBSD (i386) | 21 | pc_fields="$pc_fields uc_mcontext.mc_eip" # FreeBSD (i386) |
@@ -20,6 +31,8 @@ Compatibility fixes for musl. | |||
20 | [ucontext_t u; return u.$pc_field == 0;], | 31 | [ucontext_t u; return u.$pc_field == 0;], |
21 | AC_DEFINE_UNQUOTED(PC_FROM_UCONTEXT, $pc_field, | 32 | AC_DEFINE_UNQUOTED(PC_FROM_UCONTEXT, $pc_field, |
22 | How to access the PC from a struct ucontext) | 33 | How to access the PC from a struct ucontext) |
34 | diff --git a/src/getpc.h b/src/getpc.h | ||
35 | index 9605363..cd8ccfa 100644 | ||
23 | --- a/src/getpc.h | 36 | --- a/src/getpc.h |
24 | +++ b/src/getpc.h | 37 | +++ b/src/getpc.h |
25 | @@ -68,6 +68,9 @@ | 38 | @@ -68,6 +68,9 @@ |
@@ -32,6 +45,8 @@ Compatibility fixes for musl. | |||
32 | 45 | ||
33 | // Take the example where function Foo() calls function Bar(). For | 46 | // Take the example where function Foo() calls function Bar(). For |
34 | // many architectures, Bar() is responsible for setting up and tearing | 47 | // many architectures, Bar() is responsible for setting up and tearing |
48 | diff --git a/src/stacktrace_powerpc-linux-inl.h b/src/stacktrace_powerpc-linux-inl.h | ||
49 | index a301a46..efca426 100644 | ||
35 | --- a/src/stacktrace_powerpc-linux-inl.h | 50 | --- a/src/stacktrace_powerpc-linux-inl.h |
36 | +++ b/src/stacktrace_powerpc-linux-inl.h | 51 | +++ b/src/stacktrace_powerpc-linux-inl.h |
37 | @@ -186,7 +186,7 @@ static int GET_STACK_TRACE_OR_FRAMES { | 52 | @@ -186,7 +186,7 @@ static int GET_STACK_TRACE_OR_FRAMES { |
diff --git a/meta-oe/recipes-support/gperftools/gperftools_2.9.1.bb b/meta-oe/recipes-support/gperftools/gperftools_2.10.bb index d056622b2b..602a7e263a 100644 --- a/meta-oe/recipes-support/gperftools/gperftools_2.9.1.bb +++ b/meta-oe/recipes-support/gperftools/gperftools_2.10.bb | |||
@@ -10,7 +10,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=762732742c73dc6c7fbe8632f06c059a" | |||
10 | 10 | ||
11 | DEPENDS:append:libc-musl = " libucontext" | 11 | DEPENDS:append:libc-musl = " libucontext" |
12 | 12 | ||
13 | SRCREV = "f7c6fb6c8e99d6b1b725e5994373bcd19ffdf8fd" | 13 | SRCREV = "bf8b714bf5075d0a6f2f28504b43095e2b1e11c5" |
14 | SRC_URI = "git://github.com/gperftools/gperftools;branch=master;protocol=https \ | 14 | SRC_URI = "git://github.com/gperftools/gperftools;branch=master;protocol=https \ |
15 | file://0001-Support-Atomic-ops-on-clang.patch \ | 15 | file://0001-Support-Atomic-ops-on-clang.patch \ |
16 | file://0001-fix-build-with-musl-libc.patch \ | 16 | file://0001-fix-build-with-musl-libc.patch \ |