summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordengke.du@windriver.com <dengke.du@windriver.com>2018-12-06 14:39:30 +0800
committerKhem Raj <raj.khem@gmail.com>2018-12-06 08:11:52 -0800
commit23c01539423e6e32e86f8730195d294377a22b80 (patch)
tree299ca336574a0357ae1c0ec01d49b152120f6dc6
parent047dc65d98ebed357d314ffc24db08e9b79bb10e (diff)
downloadmeta-openembedded-23c01539423e6e32e86f8730195d294377a22b80.tar.gz
mce-test: add it
Signed-off-by: Dengke Du <dengke.du@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/mcelog/mce-test/makefile-remove-ldflags.patch23
-rw-r--r--meta-oe/recipes-support/mcelog/mce-test_git.bb30
2 files changed, 53 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/mcelog/mce-test/makefile-remove-ldflags.patch b/meta-oe/recipes-support/mcelog/mce-test/makefile-remove-ldflags.patch
new file mode 100644
index 000000000..0ffedd2c1
--- /dev/null
+++ b/meta-oe/recipes-support/mcelog/mce-test/makefile-remove-ldflags.patch
@@ -0,0 +1,23 @@
1Remove the default CFLAGS and LDFLAGS in Makefile. Ensure the extra linker flags can be passed.
2
3Upstream-Status: Inappropriate [embedded specific]
4
5Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
6
7diff --git a/cases/stress/hwpoison/Makefile b/cases/stress/hwpoison/Makefile
8index da1cbd8..dec5b14 100644
9--- a/cases/stress/hwpoison/Makefile
10+++ b/cases/stress/hwpoison/Makefile
11@@ -1,8 +1,8 @@
12-CFLAGS := -g -Wall
13-LDFLAGS := -g
14+#CFLAGS := -g -Wall
15+#LDFLAGS := -g
16
17-export CFLAGS
18-export LDFLAGS
19+#export CFLAGS
20+#export LDFLAGS
21
22 all:
23 mkdir -p bin
diff --git a/meta-oe/recipes-support/mcelog/mce-test_git.bb b/meta-oe/recipes-support/mcelog/mce-test_git.bb
new file mode 100644
index 000000000..888c729b3
--- /dev/null
+++ b/meta-oe/recipes-support/mcelog/mce-test_git.bb
@@ -0,0 +1,30 @@
1#
2# Copyright (C) 2012 Wind River Systems, Inc.
3#
4SUMMARY = "MCE test suite"
5
6DESCRIPTION = "The MCE test suite is a collection of tools and test scripts for \
7testing the Linux RAS related features, including CPU/Memory error \
8containment and recovery, ACPI/APEI support etc."
9
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
12
13SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mce-test.git;protocol=git \
14 file://makefile-remove-ldflags.patch \
15 "
16SRCREV = "74bffd8b0aa27051aeaa1983a7b23975ca8d8726"
17PV = "20171030+git${SRCPV}"
18
19RDEPENDS_${PN} = "mcelog mce-inject dialog bash"
20
21COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
22
23S ="${WORKDIR}/git"
24
25do_install_append(){
26 install -d ${D}/opt/mce-test
27 cp -rf ${S}/* ${D}/opt/mce-test/
28}
29
30FILES_${PN} += "/opt"