summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlejandro Enedino Hernandez Samaniego <alejandro@enedino.org>2022-09-22 02:35:22 -0600
committerKhem Raj <raj.khem@gmail.com>2022-09-22 03:51:38 -0700
commit2239a3063cadbdf7f9deb41d2842c06c2ad2bce1 (patch)
tree8f272ac593cbe28d3b188573f52e733d4d53f9b9
parent03a565a7bfa7e7358df22d4e5bfaadd2cfbbbbff (diff)
downloadmeta-openembedded-2239a3063cadbdf7f9deb41d2842c06c2ad2bce1.tar.gz
emacs: Update to version 28.2
- Remove upstreamed patch emacs-glibc-2.34.patch - Rebase usemake-docfile-native.patch - Emacs isnt aware we are cross compiling, detects host arch, e.g. x86 and tries to build seccomp-filter using cross-compiler even though it wont work for the target arch, explicitly disable seccomp to avoid configure script from wronfully enabling it for target. - Fix emacs-minimal package runtime issue. - Fix target pollution (buildpaths) reference to TMPDIR. Signed-off-by: Alejandro Enedino Hernandez Samaniego <alejandro@enedino.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/emacs/emacs_28.2.bb (renamed from meta-oe/recipes-support/emacs/emacs_27.2.bb)289
-rw-r--r--meta-oe/recipes-support/emacs/files/emacs-glibc-2.34.patch40
-rw-r--r--meta-oe/recipes-support/emacs/files/usemake-docfile-native.patch30
3 files changed, 165 insertions, 194 deletions
diff --git a/meta-oe/recipes-support/emacs/emacs_27.2.bb b/meta-oe/recipes-support/emacs/emacs_28.2.bb
index 4a7e7aba5..7b0a422be 100644
--- a/meta-oe/recipes-support/emacs/emacs_27.2.bb
+++ b/meta-oe/recipes-support/emacs/emacs_28.2.bb
@@ -5,11 +5,10 @@ LICENSE = "GPL-3.0-only"
5LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464" 5LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
6 6
7SRC_URI = "https://ftp.gnu.org/pub/gnu/emacs/emacs-${PV}.tar.xz \ 7SRC_URI = "https://ftp.gnu.org/pub/gnu/emacs/emacs-${PV}.tar.xz \
8 file://emacs-glibc-2.34.patch \
9 " 8 "
10SRC_URI:append:class-target = " file://usemake-docfile-native.patch" 9SRC_URI:append:class-target = " file://usemake-docfile-native.patch"
11 10
12SRC_URI[sha256sum] = "b4a7cc4e78e63f378624e0919215b910af5bb2a0afc819fad298272e9f40c1b9" 11SRC_URI[sha256sum] = "ee21182233ef3232dc97b486af2d86e14042dbb65bbc535df562c3a858232488"
13 12
14CVE_CHECK_IGNORE = "\ 13CVE_CHECK_IGNORE = "\
15 CVE-2007-6109 \ 14 CVE-2007-6109 \
@@ -23,13 +22,23 @@ PACKAGECONFIG ??= "gnutls kerberos libgmp"
23 22
24# We could use --without-all but its better to 23# We could use --without-all but its better to
25# split it into several packages (size of minimal doesnt change) 24# split it into several packages (size of minimal doesnt change)
26EXTRA_OECONF = " --with-x=no --with-dumping=none" 25EXTRA_OECONF = " --with-x=no --with-dumping=none --disable-build-details"
26
27# Disable seccomp, as its a default dependency for gnutls but it doesnt work when cross-compiling emacs
28EXTRA_OECONF:append = " ${@bb.utils.contains('PACKAGECONFIG', 'gnutls', 'ac_cv_have_decl_SECCOMP_FILTER_FLAG_TSYNC=no ac_cv_have_decl_SECCOMP_SET_MODE_FILTER=no', '', d)}"
29
27 30
28DEPENDS = "ncurses" 31DEPENDS = "ncurses"
29DEPENDS:append:class-target = " emacs-native" 32DEPENDS:append:class-target = " emacs-native"
30 33
31inherit autotools mime-xdg pkgconfig 34inherit autotools mime-xdg pkgconfig
32 35
36# Remove build host references to avoid target pollution
37do_compile:prepend () {
38 sed -i -e 's|${TMPDIR}||g' ${B}/src/config.h
39 sed -i -e 's|${B}||g' ${B}/src/epaths.h
40}
41
33do_compile:class-native (){ 42do_compile:class-native (){
34 cd ${B}/lib-src 43 cd ${B}/lib-src
35 oe_runmake make-docfile 44 oe_runmake make-docfile
@@ -53,7 +62,6 @@ do_install:append(){
53 chown -R root:root ${D}${datadir} 62 chown -R root:root ${D}${datadir}
54} 63}
55 64
56
57# Use a similar strategy to how we build python: 65# Use a similar strategy to how we build python:
58# Create three packages 66# Create three packages
59# minimal - A working lisp based text editor 67# minimal - A working lisp based text editor
@@ -68,191 +76,194 @@ RDEPENDS:${PN}-full:class-target = "${PN}"
68 76
69 77
70# A minimal version of emacs that works 78# A minimal version of emacs that works
79# These are kept sorted in alphabetical order
71FILES:${PN}-minimal = " \ 80FILES:${PN}-minimal = " \
72 ${datadir}/${BPN}/${PV}/lisp/loadup.el \ 81 ${bindir}/emacs* \
73 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/byte-run.elc \ 82 ${datadir}/${BPN}/${PV}/etc/charsets/ \
74 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/backquote.elc \ 83 ${datadir}/${BPN}/${PV}/lisp/abbrev.elc \
75 ${datadir}/${BPN}/${PV}/lisp/subr.elc \
76 ${datadir}/${BPN}/${PV}/lisp/version.elc \
77 ${datadir}/${BPN}/${PV}/lisp/widget.elc \
78 ${datadir}/${BPN}/${PV}/lisp/custom.elc \
79 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/map-ynp.elc \
80 ${datadir}/${BPN}/${PV}/lisp/international/mule.elc \
81 ${datadir}/${BPN}/${PV}/lisp/international/mule-conf.elc \
82 ${datadir}/${BPN}/${PV}/lisp/env.elc \
83 ${datadir}/${BPN}/${PV}/lisp/format.elc \
84 ${datadir}/${BPN}/${PV}/lisp/bindings.elc \ 84 ${datadir}/${BPN}/${PV}/lisp/bindings.elc \
85 ${datadir}/${BPN}/${PV}/lisp/window.elc \ 85 ${datadir}/${BPN}/${PV}/lisp/buff-menu.elc \
86 ${datadir}/${BPN}/${PV}/lisp/files.elc \
87 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/macroexp.elc \
88 ${datadir}/${BPN}/${PV}/lisp/cus-face.elc \
89 ${datadir}/${BPN}/${PV}/lisp/faces.elc \
90 ${datadir}/${BPN}/${PV}/lisp/button.elc \ 86 ${datadir}/${BPN}/${PV}/lisp/button.elc \
91 ${datadir}/${BPN}/${PV}/lisp/loaddefs.el \ 87 ${datadir}/${BPN}/${PV}/lisp/case-table.elc \
92 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/nadvice.elc \ 88 ${datadir}/${BPN}/${PV}/lisp/composite.elc \
89 ${datadir}/${BPN}/${PV}/lisp/cus-face.elc \
90 ${datadir}/${BPN}/${PV}/lisp/cus-start.elc \
91 ${datadir}/${BPN}/${PV}/lisp/custom.elc \
92 ${datadir}/${BPN}/${PV}/lisp/disp-table.elc \
93 ${datadir}/${BPN}/${PV}/lisp/electric.elc \
94 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/backquote.elc \
95 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/byte-opt.elc \
96 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/byte-run.elc \
97 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/bytecomp.elc \
98 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/cconv.elc \
99 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/cl-generic.elc \
93 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/cl-preloaded.elc \ 100 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/cl-preloaded.elc \
94 ${datadir}/${BPN}/${PV}/lisp/obarray.elc \ 101 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/easymenu.elc \
95 ${datadir}/${BPN}/${PV}/lisp/abbrev.elc \ 102 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/eldoc.elc \
96 ${datadir}/${BPN}/${PV}/lisp/simple.elc \ 103 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/float-sup.elc \
97 ${datadir}/${BPN}/${PV}/lisp/jka-cmpr-hook.elc \ 104 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/gv.elc \
105 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/lisp-mode.elc \
106 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/lisp.elc \
107 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/macroexp.elc \
108 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/map-ynp.elc \
109 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/map.elc \
110 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/nadvice.elc \
111 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/regexp-opt.elc \
112 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/seq.elc \
113 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/shorthands.elc \
114 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/subr-x.elc \
115 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/syntax.elc \
116 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/tabulated-list.elc \
117 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/timer.elc \
118 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/vc/warnings.elc \
119 ${datadir}/${BPN}/${PV}/lisp/env.elc \
98 ${datadir}/${BPN}/${PV}/lisp/epa-hook.elc \ 120 ${datadir}/${BPN}/${PV}/lisp/epa-hook.elc \
99 ${datadir}/${BPN}/${PV}/lisp/international/mule-cmds.elc \ 121 ${datadir}/${BPN}/${PV}/lisp/facemenu.elc \
100 ${datadir}/${BPN}/${PV}/lisp/case-table.elc \ 122 ${datadir}/${BPN}/${PV}/lisp/faces.elc \
101 ${datadir}/${BPN}/${PV}/lisp/international/charprop.el \ 123 ${datadir}/${BPN}/${PV}/lisp/files.elc \
124 ${datadir}/${BPN}/${PV}/lisp/font-core.elc \
125 ${datadir}/${BPN}/${PV}/lisp/font-lock.elc \
126 ${datadir}/${BPN}/${PV}/lisp/format.elc \
127 ${datadir}/${BPN}/${PV}/lisp/frame.elc \
128 ${datadir}/${BPN}/${PV}/lisp/help.elc \
129 ${datadir}/${BPN}/${PV}/lisp/image.elc \
130 ${datadir}/${BPN}/${PV}/lisp/indent.elc \
102 ${datadir}/${BPN}/${PV}/lisp/international/characters.elc \ 131 ${datadir}/${BPN}/${PV}/lisp/international/characters.elc \
132 ${datadir}/${BPN}/${PV}/lisp/international/charprop.el \
103 ${datadir}/${BPN}/${PV}/lisp/international/charscript.elc \ 133 ${datadir}/${BPN}/${PV}/lisp/international/charscript.elc \
104 ${datadir}/${BPN}/${PV}/lisp/composite.elc \ 134 ${datadir}/${BPN}/${PV}/lisp/international/cp51932.elc \
135 ${datadir}/${BPN}/${PV}/lisp/international/emoji-zwj.elc \
136 ${datadir}/${BPN}/${PV}/lisp/international/eucjp-ms.elc \
137 ${datadir}/${BPN}/${PV}/lisp/international/iso-transl.elc \
138 ${datadir}/${BPN}/${PV}/lisp/international/mule-cmds.elc \
139 ${datadir}/${BPN}/${PV}/lisp/international/mule-conf.elc \
140 ${datadir}/${BPN}/${PV}/lisp/international/mule.elc \
141 ${datadir}/${BPN}/${PV}/lisp/international/uni*.el \
142 ${datadir}/${BPN}/${PV}/lisp/isearch.elc \
143 ${datadir}/${BPN}/${PV}/lisp/jit-lock.elc \
144 ${datadir}/${BPN}/${PV}/lisp/jka-cmpr-hook.elc \
145 ${datadir}/${BPN}/${PV}/lisp/language/burmese.elc \
146 ${datadir}/${BPN}/${PV}/lisp/language/cham.elc \
105 ${datadir}/${BPN}/${PV}/lisp/language/chinese.elc \ 147 ${datadir}/${BPN}/${PV}/lisp/language/chinese.elc \
106 ${datadir}/${BPN}/${PV}/lisp/language/cyrillic.elc \ 148 ${datadir}/${BPN}/${PV}/lisp/language/cyrillic.elc \
107 ${datadir}/${BPN}/${PV}/lisp/language/indian.elc \ 149 ${datadir}/${BPN}/${PV}/lisp/language/czech.elc \
108 ${datadir}/${BPN}/${PV}/lisp/language/sinhala.elc \
109 ${datadir}/${BPN}/${PV}/lisp/language/english.elc \ 150 ${datadir}/${BPN}/${PV}/lisp/language/english.elc \
110 ${datadir}/${BPN}/${PV}/lisp/language/ethiopic.elc \ 151 ${datadir}/${BPN}/${PV}/lisp/language/ethiopic.elc \
111 ${datadir}/${BPN}/${PV}/lisp/language/european.elc \ 152 ${datadir}/${BPN}/${PV}/lisp/language/european.elc \
112 ${datadir}/${BPN}/${PV}/lisp/language/czech.elc \ 153 ${datadir}/${BPN}/${PV}/lisp/language/georgian.elc \
113 ${datadir}/${BPN}/${PV}/lisp/language/slovak.elc \
114 ${datadir}/${BPN}/${PV}/lisp/language/romanian.elc \
115 ${datadir}/${BPN}/${PV}/lisp/language/greek.elc \ 154 ${datadir}/${BPN}/${PV}/lisp/language/greek.elc \
116 ${datadir}/${BPN}/${PV}/lisp/language/hebrew.elc \ 155 ${datadir}/${BPN}/${PV}/lisp/language/hebrew.elc \
117 ${datadir}/${BPN}/${PV}/lisp/international/cp51932.elc \ 156 ${datadir}/${BPN}/${PV}/lisp/language/indian.elc \
118 ${datadir}/${BPN}/${PV}/lisp/international/eucjp-ms.elc \
119 ${datadir}/${BPN}/${PV}/lisp/language/japanese.elc \ 157 ${datadir}/${BPN}/${PV}/lisp/language/japanese.elc \
158 ${datadir}/${BPN}/${PV}/lisp/language/khmer.elc \
120 ${datadir}/${BPN}/${PV}/lisp/language/korean.elc \ 159 ${datadir}/${BPN}/${PV}/lisp/language/korean.elc \
121 ${datadir}/${BPN}/${PV}/lisp/language/lao.elc \ 160 ${datadir}/${BPN}/${PV}/lisp/language/lao.elc \
161 ${datadir}/${BPN}/${PV}/lisp/language/misc-lang.elc \
162 ${datadir}/${BPN}/${PV}/lisp/language/romanian.elc \
163 ${datadir}/${BPN}/${PV}/lisp/language/sinhala.elc \
164 ${datadir}/${BPN}/${PV}/lisp/language/slovak.elc \
122 ${datadir}/${BPN}/${PV}/lisp/language/tai-viet.elc \ 165 ${datadir}/${BPN}/${PV}/lisp/language/tai-viet.elc \
123 ${datadir}/${BPN}/${PV}/lisp/language/thai.elc \ 166 ${datadir}/${BPN}/${PV}/lisp/language/thai.elc \
124 ${datadir}/${BPN}/${PV}/lisp/language/tibetan.elc \ 167 ${datadir}/${BPN}/${PV}/lisp/language/tibetan.elc \
125 ${datadir}/${BPN}/${PV}/lisp/language/vietnamese.elc \
126 ${datadir}/${BPN}/${PV}/lisp/language/misc-lang.elc \
127 ${datadir}/${BPN}/${PV}/lisp/language/utf-8-lang.elc \ 168 ${datadir}/${BPN}/${PV}/lisp/language/utf-8-lang.elc \
128 ${datadir}/${BPN}/${PV}/lisp/language/georgian.elc \ 169 ${datadir}/${BPN}/${PV}/lisp/language/vietnamese.elc \
129 ${datadir}/${BPN}/${PV}/lisp/language/khmer.elc \ 170 ${datadir}/${BPN}/${PV}/lisp/ldefs-boot.el \
130 ${datadir}/${BPN}/${PV}/lisp/language/burmese.elc \ 171 ${datadir}/${BPN}/${PV}/lisp/loaddefs.el \
131 ${datadir}/${BPN}/${PV}/lisp/language/cham.elc \ 172 ${datadir}/${BPN}/${PV}/lisp/loadup.el \
132 ${datadir}/${BPN}/${PV}/lisp/indent.elc \ 173 ${datadir}/${BPN}/${PV}/lisp/menu-bar.elc \
133 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/cl-generic.elc \
134 ${datadir}/${BPN}/${PV}/lisp/minibuffer.elc \ 174 ${datadir}/${BPN}/${PV}/lisp/minibuffer.elc \
135 ${datadir}/${BPN}/${PV}/lisp/frame.elc \
136 ${datadir}/${BPN}/${PV}/lisp/startup.elc \
137 ${datadir}/${BPN}/${PV}/lisp/term/tty-colors.elc \
138 ${datadir}/${BPN}/${PV}/lisp/font-core.elc \
139 ${datadir}/${BPN}/${PV}/lisp/facemenu.elc \
140 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/syntax.elc \
141 ${datadir}/${BPN}/${PV}/lisp/font-lock.elc \
142 ${datadir}/${BPN}/${PV}/lisp/jit-lock.elc \
143 ${datadir}/${BPN}/${PV}/lisp/mouse.elc \ 175 ${datadir}/${BPN}/${PV}/lisp/mouse.elc \
144 ${datadir}/${BPN}/${PV}/lisp/select.elc \ 176 ${datadir}/${BPN}/${PV}/lisp/newcomment.elc \
145 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/timer.elc \ 177 ${datadir}/${BPN}/${PV}/lisp/obarray.elc \
146 ${datadir}/${BPN}/${PV}/lisp/isearch.elc \ 178 ${datadir}/${BPN}/${PV}/lisp/paren.elc \
179 ${datadir}/${BPN}/${PV}/lisp/progmodes/elisp-mode.elc \
180 ${datadir}/${BPN}/${PV}/lisp/progmodes/prog-mode.elc \
181 ${datadir}/${BPN}/${PV}/lisp/register.elc \
182 ${datadir}/${BPN}/${PV}/lisp/replace.elc \
147 ${datadir}/${BPN}/${PV}/lisp/rfn-eshadow.elc \ 183 ${datadir}/${BPN}/${PV}/lisp/rfn-eshadow.elc \
148 ${datadir}/${BPN}/${PV}/lisp/menu-bar.elc \ 184 ${datadir}/${BPN}/${PV}/lisp/select.elc \
185 ${datadir}/${BPN}/${PV}/lisp/simple.elc \
186 ${datadir}/${BPN}/${PV}/lisp/simple.elc \
187 ${datadir}/${BPN}/${PV}/lisp/startup.elc \
188 ${datadir}/${BPN}/${PV}/lisp/subr.elc \
149 ${datadir}/${BPN}/${PV}/lisp/tab-bar.elc \ 189 ${datadir}/${BPN}/${PV}/lisp/tab-bar.elc \
150 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/lisp.elc \ 190 ${datadir}/${BPN}/${PV}/lisp/term/tty-colors.elc \
191 ${datadir}/${BPN}/${PV}/lisp/term/xterm.elc \
192 ${datadir}/${BPN}/${PV}/lisp/textmodes/fill.elc \
151 ${datadir}/${BPN}/${PV}/lisp/textmodes/page.elc \ 193 ${datadir}/${BPN}/${PV}/lisp/textmodes/page.elc \
152 ${datadir}/${BPN}/${PV}/lisp/register.elc \
153 ${datadir}/${BPN}/${PV}/lisp/textmodes/paragraphs.elc \ 194 ${datadir}/${BPN}/${PV}/lisp/textmodes/paragraphs.elc \
154 ${datadir}/${BPN}/${PV}/lisp/progmodes/prog-mode.elc \
155 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/lisp-mode.elc \
156 ${datadir}/${BPN}/${PV}/lisp/progmodes/elisp-mode.elc \
157 ${datadir}/${BPN}/${PV}/lisp/textmodes/text-mode.elc \ 195 ${datadir}/${BPN}/${PV}/lisp/textmodes/text-mode.elc \
158 ${datadir}/${BPN}/${PV}/lisp/textmodes/fill.elc \
159 ${datadir}/${BPN}/${PV}/lisp/newcomment.elc \
160 ${datadir}/${BPN}/${PV}/lisp/replace.elc \
161 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/tabulated-list.elc \
162 ${datadir}/${BPN}/${PV}/lisp/buff-menu.elc \
163 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/float-sup.elc \
164 ${datadir}/${BPN}/${PV}/lisp/vc/vc-hooks.elc \
165 ${datadir}/${BPN}/${PV}/lisp/vc/ediff-hook.elc \
166 ${datadir}/${BPN}/${PV}/lisp/uniquify.elc \
167 ${datadir}/${BPN}/${PV}/lisp/electric.elc \
168 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/eldoc.elc \
169 ${datadir}/${BPN}/${PV}/lisp/cus-start.elc \
170 ${datadir}/${BPN}/${PV}/lisp/tooltip.elc \ 196 ${datadir}/${BPN}/${PV}/lisp/tooltip.elc \
171 ${datadir}/${BPN}/${PV}/lisp/simple.elc \ 197 ${datadir}/${BPN}/${PV}/lisp/uniquify.elc \
172 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/regexp-opt.elc \ 198 ${datadir}/${BPN}/${PV}/lisp/vc/ediff-hook.elc \
173 ${datadir}/${BPN}/${PV}/lisp/term/xterm.elc \ 199 ${datadir}/${BPN}/${PV}/lisp/vc/vc-hooks.elc \
174 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/bytecomp.elc \ 200 ${datadir}/${BPN}/${PV}/lisp/version.elc \
175 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/cconv.elc \ 201 ${datadir}/${BPN}/${PV}/lisp/widget.elc \
176 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/gv.elc \ 202 ${datadir}/${BPN}/${PV}/lisp/window.elc \
177 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/byte-opt.elc \
178 ${datadir}/${BPN}/${PV}/lisp/image.elc \
179 ${datadir}/${BPN}/${PV}/lisp/ldefs-boot.el \
180 ${datadir}/${BPN}/${PV}/lisp/help.elc \
181 ${datadir}/${BPN}/${PV}/lisp/international/uni*.el \
182 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/vc/warnings.elc \
183 ${datadir}/${BPN}/${PV}/etc/charsets/ \
184 ${datadir}/${BPN}/${PV}/lisp/disp-table.elc \
185 ${bindir}/emacs* \
186 ${prefix}/libexec \ 203 ${prefix}/libexec \
187" 204"
188 205
189
190# What works for "most" is relative, but this can be easily extended if needed 206# What works for "most" is relative, but this can be easily extended if needed
191FILES:${PN}-base = " \ 207FILES:${PN}-base = " \
192 ${datadir}/${BPN}/${PV}/etc/srecode \
193 ${datadir}/${BPN}/${PV}/etc/e \ 208 ${datadir}/${BPN}/${PV}/etc/e \
194 ${datadir}/${BPN}/${PV}/etc/forms \ 209 ${datadir}/${BPN}/${PV}/etc/forms \
210 ${datadir}/${BPN}/${PV}/etc/srecode \
211 ${datadir}/${BPN}/${PV}/etc/themes/adwaita-theme.el \
212 ${datadir}/${BPN}/${PV}/etc/themes/deeper-blue-theme.el \
213 ${datadir}/${BPN}/${PV}/etc/themes/light-blue-theme.el \
214 ${datadir}/${BPN}/${PV}/etc/themes/misterioso-theme.el \
215 ${datadir}/${BPN}/${PV}/etc/themes/tango-theme.el \
216 ${datadir}/${BPN}/${PV}/etc/themes/wheatgrass-theme.el \
217 ${datadir}/${BPN}/${PV}/etc/themes/wombat-theme.el \
218 ${datadir}/${BPN}/${PV}/lisp/ansi-color.elc \
219 ${datadir}/${BPN}/${PV}/lisp/auth-source.elc \
220 ${datadir}/${BPN}/${PV}/lisp/calendar/iso8601.elc \
221 ${datadir}/${BPN}/${PV}/lisp/calendar/parse-time.elc \
222 ${datadir}/${BPN}/${PV}/lisp/calendar/time-date.elc \
195 ${datadir}/${BPN}/${PV}/lisp/cedet \ 223 ${datadir}/${BPN}/${PV}/lisp/cedet \
196 ${datadir}/${BPN}/${PV}/site-lisp/ \ 224 ${datadir}/${BPN}/${PV}/lisp/comint.elc \
197 ${datadir}/${BPN}/${PV}/lisp/subdirs.el \
198 ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-mode.elc \
199 ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-defs.elc \
200 ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-vars.elc \
201 ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-engine.elc \
202 ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-styles.elc \
203 ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-fonts.elc \
204 ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-cmds.elc \
205 ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-align.elc \
206 ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-menus.elc \
207 ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-guess.elc \
208 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/cl-lib.elc \ 225 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/cl-lib.elc \
209 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/cl-macs.elc \ 226 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/cl-macs.elc \
210 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/pcase.elc \
211 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/inline.elc \
212 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/cl-seq.elc \ 227 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/cl-seq.elc \
213 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/easymenu.elc \ 228 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/eieio-core.elc \
214 ${datadir}/${BPN}/${PV}/lisp/progmodes/python* \ 229 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/eieio.elc \
215 ${datadir}/${BPN}/${PV}/lisp/ansi-color.elc \ 230 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/inline.elc \
216 ${datadir}/${BPN}/${PV}/lisp/comint.elc \ 231 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/pcase.elc \
217 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/ring.elc \ 232 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/ring.elc \
233 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/smie.elc \
234 ${datadir}/${BPN}/${PV}/lisp/files-x.elc \
235 ${datadir}/${BPN}/${PV}/lisp/format-spec.elc \
218 ${datadir}/${BPN}/${PV}/lisp/json.elc \ 236 ${datadir}/${BPN}/${PV}/lisp/json.elc \
219 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/map.elc \ 237 ${datadir}/${BPN}/${PV}/lisp/ls-lisp.elc \
220 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/seq.elc \ 238 ${datadir}/${BPN}/${PV}/lisp/net/tramp-compat.elc \
221 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/subr-x.elc \ 239 ${datadir}/${BPN}/${PV}/lisp/net/tramp-integration.elc \
222 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/seq.elc \ 240 ${datadir}/${BPN}/${PV}/lisp/net/tramp-loaddefs.el \
223 ${datadir}/${BPN}/${PV}/lisp/net/tramp-sh.elc \ 241 ${datadir}/${BPN}/${PV}/lisp/net/tramp-sh.elc \
224 ${datadir}/${BPN}/${PV}/lisp/net/tramp.elc \ 242 ${datadir}/${BPN}/${PV}/lisp/net/tramp.elc \
225 ${datadir}/${BPN}/${PV}/lisp/net/tramp-compat.elc \ 243 ${datadir}/${BPN}/${PV}/lisp/net/trampver.elc \
226 ${datadir}/${BPN}/${PV}/lisp/auth-source.elc \
227 ${datadir}/${BPN}/${PV}/lisp/password-cache.elc \ 244 ${datadir}/${BPN}/${PV}/lisp/password-cache.elc \
228 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/eieio.elc \
229 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/eieio-core.elc \
230 ${datadir}/${BPN}/${PV}/lisp/format-spec.elc \
231 ${datadir}/${BPN}/${PV}/lisp/ls-lisp.elc \
232 ${datadir}/${BPN}/${PV}/lisp/calendar/parse-time.elc \
233 ${datadir}/${BPN}/${PV}/lisp/calendar/iso8601.elc \
234 ${datadir}/${BPN}/${PV}/lisp/calendar/time-date.elc \
235 ${datadir}/${BPN}/${PV}/lisp/shell.elc \
236 ${datadir}/${BPN}/${PV}/lisp/pcomplete.elc \ 245 ${datadir}/${BPN}/${PV}/lisp/pcomplete.elc \
237 ${datadir}/${BPN}/${PV}/lisp/net/tramp-integration.elc \
238 ${datadir}/${BPN}/${PV}/lisp/files-x.elc \
239 ${datadir}/${BPN}/${PV}/lisp/net/trampver.elc \
240 ${datadir}/${BPN}/${PV}/lisp/net/tramp-loaddefs.el \
241 ${datadir}/${BPN}/${PV}/lisp/progmodes/*perl* \
242 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/smie.elc \
243 ${datadir}/${BPN}/${PV}/lisp/progmodes/*asm* \ 246 ${datadir}/${BPN}/${PV}/lisp/progmodes/*asm* \
247 ${datadir}/${BPN}/${PV}/lisp/progmodes/*perl* \
248 ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-align.elc \
249 ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-cmds.elc \
250 ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-defs.elc \
251 ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-engine.elc \
252 ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-fonts.elc \
253 ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-guess.elc \
254 ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-menus.elc \
255 ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-mode.elc \
256 ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-styles.elc \
257 ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-vars.elc \
244 ${datadir}/${BPN}/${PV}/lisp/progmodes/cpp* \ 258 ${datadir}/${BPN}/${PV}/lisp/progmodes/cpp* \
259 ${datadir}/${BPN}/${PV}/lisp/progmodes/executable* \
245 ${datadir}/${BPN}/${PV}/lisp/progmodes/make* \ 260 ${datadir}/${BPN}/${PV}/lisp/progmodes/make* \
246 ${datadir}/${BPN}/${PV}/lisp/progmodes/sh-script* \
247 ${datadir}/${BPN}/${PV}/etc/themes/adwaita-theme.el \
248 ${datadir}/${BPN}/${PV}/etc/themes/wheatgrass-theme.el \
249 ${datadir}/${BPN}/${PV}/etc/themes/deeper-blue-theme.el \
250 ${datadir}/${BPN}/${PV}/etc/themes/light-blue-theme.el \
251 ${datadir}/${BPN}/${PV}/etc/themes/misterioso-theme.el \
252 ${datadir}/${BPN}/${PV}/etc/themes/tango-theme.el \
253 ${datadir}/${BPN}/${PV}/etc/themes/wombat-theme.el \
254 ${datadir}/${BPN}/${PV}/lisp/progmodes/prog* \ 261 ${datadir}/${BPN}/${PV}/lisp/progmodes/prog* \
255 ${datadir}/${BPN}/${PV}/lisp/progmodes/executable* \ 262 ${datadir}/${BPN}/${PV}/lisp/progmodes/python* \
263 ${datadir}/${BPN}/${PV}/lisp/progmodes/sh-script* \
264 ${datadir}/${BPN}/${PV}/lisp/shell.elc \
265 ${datadir}/${BPN}/${PV}/lisp/subdirs.el \
266 ${datadir}/${BPN}/${PV}/site-lisp/ \
256" 267"
257 268
258# Restore FILES for the full package to catch everything left 269# Restore FILES for the full package to catch everything left
diff --git a/meta-oe/recipes-support/emacs/files/emacs-glibc-2.34.patch b/meta-oe/recipes-support/emacs/files/emacs-glibc-2.34.patch
deleted file mode 100644
index 6d764aa26..000000000
--- a/meta-oe/recipes-support/emacs/files/emacs-glibc-2.34.patch
+++ /dev/null
@@ -1,40 +0,0 @@
1From f97e07ea807cc6d38774a3888a15091b20645ac6 Mon Sep 17 00:00:00 2001
2From: Paul Eggert <eggert@cs.ucla.edu>
3Date: Tue, 9 Mar 2021 11:22:59 -0800
4Subject: [PATCH] Port alternate signal stack to upcoming glibc 2.34
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9* src/sysdep.c (sigsegv_stack): Increase size to 64 KiB and align
10it to max_align_t. This copies from Gnulib’s c-stack.c, and works
11around a portability bug in draft glibc 2.34, which no longer
12defines SIGSTKSZ when _GNU_SOURCE is defined.
13---
14 src/sysdep.c | 10 +++++++++-
15 1 file changed, 9 insertions(+), 1 deletion(-)
16
17diff --git a/src/sysdep.c b/src/sysdep.c
18index 941b4e2fa2..24d8832b2f 100644
19--- a/src/sysdep.c
20+++ b/src/sysdep.c
21@@ -1785,7 +1785,15 @@ handle_arith_signal (int sig)
22
23 /* Alternate stack used by SIGSEGV handler below. */
24
25-static unsigned char sigsegv_stack[SIGSTKSZ];
26+/* Storage for the alternate signal stack.
27+ 64 KiB is not too large for Emacs, and is large enough
28+ for all known platforms. Smaller sizes may run into trouble.
29+ For example, libsigsegv 2.6 through 2.8 have a bug where some
30+ architectures use more than the Linux default of an 8 KiB alternate
31+ stack when deciding if a fault was caused by stack overflow. */
32+static max_align_t sigsegv_stack[(64 * 1024
33+ + sizeof (max_align_t) - 1)
34+ / sizeof (max_align_t)];
35
36
37 /* Return true if SIGINFO indicates a stack overflow. */
38--
392.29.2
40
diff --git a/meta-oe/recipes-support/emacs/files/usemake-docfile-native.patch b/meta-oe/recipes-support/emacs/files/usemake-docfile-native.patch
index cc0b05c79..95b428183 100644
--- a/meta-oe/recipes-support/emacs/files/usemake-docfile-native.patch
+++ b/meta-oe/recipes-support/emacs/files/usemake-docfile-native.patch
@@ -11,11 +11,11 @@ version of the recipe instead.
11 11
12Signed-off-by: Alejandro Enedino Hernandez Samaniego <alejandro@enedino.org> 12Signed-off-by: Alejandro Enedino Hernandez Samaniego <alejandro@enedino.org>
13 13
14Index: emacs-27.1/src/Makefile.in 14Index: emacs-28.2/src/Makefile.in
15=================================================================== 15===================================================================
16--- emacs-27.1.orig/src/Makefile.in 16--- emacs-28.2.orig/src/Makefile.in
17+++ emacs-27.1/src/Makefile.in 17+++ emacs-28.2/src/Makefile.in
18@@ -472,7 +472,7 @@ ifeq ($(CHECK_STRUCTS),true) 18@@ -462,7 +462,7 @@ ifeq ($(CHECK_STRUCTS),true)
19 pdumper.o: dmpstruct.h 19 pdumper.o: dmpstruct.h
20 endif 20 endif
21 dmpstruct.h: $(srcdir)/dmpstruct.awk 21 dmpstruct.h: $(srcdir)/dmpstruct.awk
@@ -24,7 +24,7 @@ Index: emacs-27.1/src/Makefile.in
24 $(AM_V_GEN)POSIXLY_CORRECT=1 awk -f $(srcdir)/dmpstruct.awk \ 24 $(AM_V_GEN)POSIXLY_CORRECT=1 awk -f $(srcdir)/dmpstruct.awk \
25 $(dmpstruct_headers) > $@ 25 $(dmpstruct_headers) > $@
26 26
27@@ -566,8 +566,7 @@ ${lispintdir}/characters.elc: ${charscri 27@@ -563,8 +563,7 @@ SYSTEM_TYPE = @SYSTEM_TYPE@
28 ## Strictly speaking, emacs does not depend directly on all of $lisp, 28 ## Strictly speaking, emacs does not depend directly on all of $lisp,
29 ## since not all pieces are used on all platforms. But DOC depends 29 ## since not all pieces are used on all platforms. But DOC depends
30 ## on all of $lisp, and emacs depends on DOC, so it is ok to use $lisp here. 30 ## on all of $lisp, and emacs depends on DOC, so it is ok to use $lisp here.
@@ -32,9 +32,9 @@ Index: emacs-27.1/src/Makefile.in
32- lisp.mk $(etc)/DOC $(lisp) \ 32- lisp.mk $(etc)/DOC $(lisp) \
33+emacs$(EXEEXT): lisp.mk $(etc)/DOC $(lisp) \ 33+emacs$(EXEEXT): lisp.mk $(etc)/DOC $(lisp) \
34 $(lispsource)/international/charprop.el ${charsets} 34 $(lispsource)/international/charprop.el ${charsets}
35 ifeq ($(DUMPING),unexec) 35 ifeq ($(SYSTEM_TYPE),cygwin)
36 LC_ALL=C $(RUN_TEMACS) -batch $(BUILD_DETAILS) -l loadup --temacs=dump 36 find ${top_builddir} -name '*.eln' | rebase -v -O -T -
37@@ -596,15 +595,15 @@ endif 37@@ -597,15 +596,15 @@ endif
38 ## for the first time, this prevents any variation between configurations 38 ## for the first time, this prevents any variation between configurations
39 ## in the contents of the DOC file. 39 ## in the contents of the DOC file.
40 ## 40 ##
@@ -54,9 +54,9 @@ Index: emacs-27.1/src/Makefile.in
54 $(lib)/libgnu.a 54 $(lib)/libgnu.a
55 $(MAKE) -C $(dir $@) $(notdir $@) 55 $(MAKE) -C $(dir $@) $(notdir $@)
56 56
57@@ -622,8 +621,8 @@ am__v_GLOBALS_ = $(am__v_GLOBALS_@AM_DEF 57@@ -618,8 +617,8 @@ buildobj.h: Makefile
58 am__v_GLOBALS_0 = @echo " GEN " globals.h; 58
59 am__v_GLOBALS_1 = 59 GLOBAL_SOURCES = $(base_obj:.o=.c) $(NS_OBJC_OBJ:.o=.m)
60 60
61-gl-stamp: $(libsrc)/make-docfile$(EXEEXT) $(GLOBAL_SOURCES) 61-gl-stamp: $(libsrc)/make-docfile$(EXEEXT) $(GLOBAL_SOURCES)
62- $(AM_V_GLOBALS)$(libsrc)/make-docfile -d $(srcdir) -g $(obj) > globals.tmp 62- $(AM_V_GLOBALS)$(libsrc)/make-docfile -d $(srcdir) -g $(obj) > globals.tmp
@@ -65,7 +65,7 @@ Index: emacs-27.1/src/Makefile.in
65 $(AM_V_at)$(top_srcdir)/build-aux/move-if-change globals.tmp globals.h 65 $(AM_V_at)$(top_srcdir)/build-aux/move-if-change globals.tmp globals.h
66 $(AM_V_at)echo timestamp > $@ 66 $(AM_V_at)echo timestamp > $@
67 67
68@@ -637,7 +636,7 @@ $(LIBEGNU_ARCHIVE): $(config_h) 68@@ -633,7 +632,7 @@ $(LIBEGNU_ARCHIVE): $(config_h)
69 $(MAKE) -C $(dir $@) all 69 $(MAKE) -C $(dir $@) all
70 70
71 ifeq ($(HAVE_PDUMPER),yes) 71 ifeq ($(HAVE_PDUMPER),yes)
@@ -74,12 +74,12 @@ Index: emacs-27.1/src/Makefile.in
74 else 74 else
75 MAKE_PDUMPER_FINGERPRINT = 75 MAKE_PDUMPER_FINGERPRINT =
76 endif 76 endif
77@@ -647,7 +646,7 @@ endif 77@@ -643,7 +642,7 @@ endif
78 ## This goes on to affect various things, and the emacs binary fails 78 ## This goes on to affect various things, and the emacs binary fails
79 ## to start if Vinstallation_directory has the wrong value. 79 ## to start if Vinstallation_directory has the wrong value.
80 temacs$(EXEEXT): $(LIBXMENU) $(ALLOBJS) $(LIBEGNU_ARCHIVE) $(EMACSRES) \ 80 temacs$(EXEEXT): $(LIBXMENU) $(ALLOBJS) $(LIBEGNU_ARCHIVE) $(EMACSRES) \
81- $(charsets) $(charscript) $(MAKE_PDUMPER_FINGERPRINT) 81- $(charsets) $(charscript) ${emoji-zwj} $(MAKE_PDUMPER_FINGERPRINT)
82+ $(charsets) $(charscript) 82+ $(charsets) $(charscript) ${emoji-zwj}
83 $(AM_V_CCLD)$(CC) -o $@.tmp \ 83 $(AM_V_CCLD)$(CC) -o $@.tmp \
84 $(ALL_CFLAGS) $(TEMACS_LDFLAGS) $(LDFLAGS) \ 84 $(ALL_CFLAGS) $(TEMACS_LDFLAGS) $(LDFLAGS) \
85 $(ALLOBJS) $(LIBEGNU_ARCHIVE) $(W32_RES_LINK) $(LIBES) 85 $(ALLOBJS) $(LIBEGNU_ARCHIVE) $(W32_RES_LINK) $(LIBES)