summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMing Liu <peter.x.liu@external.atlascopco.com>2017-06-11 14:58:15 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-14 14:51:16 +0200
commit21f7ec05e8f5f8952877e24c4b8a55822131459c (patch)
tree8d245fe46990295978a11212cc575e2fcf8e3e49
parent1f6be355039da4cd931168c47f64cc0173f61ac6 (diff)
downloadmeta-openembedded-21f7ec05e8f5f8952877e24c4b8a55822131459c.tar.gz
librcf: convert CRLF to LF
librcf is developed on Windows system, so CRLF is the line terminator being used in this project, this can lead annoying patching issues if the users forget to set autocrlf in git config. It can be fixed by inheriting dos2unix, hence a convert_crlf_to_lf task will be executed before do_patch, to convert all CRLF to LF. Signed-off-by: Ming Liu <liu.ming50@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/librcf/librcf/aarch64-support.patch16
-rw-r--r--meta-oe/recipes-devtools/librcf/librcf_2.2.0.0.bb4
2 files changed, 10 insertions, 10 deletions
diff --git a/meta-oe/recipes-devtools/librcf/librcf/aarch64-support.patch b/meta-oe/recipes-devtools/librcf/librcf/aarch64-support.patch
index 28cd0fe60..e08efb92f 100644
--- a/meta-oe/recipes-devtools/librcf/librcf/aarch64-support.patch
+++ b/meta-oe/recipes-devtools/librcf/librcf/aarch64-support.patch
@@ -3,11 +3,11 @@ Index: RCF-2.2.0.0/src/RCF/ByteOrdering.cpp
3--- RCF-2.2.0.0.orig/src/RCF/ByteOrdering.cpp 3--- RCF-2.2.0.0.orig/src/RCF/ByteOrdering.cpp
4+++ RCF-2.2.0.0/src/RCF/ByteOrdering.cpp 4+++ RCF-2.2.0.0/src/RCF/ByteOrdering.cpp
5@@ -60,7 +60,7 @@ namespace RCF { 5@@ -60,7 +60,7 @@ namespace RCF {
6 6
7 const ByteOrder MachineByteOrder = LittleEndian; 7 const ByteOrder MachineByteOrder = LittleEndian;
8 8
9-#elif defined(__arm__) 9-#elif defined(__arm__)
10+#elif defined(__arm__) || defined(__aarch64__) 10+#elif defined(__arm__) || defined(__aarch64__)
11 11
12 const ByteOrder MachineByteOrder = LittleEndian; 12 const ByteOrder MachineByteOrder = LittleEndian;
13 13
diff --git a/meta-oe/recipes-devtools/librcf/librcf_2.2.0.0.bb b/meta-oe/recipes-devtools/librcf/librcf_2.2.0.0.bb
index 51ad7ec9c..cf0a8e7b1 100644
--- a/meta-oe/recipes-devtools/librcf/librcf_2.2.0.0.bb
+++ b/meta-oe/recipes-devtools/librcf/librcf_2.2.0.0.bb
@@ -8,7 +8,7 @@ HOMEPAGE = "http://www.deltavsoft.com/"
8SECTION = "libs" 8SECTION = "libs"
9PRIORITY = "optional" 9PRIORITY = "optional"
10LICENSE = "GPLv2" 10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://license.txt;md5=137c2935b51c95068a8b1bbd434ffe2d" 11LIC_FILES_CHKSUM = "file://license.txt;md5=7586a312b9e978f9d6fac9a5780d1f84"
12 12
13SRC_URI = "http://www.deltavsoft.com/downloads/RCF-${PV}.tar.gz \ 13SRC_URI = "http://www.deltavsoft.com/downloads/RCF-${PV}.tar.gz \
14 file://0001-Add-CMake-build-files.patch \ 14 file://0001-Add-CMake-build-files.patch \
@@ -20,7 +20,7 @@ SRC_URI[sha256sum] = "bbfcc88de502c39604878c395f516b03fff4eac63eb4f7f44c07d43383
20 20
21S = "${WORKDIR}/RCF-${PV}" 21S = "${WORKDIR}/RCF-${PV}"
22 22
23inherit cmake 23inherit cmake dos2unix
24 24
25PACKAGECONFIG ?= "zlib openssl sf-serialization boost-filesystem boost-asio protobuf json dll static shared demos" 25PACKAGECONFIG ?= "zlib openssl sf-serialization boost-filesystem boost-asio protobuf json dll static shared demos"
26PACKAGECONFIG[zlib] = "-DLIBRCF_USE_ZLIB=ON,-DLIBRCF_USE_ZLIB=OFF,zlib,zlib" 26PACKAGECONFIG[zlib] = "-DLIBRCF_USE_ZLIB=ON,-DLIBRCF_USE_ZLIB=OFF,zlib,zlib"