summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2013-04-16 10:53:55 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-19 02:45:27 +0200
commit21adc5d117329b11fa42da2f62edce3cad8719ff (patch)
tree369b8b36964abec08428032c3162423275160c7d
parentb2aa32edd3f922514938f895354ef6719bf56681 (diff)
downloadmeta-openembedded-21adc5d117329b11fa42da2f62edce3cad8719ff.tar.gz
vsftpd: move from meta-oe to meta-networking and tweak
* Fix stripped file QA warning * Add proper headers to patches (and split makefile.patch into two parts, one of which may be upstreamable) * Use PV in SRC_URI instead of hardcoded version * Move SRC_URI checksums up next to SRC_URI * Set SUMMARY instead of DESCRIPTION Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rwxr-xr-xmeta-networking/recipes-daemons/vsftpd/files/init (renamed from meta-oe/recipes-connectivity/vsftpd/files/init)0
-rwxr-xr-xmeta-networking/recipes-daemons/vsftpd/files/vsftpd.conf (renamed from meta-oe/recipes-connectivity/vsftpd/files/vsftpd.conf)0
-rw-r--r--meta-networking/recipes-daemons/vsftpd/vsftpd-2.3.5/makefile-destdir.patch (renamed from meta-oe/recipes-connectivity/vsftpd/vsftpd-2.3.5/makefile.patch)25
-rw-r--r--meta-networking/recipes-daemons/vsftpd/vsftpd-2.3.5/makefile-libs.patch21
-rw-r--r--meta-networking/recipes-daemons/vsftpd/vsftpd-2.3.5/makefile-strip.patch17
-rw-r--r--meta-networking/recipes-daemons/vsftpd/vsftpd-2.3.5/nopam.patch (renamed from meta-oe/recipes-connectivity/vsftpd/vsftpd-2.3.5/nopam.patch)4
-rw-r--r--meta-networking/recipes-daemons/vsftpd/vsftpd_2.3.5.bb (renamed from meta-oe/recipes-connectivity/vsftpd/vsftpd_2.3.5.bb)17
7 files changed, 63 insertions, 21 deletions
diff --git a/meta-oe/recipes-connectivity/vsftpd/files/init b/meta-networking/recipes-daemons/vsftpd/files/init
index d0ec010dc..d0ec010dc 100755
--- a/meta-oe/recipes-connectivity/vsftpd/files/init
+++ b/meta-networking/recipes-daemons/vsftpd/files/init
diff --git a/meta-oe/recipes-connectivity/vsftpd/files/vsftpd.conf b/meta-networking/recipes-daemons/vsftpd/files/vsftpd.conf
index 08f91e048..08f91e048 100755
--- a/meta-oe/recipes-connectivity/vsftpd/files/vsftpd.conf
+++ b/meta-networking/recipes-daemons/vsftpd/files/vsftpd.conf
diff --git a/meta-oe/recipes-connectivity/vsftpd/vsftpd-2.3.5/makefile.patch b/meta-networking/recipes-daemons/vsftpd/vsftpd-2.3.5/makefile-destdir.patch
index 3bf8f9767..ee37f26e9 100644
--- a/meta-oe/recipes-connectivity/vsftpd/vsftpd-2.3.5/makefile.patch
+++ b/meta-networking/recipes-daemons/vsftpd/vsftpd-2.3.5/makefile-destdir.patch
@@ -1,17 +1,14 @@
1diff -ur vsftpd-2.0.1_org/Makefile vsftpd-2.0.1_patch/Makefile 1Use DESTDIR within install to allow installing under a prefix
2--- vsftpd-2.0.1_org/Makefile 2004-06-06 18:21:27.000000000 +0200 2
3+++ vsftpd-2.0.1_patch/Makefile 2004-07-21 09:50:25.245576352 +0200 3Upstream-Status: Pending
4@@ -5,7 +5,7 @@ 4
5 #CFLAGS = -g 5Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
6 CFLAGS = -O2 -Wall -W -Wshadow #-pedantic -Werror -Wconversion 6
7 7diff --git a/Makefile b/Makefile
8-LIBS = `./vsf_findlibs.sh` 8--- a/Makefile
9+LIBS = -lssl -lcrypto -lnsl -lresolv 9+++ b/Makefile
10 LINK = -Wl,-s 10@@ -24,21 +24,21 @@ vsftpd: $(OBJS)
11 11 $(CC) -o vsftpd $(OBJS) $(LINK) $(LIBS) $(LDFLAGS)
12 OBJS = main.o utility.o prelogin.o ftpcmdio.o postlogin.o privsock.o \
13@@ -24,21 +24,21 @@
14 $(CC) -o vsftpd $(OBJS) $(LINK) $(LIBS)
15 12
16 install: 13 install:
17- if [ -x /usr/local/sbin ]; then \ 14- if [ -x /usr/local/sbin ]; then \
diff --git a/meta-networking/recipes-daemons/vsftpd/vsftpd-2.3.5/makefile-libs.patch b/meta-networking/recipes-daemons/vsftpd/vsftpd-2.3.5/makefile-libs.patch
new file mode 100644
index 000000000..6a419db47
--- /dev/null
+++ b/meta-networking/recipes-daemons/vsftpd/vsftpd-2.3.5/makefile-libs.patch
@@ -0,0 +1,21 @@
1Hardcode LIBS instead of using a script to determine available libs
2
3We want to avoid this dynamic detection so we have a deterministic
4build.
5
6Upstream-Status: Inappropriate [config]
7
8Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
9
10diff --git a/Makefile b/Makefile
11--- a/Makefile
12+++ b/Makefile
13@@ -5,7 +5,7 @@ IFLAGS = -idirafter dummyinc
14 #CFLAGS = -g
15 CFLAGS = -O2 -Wall -W -Wshadow #-pedantic -Werror -Wconversion
16
17-LIBS = `./vsf_findlibs.sh`
18+LIBS = -lssl -lcrypto -lnsl -lresolv
19 LINK = -Wl,-s
20
21 OBJS = main.o utility.o prelogin.o ftpcmdio.o postlogin.o privsock.o \
diff --git a/meta-networking/recipes-daemons/vsftpd/vsftpd-2.3.5/makefile-strip.patch b/meta-networking/recipes-daemons/vsftpd/vsftpd-2.3.5/makefile-strip.patch
new file mode 100644
index 000000000..a2e0cd048
--- /dev/null
+++ b/meta-networking/recipes-daemons/vsftpd/vsftpd-2.3.5/makefile-strip.patch
@@ -0,0 +1,17 @@
1Disable stripping at link time
2
3Upstream-Status: Inappropriate [config]
4
5Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
6
7diff --git a/Makefile b/Makefile
8--- a/Makefile
9+++ b/Makefile
10@@ -6,7 +6,6 @@ IFLAGS = -idirafter dummyinc
11 CFLAGS = -O2 -Wall -W -Wshadow #-pedantic -Werror -Wconversion
12
13 LIBS = -lssl -lcrypto -lnsl -lresolv
14-LINK = -Wl,-s
15
16 OBJS = main.o utility.o prelogin.o ftpcmdio.o postlogin.o privsock.o \
17 tunables.o ftpdataio.o secbuf.o ls.o \
diff --git a/meta-oe/recipes-connectivity/vsftpd/vsftpd-2.3.5/nopam.patch b/meta-networking/recipes-daemons/vsftpd/vsftpd-2.3.5/nopam.patch
index 8e0559cad..cf0d68e27 100644
--- a/meta-oe/recipes-connectivity/vsftpd/vsftpd-2.3.5/nopam.patch
+++ b/meta-networking/recipes-daemons/vsftpd/vsftpd-2.3.5/nopam.patch
@@ -1,3 +1,7 @@
1Disable PAM
2
3Upstream-Status: Inappropriate [config]
4
1diff -ur vsftpd-2.0.1_org/builddefs.h vsftpd-2.0.1_patch/builddefs.h 5diff -ur vsftpd-2.0.1_org/builddefs.h vsftpd-2.0.1_patch/builddefs.h
2--- vsftpd-2.0.1_org/builddefs.h 2004-07-02 16:36:59.000000000 +0200 6--- vsftpd-2.0.1_org/builddefs.h 2004-07-02 16:36:59.000000000 +0200
3+++ vsftpd-2.0.1_patch/builddefs.h 2004-07-21 09:34:49.044900488 +0200 7+++ vsftpd-2.0.1_patch/builddefs.h 2004-07-21 09:34:49.044900488 +0200
diff --git a/meta-oe/recipes-connectivity/vsftpd/vsftpd_2.3.5.bb b/meta-networking/recipes-daemons/vsftpd/vsftpd_2.3.5.bb
index 1669d96f8..c02ee9c0a 100644
--- a/meta-oe/recipes-connectivity/vsftpd/vsftpd_2.3.5.bb
+++ b/meta-networking/recipes-daemons/vsftpd/vsftpd_2.3.5.bb
@@ -1,17 +1,22 @@
1DESCRIPTION = "Secure ftp server" 1SUMMARY = "Very Secure FTP server"
2HOMEPAGE="https://security.appspot.com/vsftpd.html" 2HOMEPAGE = "https://security.appspot.com/vsftpd.html"
3SECTION = "network" 3SECTION = "network"
4LICENSE = "GPLv2" 4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=a6067ad950b28336613aed9dd47b1271" 5LIC_FILES_CHKSUM = "file://COPYING;md5=a6067ad950b28336613aed9dd47b1271"
6 6
7DEPENDS = "libcap" 7DEPENDS = "libcap"
8 8
9SRC_URI = "https://security.appspot.com/downloads/vsftpd-2.3.5.tar.gz \ 9SRC_URI = "https://security.appspot.com/downloads/vsftpd-${PV}.tar.gz \
10 file://makefile.patch \ 10 file://makefile-destdir.patch \
11 file://makefile-libs.patch \
12 file://makefile-strip.patch \
11 file://nopam.patch \ 13 file://nopam.patch \
12 file://init \ 14 file://init \
13 file://vsftpd.conf" 15 file://vsftpd.conf"
14 16
17SRC_URI[md5sum] = "01398a5bef8e85b6cf2c213a4b011eca"
18SRC_URI[sha256sum] = "d87ee2987df8f03e1dbe294905f7907b2798deb89c67ca965f6e2f60879e54f1"
19
15inherit update-rc.d useradd 20inherit update-rc.d useradd
16 21
17CONFFILES_${PN} = "${sysconfdir}/vsftpd.conf" 22CONFFILES_${PN} = "${sysconfdir}/vsftpd.conf"
@@ -43,6 +48,4 @@ USERADD_PACKAGES = "${PN}"
43USERADD_PARAM_${PN} = "--system --home-dir /var/lib/ftp --no-create-home -g ftp \ 48USERADD_PARAM_${PN} = "--system --home-dir /var/lib/ftp --no-create-home -g ftp \
44 --shell /bin/false ftp " 49 --shell /bin/false ftp "
45GROUPADD_PARAM_${PN} = "-r ftp" 50GROUPADD_PARAM_${PN} = "-r ftp"
46 51
47SRC_URI[md5sum] = "01398a5bef8e85b6cf2c213a4b011eca"
48SRC_URI[sha256sum] = "d87ee2987df8f03e1dbe294905f7907b2798deb89c67ca965f6e2f60879e54f1"