diff options
author | Tim Orling <ticotimo@gmail.com> | 2024-02-16 16:15:28 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-02-16 16:42:36 -0800 |
commit | 2192056f6729e7de540784337e37860c51d61e04 (patch) | |
tree | 719c9e27352bac06cc3144045e671ae3ff81091b | |
parent | 22e97ce3f18c024bcc645e7b5a0fcd26e9f8b8dd (diff) | |
download | meta-openembedded-2192056f6729e7de540784337e37860c51d61e04.tar.gz |
python3-cbor2: switch to pytest --automake
* Also replace ${PYTHON_PN} with python3
* Be consistent with tabs vs. spaces in do_install_ptest
Signed-off-by: Tim Orling <tim.orling@konsulko.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-python/recipes-devtools/python/python3-cbor2/run-ptest | 2 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-cbor2_5.6.1.bb | 13 |
2 files changed, 8 insertions, 7 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cbor2/run-ptest b/meta-python/recipes-devtools/python/python3-cbor2/run-ptest index b63c4de0d..8d2017d39 100644 --- a/meta-python/recipes-devtools/python/python3-cbor2/run-ptest +++ b/meta-python/recipes-devtools/python/python3-cbor2/run-ptest | |||
@@ -1,3 +1,3 @@ | |||
1 | #!/bin/sh | 1 | #!/bin/sh |
2 | 2 | ||
3 | pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' | 3 | pytest --automake |
diff --git a/meta-python/recipes-devtools/python/python3-cbor2_5.6.1.bb b/meta-python/recipes-devtools/python/python3-cbor2_5.6.1.bb index 2c1b0e67a..e2493e4e1 100644 --- a/meta-python/recipes-devtools/python/python3-cbor2_5.6.1.bb +++ b/meta-python/recipes-devtools/python/python3-cbor2_5.6.1.bb | |||
@@ -1,5 +1,5 @@ | |||
1 | DESCRIPTION = "An implementation of RFC 7049 - Concise Binary Object Representation (CBOR)." | 1 | DESCRIPTION = "An implementation of RFC 7049 - Concise Binary Object Representation (CBOR)." |
2 | DEPENDS +="${PYTHON_PN}-setuptools-scm-native" | 2 | DEPENDS +="python3-setuptools-scm-native" |
3 | 3 | ||
4 | LICENSE = "Apache-2.0" | 4 | LICENSE = "Apache-2.0" |
5 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" | 5 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
@@ -15,18 +15,19 @@ SRC_URI += " \ | |||
15 | " | 15 | " |
16 | 16 | ||
17 | RDEPENDS:${PN}-ptest += " \ | 17 | RDEPENDS:${PN}-ptest += " \ |
18 | ${PYTHON_PN}-hypothesis \ | 18 | python3-hypothesis \ |
19 | ${PYTHON_PN}-pytest \ | 19 | python3-pytest \ |
20 | ${PYTHON_PN}-unixadmin \ | 20 | python3-unittest-automake-output \ |
21 | python3-unixadmin \ | ||
21 | " | 22 | " |
22 | 23 | ||
23 | do_install_ptest() { | 24 | do_install_ptest() { |
24 | install -d ${D}${PTEST_PATH}/tests | 25 | install -d ${D}${PTEST_PATH}/tests |
25 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | 26 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
26 | } | 27 | } |
27 | 28 | ||
28 | RDEPENDS:${PN} += " \ | 29 | RDEPENDS:${PN} += " \ |
29 | ${PYTHON_PN}-datetime \ | 30 | python3-datetime \ |
30 | " | 31 | " |
31 | 32 | ||
32 | BBCLASSEXTEND = "native nativesdk" | 33 | BBCLASSEXTEND = "native nativesdk" |