diff options
author | Khem Raj <raj.khem@gmail.com> | 2023-05-28 15:25:37 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-05-28 16:35:00 -0700 |
commit | 20cea78248b9d8fc47de731d25b4ea26ffa9103b (patch) | |
tree | 727a033f6fdd4a243e607310f87d5120768ea121 | |
parent | 98353572fa7298b5098b0cb48993ab37373dbccc (diff) | |
download | meta-openembedded-20cea78248b9d8fc47de731d25b4ea26ffa9103b.tar.gz |
zfs: Fix build with aarch64
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-filesystems/recipes-filesystems/zfs/zfs/aaf28a4630af60496c9d33db1d06a7d7d8983422.patch | 35 | ||||
-rw-r--r-- | meta-filesystems/recipes-filesystems/zfs/zfs_2.1.11.bb | 6 |
2 files changed, 28 insertions, 13 deletions
diff --git a/meta-filesystems/recipes-filesystems/zfs/zfs/aaf28a4630af60496c9d33db1d06a7d7d8983422.patch b/meta-filesystems/recipes-filesystems/zfs/zfs/aaf28a4630af60496c9d33db1d06a7d7d8983422.patch index f682a412ae..bcca56347c 100644 --- a/meta-filesystems/recipes-filesystems/zfs/zfs/aaf28a4630af60496c9d33db1d06a7d7d8983422.patch +++ b/meta-filesystems/recipes-filesystems/zfs/zfs/aaf28a4630af60496c9d33db1d06a7d7d8983422.patch | |||
@@ -32,23 +32,36 @@ fixes the following error | |||
32 | /mnt/b/yoe/master/build/tmp/work/imx8qm_var_som-yoe-linux/zfs/2.1.9-r0/build/../zfs-2.1.9/module/zfs/vdev_raidz_math_impl.h:1360:9: note: in expansion of macro 'REC_PQR_DEFINE' | 32 | /mnt/b/yoe/master/build/tmp/work/imx8qm_var_som-yoe-linux/zfs/2.1.9-r0/build/../zfs-2.1.9/module/zfs/vdev_raidz_math_impl.h:1360:9: note: in expansion of macro 'REC_PQR_DEFINE' |
33 | 1360 | REC_PQR_DEFINE(); | 33 | 1360 | REC_PQR_DEFINE(); |
34 | 34 | ||
35 | Upstream-Status: Pending [https://github.com/BrainSlayer/zfs/commit/aaf28a4630af60496c9d33db1d06a7d7d8983422] | ||
35 | Signed-off-by: Sebastian Gottschall <s.gottschall@dd-wrt.com> | 36 | Signed-off-by: Sebastian Gottschall <s.gottschall@dd-wrt.com> |
37 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
36 | --- | 38 | --- |
37 | Source: https://github.com/BrainSlayer/zfs/commit/aaf28a4630af60496c9d33db1d06a7d7d8983422 | ||
38 | |||
39 | module/Kbuild.in | 6 +++--- | 39 | module/Kbuild.in | 6 +++--- |
40 | 1 file changed, 3 insertions(+), 3 deletions(-) | 40 | 1 file changed, 3 insertions(+), 3 deletions(-) |
41 | 41 | ||
42 | --- a/module/Kbuild.in | 42 | --- a/module/Kbuild.in |
43 | +++ b/module/Kbuild.in | 43 | +++ b/module/Kbuild.in |
44 | @@ -44,4 +44,10 @@ endif | 44 | @@ -57,9 +57,9 @@ asflags-y := $(ZFS_MODULE_CFLAGS) $(ZFS_ |
45 | subdir-asflags-y := $(ZFS_MODULE_CFLAGS) $(ZFS_MODULE_CPPFLAGS) | 45 | ccflags-y := $(ZFS_MODULE_CFLAGS) $(ZFS_MODULE_CPPFLAGS) |
46 | subdir-ccflags-y := $(ZFS_MODULE_CFLAGS) $(ZFS_MODULE_CPPFLAGS) | ||
47 | 46 | ||
48 | +ifeq ($(CONFIG_ARM64),y) | 47 | ifeq ($(CONFIG_ARM64),y) |
49 | +CFLAGS_REMOVE_zfs_fletcher_aarch64_neon.o = -mgeneral-regs-only | 48 | -CFLAGS_REMOVE_zcommon/zfs_fletcher_aarch64_neon.o += -mgeneral-regs-only |
50 | +CFLAGS_REMOVE_vdev_raidz_math_aarch64_neon.o = -mgeneral-regs-only | 49 | -CFLAGS_REMOVE_zfs/vdev_raidz_math_aarch64_neon.o += -mgeneral-regs-only |
51 | +CFLAGS_REMOVE_vdev_raidz_math_aarch64_neonx2.o = -mgeneral-regs-only | 50 | -CFLAGS_REMOVE_zfs/vdev_raidz_math_aarch64_neonx2.o += -mgeneral-regs-only |
52 | +endif | 51 | +CFLAGS_REMOVE_zcommon/zfs_fletcher_aarch64_neon.o = -mgeneral-regs-only |
53 | + | 52 | +CFLAGS_REMOVE_zfs/vdev_raidz_math_aarch64_neon.o = -mgeneral-regs-only |
53 | +CFLAGS_REMOVE_zfs/vdev_raidz_math_aarch64_neonx2.o = -mgeneral-regs-only | ||
54 | endif | 54 | endif |
55 | |||
56 | # Suppress unused-value warnings in sparc64 architecture headers | ||
57 | --- a/META | ||
58 | +++ b/META | ||
59 | @@ -1,7 +1,7 @@ | ||
60 | Meta: 1 | ||
61 | Name: zfs | ||
62 | Branch: 1.0 | ||
63 | -Version: 2.1.99 | ||
64 | +Version: 2.1.11 | ||
65 | Release: 1 | ||
66 | Release-Tags: relext | ||
67 | License: CDDL | ||
diff --git a/meta-filesystems/recipes-filesystems/zfs/zfs_2.1.11.bb b/meta-filesystems/recipes-filesystems/zfs/zfs_2.1.11.bb index be1e60be7c..942f5f9de1 100644 --- a/meta-filesystems/recipes-filesystems/zfs/zfs_2.1.11.bb +++ b/meta-filesystems/recipes-filesystems/zfs/zfs_2.1.11.bb | |||
@@ -4,11 +4,13 @@ LICENSE = "CDDL-1.0" | |||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=7087caaf1dc8a2856585619f4a787faa" | 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=7087caaf1dc8a2856585619f4a787faa" |
5 | HOMEPAGE ="https://github.com/openzfs/zfs" | 5 | HOMEPAGE ="https://github.com/openzfs/zfs" |
6 | 6 | ||
7 | SRC_URI = "https://github.com/openzfs/zfs/releases/download/${BPN}-${PV}/${BPN}-${PV}.tar.gz \ | 7 | SRCREV = "0f03a411615a797425de488eecfaaf63fc41acfe" |
8 | SRC_URI = "git://github.com/openzfs/zfs;protocol=https;branch=master \ | ||
8 | file://0001-Define-strndupa-if-it-does-not-exist.patch \ | 9 | file://0001-Define-strndupa-if-it-does-not-exist.patch \ |
9 | file://aaf28a4630af60496c9d33db1d06a7d7d8983422.patch \ | 10 | file://aaf28a4630af60496c9d33db1d06a7d7d8983422.patch \ |
10 | " | 11 | " |
11 | SRC_URI[sha256sum] = "a54fe4e854d0a207584f1799a80e165eae66bc30dc8e8c96a1f99ed9d4d8ceb2" | 12 | |
13 | S = "${WORKDIR}/git" | ||
12 | 14 | ||
13 | # Using both 'module' and 'autotools' classes seems a bit odd, they both | 15 | # Using both 'module' and 'autotools' classes seems a bit odd, they both |
14 | # define a do_compile function. | 16 | # define a do_compile function. |