summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2025-01-17 18:59:35 +0000
committerKhem Raj <raj.khem@gmail.com>2025-01-17 11:29:12 -0800
commit1f3fae93747ea39936fd0b31160e64e4fb13ad2e (patch)
tree1d4317f16a646c56d7a029682bf98efd601338c5
parent67d94fecb0dbd4f979b09a439c614ee4f01fc0c2 (diff)
downloadmeta-openembedded-1f3fae93747ea39936fd0b31160e64e4fb13ad2e.tar.gz
python3-semver: update recipe to use the ptest-python-pytest class
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-semver/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-semver_3.0.2.bb14
2 files changed, 1 insertions, 16 deletions
diff --git a/meta-python/recipes-devtools/python/python3-semver/run-ptest b/meta-python/recipes-devtools/python/python3-semver/run-ptest
deleted file mode 100644
index 8d2017d39c..0000000000
--- a/meta-python/recipes-devtools/python/python3-semver/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@
1#!/bin/sh
2
3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-semver_3.0.2.bb b/meta-python/recipes-devtools/python/python3-semver_3.0.2.bb
index 25222bb5ff..b329d65e1f 100644
--- a/meta-python/recipes-devtools/python/python3-semver_3.0.2.bb
+++ b/meta-python/recipes-devtools/python/python3-semver_3.0.2.bb
@@ -6,21 +6,9 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=d9da679db3bdce30a1b4328d5c474f98"
6 6
7SRC_URI[sha256sum] = "6253adb39c70f6e51afed2fa7152bcd414c411286088fb4b9effb133885ab4cc" 7SRC_URI[sha256sum] = "6253adb39c70f6e51afed2fa7152bcd414c411286088fb4b9effb133885ab4cc"
8 8
9inherit pypi python_setuptools_build_meta ptest 9inherit pypi python_setuptools_build_meta ptest-python-pytest
10 10
11BBCLASSEXTEND = "native nativesdk" 11BBCLASSEXTEND = "native nativesdk"
12 12
13SRC_URI += " \
14 file://run-ptest \
15"
16
17DEPENDS += " python3-setuptools-scm-native" 13DEPENDS += " python3-setuptools-scm-native"
18 14
19RDEPENDS:${PN}-ptest += " \
20 python3-pytest \
21 python3-unittest-automake-output \
22"
23
24do_install_ptest() {
25 cp -rf ${S}/tests ${D}${PTEST_PATH}/
26}