summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoralperak <alperyasinak1@gmail.com>2024-03-26 22:25:23 +0300
committerKhem Raj <raj.khem@gmail.com>2024-03-26 12:29:15 -0700
commit1ea98b7bfe36002f1a7bf2fb8097dccd5974c05f (patch)
treeb72e32170d2689bfaf8f63d691b0527ed8a16c65
parent83c80dd111a0c743c2c1bf8971dc49fdaee26be8 (diff)
downloadmeta-openembedded-1ea98b7bfe36002f1a7bf2fb8097dccd5974c05f.tar.gz
python3-portalocker: enable ptest
* test_combined.py deleted because it is not a functional test. It checks if the 'combine' function work correctly which is parse README.rst and LICENSE. * Ptest and library example tested on qemux86-64 and qemuarm64 * Add ptest into PTESTS_FAST_META_PYTHON qemux86-64: Testsuite summary TOTAL: 21 PASS: 21 SKIP: 0 XFAIL: 0 FAIL: 0 XPASS: 0 ERROR: 0 DURATION: 11 END: /usr/lib/python3-portalocker/ptest 2024-03-26T18:47 STOP: ptest-runner TOTAL: 1 FAIL: 0 qemuarm64: Testsuite summary TOTAL: 21 PASS: 21 SKIP: 0 XFAIL: 0 FAIL: 0 XPASS: 0 ERROR: 0 DURATION: 11 END: /usr/lib/python3-portalocker/ptest 2024-03-26T18:52 STOP: ptest-runner TOTAL: 1 FAIL: 0 Signed-off-by: alperak <alperyasinak1@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/conf/include/ptest-packagelists-meta-python.inc1
-rw-r--r--meta-python/recipes-extended/python3-portalocker/python3-portalocker/run-ptest3
-rw-r--r--meta-python/recipes-extended/python3-portalocker/python3-portalocker_2.8.2.bb26
3 files changed, 26 insertions, 4 deletions
diff --git a/meta-python/conf/include/ptest-packagelists-meta-python.inc b/meta-python/conf/include/ptest-packagelists-meta-python.inc
index ec26f768e..ccb443182 100644
--- a/meta-python/conf/include/ptest-packagelists-meta-python.inc
+++ b/meta-python/conf/include/ptest-packagelists-meta-python.inc
@@ -40,6 +40,7 @@ PTESTS_FAST_META_PYTHON = "\
40 python3-parse-type \ 40 python3-parse-type \
41 python3-platformdirs \ 41 python3-platformdirs \
42 python3-polyline \ 42 python3-polyline \
43 python3-portalocker \
43 python3-precise-runner \ 44 python3-precise-runner \
44 python3-prettytable \ 45 python3-prettytable \
45 python3-pydantic \ 46 python3-pydantic \
diff --git a/meta-python/recipes-extended/python3-portalocker/python3-portalocker/run-ptest b/meta-python/recipes-extended/python3-portalocker/python3-portalocker/run-ptest
new file mode 100644
index 000000000..8d2017d39
--- /dev/null
+++ b/meta-python/recipes-extended/python3-portalocker/python3-portalocker/run-ptest
@@ -0,0 +1,3 @@
1#!/bin/sh
2
3pytest --automake
diff --git a/meta-python/recipes-extended/python3-portalocker/python3-portalocker_2.8.2.bb b/meta-python/recipes-extended/python3-portalocker/python3-portalocker_2.8.2.bb
index 69578ba84..c45a3fcda 100644
--- a/meta-python/recipes-extended/python3-portalocker/python3-portalocker_2.8.2.bb
+++ b/meta-python/recipes-extended/python3-portalocker/python3-portalocker_2.8.2.bb
@@ -8,11 +8,29 @@ SRC_URI[sha256sum] = "2b035aa7828e46c58e9b31390ee1f169b98e1066ab10b9a6a861fe7e25
8 8
9DEPENDS += "python3-setuptools-scm-native" 9DEPENDS += "python3-setuptools-scm-native"
10 10
11inherit pypi python_setuptools_build_meta 11inherit pypi python_setuptools_build_meta ptest
12 12
13BBCLASSEXTEND = "native nativesdk" 13SRC_URI += " \
14 file://run-ptest \
15"
16
17RDEPENDS:${PN}-ptest += " \
18 python3-multiprocessing \
19 python3-pytest \
20 python3-redis \
21 python3-unittest-automake-output \
22 redis \
23"
24
25do_install_ptest() {
26 install -d ${D}${PTEST_PATH}/tests
27 cp -rf ${S}/portalocker_tests/* ${D}${PTEST_PATH}/tests/
28 rm -rf ${D}${PTEST_PATH}/tests/test_combined.py
29}
14 30
15RDEPENDS:${PN} += " \ 31RDEPENDS:${PN} += " \
16 python3-fcntl \ 32 python3-fcntl \
17 python3-logging \ 33 python3-logging \
18" 34"
35
36BBCLASSEXTEND = "native nativesdk"