summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-05-05 23:18:00 -0700
committerArmin Kuster <akuster808@gmail.com>2018-05-17 08:19:22 -0700
commit1e38964b009357c3abd508917f4332616d28dea4 (patch)
treea8a687a50af62d822496713840ade727e351c044
parent6cb102d0efc2955af39e249bacbf8c7c2d099684 (diff)
downloadmeta-openembedded-1e38964b009357c3abd508917f4332616d28dea4.tar.gz
nautilus: Fix build with gdx-pixbuf >= to 2.36.11
OE-Core has updates to 2.36.11, so we have to replace obsolete API uses Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-gnome/recipes-gnome/nautilus/nautilus/0001-nautilus-drop-gnome-desktop-thumbnail-API-with-new-g.patch40
-rw-r--r--meta-gnome/recipes-gnome/nautilus/nautilus_3.18.5.bb10
2 files changed, 47 insertions, 3 deletions
diff --git a/meta-gnome/recipes-gnome/nautilus/nautilus/0001-nautilus-drop-gnome-desktop-thumbnail-API-with-new-g.patch b/meta-gnome/recipes-gnome/nautilus/nautilus/0001-nautilus-drop-gnome-desktop-thumbnail-API-with-new-g.patch
new file mode 100644
index 000000000..f19eb4979
--- /dev/null
+++ b/meta-gnome/recipes-gnome/nautilus/nautilus/0001-nautilus-drop-gnome-desktop-thumbnail-API-with-new-g.patch
@@ -0,0 +1,40 @@
1From a4ed38e95cbe07f02028249b8b315565a5ac1e43 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 5 May 2018 22:32:45 -0700
4Subject: [PATCH] nautilus: drop gnome-desktop thumbnail API with new
5 gdk-pixbuf
6MIME-Version: 1.0
7Content-Type: text/plain; charset=UTF-8
8Content-Transfer-Encoding: 8bit
9
10If gdk-pixbuf >= 2.36.5 is available, its scaling API can do what we
11want, so we don’t need to use the deprecated gnome-desktop one.
12
13Also fixes compile errors seen on master
14nautilus-properties-window.c:5101: undefined reference to `gnome_desktop_thumbnail_scale_down_pixbuf'
15
16Upstream-Status: Backport
17
18Signed-off-by: Khem Raj <raj.khem@gmail.com>
19---
20 src/nautilus-properties-window.c | 5 +++--
21 1 file changed, 3 insertions(+), 2 deletions(-)
22
23diff --git a/src/nautilus-properties-window.c b/src/nautilus-properties-window.c
24index dea8b0f..fad9bd1 100644
25--- a/src/nautilus-properties-window.c
26+++ b/src/nautilus-properties-window.c
27@@ -5098,10 +5098,11 @@ update_preview_callback (GtkFileChooser *icon_chooser,
28 scale = (double)gdk_pixbuf_get_height (pixbuf) /
29 gdk_pixbuf_get_width (pixbuf);
30
31- scaled_pixbuf = gnome_desktop_thumbnail_scale_down_pixbuf
32+ scaled_pixbuf = gdk_pixbuf_scale_simple
33 (pixbuf,
34 PREVIEW_IMAGE_WIDTH,
35- scale * PREVIEW_IMAGE_WIDTH);
36+ scale * PREVIEW_IMAGE_WIDTH,
37+ GDK_INTERP_HYPER);
38 g_object_unref (pixbuf);
39 pixbuf = scaled_pixbuf;
40 }
diff --git a/meta-gnome/recipes-gnome/nautilus/nautilus_3.18.5.bb b/meta-gnome/recipes-gnome/nautilus/nautilus_3.18.5.bb
index 8fdbf6ac2..bdb2f3c88 100644
--- a/meta-gnome/recipes-gnome/nautilus/nautilus_3.18.5.bb
+++ b/meta-gnome/recipes-gnome/nautilus/nautilus_3.18.5.bb
@@ -6,14 +6,18 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=36cf660aea2b8beffba7945f44a7e748 \
6 file://COPYING.EXTENSIONS;md5=7579d6678402a1868631bf82c93ff0d4 \ 6 file://COPYING.EXTENSIONS;md5=7579d6678402a1868631bf82c93ff0d4 \
7 file://COPYING.LIB;md5=f30a9716ef3762e3467a2f62bf790f0a" 7 file://COPYING.LIB;md5=f30a9716ef3762e3467a2f62bf790f0a"
8 8
9SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/nautilus/3.18/nautilus-${PV}.tar.xz" 9inherit distro_features_check autotools pkgconfig gobject-introspection
10
11MAJ_VER = "${@oe.utils.trim_version("${PV}", 2)}"
12SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/nautilus/${MAJ_VER}/nautilus-${PV}.tar.xz \
13 file://0001-nautilus-drop-gnome-desktop-thumbnail-API-with-new-g.patch \
14 "
10 15
11SRC_URI[md5sum] = "0f578bda5655c0ce204befafca5803d7" 16SRC_URI[md5sum] = "0f578bda5655c0ce204befafca5803d7"
12SRC_URI[sha256sum] = "60a927c0522b4cced9d8f62baed2ee5e2fd4305be4523eb5bc44805971a6cc15" 17SRC_URI[sha256sum] = "60a927c0522b4cced9d8f62baed2ee5e2fd4305be4523eb5bc44805971a6cc15"
13 18
14DEPENDS = "gtk+3 gnome-desktop3 gsettings-desktop-schemas glib-2.0-native intltool-native pango" 19DEPENDS = "gtk+3 gnome-desktop3 gsettings-desktop-schemas glib-2.0-native intltool-native pango"
15 20
16inherit distro_features_check autotools pkgconfig gobject-introspection
17REQUIRED_DISTRO_FEATURES = "x11" 21REQUIRED_DISTRO_FEATURES = "x11"
18 22
19EXTRA_OECONF = " \ 23EXTRA_OECONF = " \
@@ -23,7 +27,7 @@ EXTRA_OECONF = " \
23 --enable-tracker=no \ 27 --enable-tracker=no \
24 --disable-schemas-compile \ 28 --disable-schemas-compile \
25 --enable-xmp=no \ 29 --enable-xmp=no \
26 --enable-libexif=no \ 30 --enable-libexif=no \
27" 31"
28 32
29FILES_${PN} += "${datadir}/*" 33FILES_${PN} += "${datadir}/*"