summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrej Valek <andrej.valek@siemens.com>2019-02-17 12:03:21 +0100
committerKhem Raj <raj.khem@gmail.com>2019-02-17 12:40:56 -0800
commit1c8e4a679ae382f953b2e5c7a4966a4646314f3e (patch)
tree7da4c584aa7444f0a35eede0e0700b3ed794ea3e
parentb1ccca4bacda568062804c7c90aeb15e704c2eb9 (diff)
downloadmeta-openembedded-1c8e4a679ae382f953b2e5c7a4966a4646314f3e.tar.gz
nodejs 8.15.0 -> 10.15.1
Update nodejs to active 10.x LTS release 10.15.1. - link atomic library - make it compatible with gcc < 4.9 Signed-off-by: Andrej Valek <andrej.valek@siemens.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs/0001-Disable-running-gyp-files-for-bundled-deps.patch23
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs/0002-Using-native-torque.patch36
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs/0003-Crypto-reduce-memory-usage-of-SignFinal.patch122
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs/0004-Make-compatibility-with-gcc-4.8.patch26
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs/0005-Link-atomic-library.patch20
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_10.15.1.bb (renamed from meta-oe/recipes-devtools/nodejs/nodejs_8.15.0.bb)20
6 files changed, 230 insertions, 17 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs/0001-Disable-running-gyp-files-for-bundled-deps.patch b/meta-oe/recipes-devtools/nodejs/nodejs/0001-Disable-running-gyp-files-for-bundled-deps.patch
index 324a4683d..5d0dc03b6 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs/0001-Disable-running-gyp-files-for-bundled-deps.patch
+++ b/meta-oe/recipes-devtools/nodejs/nodejs/0001-Disable-running-gyp-files-for-bundled-deps.patch
@@ -4,26 +4,23 @@ Date: Thu, 27 Apr 2017 14:25:42 +0200
4Subject: [PATCH] Disable running gyp on shared deps 4Subject: [PATCH] Disable running gyp on shared deps
5 5
6--- 6---
7 Makefile | 7 +++---- 7 Makefile | 4 ++--
8 1 file changed, 3 insertions(+), 4 deletions(-) 8 1 file changed, 2 insertions(+), 2 deletions(-)
9 9
10diff --git a/Makefile b/Makefile 10diff --git a/Makefile b/Makefile
11index 0a217bd893..e1229ad07f 100644 11index a98772f..f5663e2 100644
12--- a/Makefile 12--- a/Makefile
13+++ b/Makefile 13+++ b/Makefile
14@@ -79,10 +79,9 @@ $(NODE_G_EXE): config.gypi out/Makefile 14@@ -123,8 +123,8 @@ with-code-cache:
15 $(MAKE) -C out BUILDTYPE=Debug V=$(V) 15 test-code-cache: with-code-cache
16 if [ ! -r $@ -o ! -L $@ ]; then ln -fs out/Debug/$(NODE_EXE) $@; fi 16 $(PYTHON) tools/test.py $(PARALLEL_ARGS) --mode=$(BUILDTYPE_LOWER) code-cache
17 17
18-out/Makefile: common.gypi deps/uv/uv.gyp deps/http_parser/http_parser.gyp \ 18-out/Makefile: common.gypi deps/uv/uv.gyp deps/http_parser/http_parser.gyp \
19- deps/zlib/zlib.gyp deps/v8/gypfiles/toolchain.gypi \ 19- deps/zlib/zlib.gyp deps/v8/gypfiles/toolchain.gypi \
20- deps/v8/gypfiles/features.gypi deps/v8/src/v8.gyp node.gyp \
21- config.gypi
22+out/Makefile: common.gypi deps/http_parser/http_parser.gyp \ 20+out/Makefile: common.gypi deps/http_parser/http_parser.gyp \
23+ deps/v8/gypfiles/toolchain.gypi deps/v8/gypfiles/features.gypi \ 21+ deps/v8/gypfiles/toolchain.gypi \
24+ deps/v8/src/v8.gyp node.gyp config.gypi 22 deps/v8/gypfiles/features.gypi deps/v8/gypfiles/v8.gyp node.gyp \
23 config.gypi
25 $(PYTHON) tools/gyp_node.py -f make 24 $(PYTHON) tools/gyp_node.py -f make
26
27 config.gypi: configure
28-- 25--
292.12.2 262.19.2
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs/0002-Using-native-torque.patch b/meta-oe/recipes-devtools/nodejs/nodejs/0002-Using-native-torque.patch
new file mode 100644
index 000000000..e9035f9eb
--- /dev/null
+++ b/meta-oe/recipes-devtools/nodejs/nodejs/0002-Using-native-torque.patch
@@ -0,0 +1,36 @@
1From 4bbee5e3d58bc4911999f3ec2cc5aab8ded6717b Mon Sep 17 00:00:00 2001
2From: "Winker Matthias (TT-CA/ENG1)" <Matthias.Winker@de.bosch.com>
3Date: Tue, 11 Dec 2018 10:44:29 +0100
4Subject: [PATCH] Using native torque
5
6---
7 deps/v8/gypfiles/v8.gyp | 6 ++++--
8 1 file changed, 4 insertions(+), 2 deletions(-)
9
10diff --git a/deps/v8/gypfiles/v8.gyp b/deps/v8/gypfiles/v8.gyp
11index 8c78f02255..434168844e 100644
12--- a/deps/v8/gypfiles/v8.gyp
13+++ b/deps/v8/gypfiles/v8.gyp
14@@ -2831,7 +2831,6 @@
15 {
16 'action_name': 'run_torque',
17 'inputs': [ # Order matters.
18- '<(PRODUCT_DIR)/<(EXECUTABLE_PREFIX)torque<(EXECUTABLE_SUFFIX)',
19 '../src/builtins/base.tq',
20 '../src/builtins/array.tq',
21 '../src/builtins/typed-array.tq',
22@@ -2845,7 +2844,10 @@
23 '<(SHARED_INTERMEDIATE_DIR)/torque-generated/builtins-typed-array-from-dsl-gen.cc',
24 '<(SHARED_INTERMEDIATE_DIR)/torque-generated/builtins-typed-array-from-dsl-gen.h',
25 ],
26- 'action': ['<@(_inputs)', '-o', '<(SHARED_INTERMEDIATE_DIR)/torque-generated'],
27+ 'action': [
28+ 'torque',
29+ '<@(_inputs)',
30+ '-o', '<(SHARED_INTERMEDIATE_DIR)/torque-generated'],
31 },
32 ],
33 }, # torque
34--
352.19.2
36
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs/0003-Crypto-reduce-memory-usage-of-SignFinal.patch b/meta-oe/recipes-devtools/nodejs/nodejs/0003-Crypto-reduce-memory-usage-of-SignFinal.patch
new file mode 100644
index 000000000..ed3bac39b
--- /dev/null
+++ b/meta-oe/recipes-devtools/nodejs/nodejs/0003-Crypto-reduce-memory-usage-of-SignFinal.patch
@@ -0,0 +1,122 @@
1From 20282b1cb0389553421c4c5b14de198c5dfff50b Mon Sep 17 00:00:00 2001
2From: Anna Henningsen <anna@addaleax.net>
3Date: Sat, 20 Oct 2018 05:24:54 +0200
4Subject: [PATCH] src: use more explicit return type in Sign::SignFinal()
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9Using the non-indexed variant of `std::get<>` broke Travis CI.
10Also, this allows us to be a bit more concise when returning
11from `SignFinal()` due to some error condition.
12
13Refs: https://github.com/nodejs/node/pull/23427
14
15PR-URL: https://github.com/nodejs/node/pull/23779
16Reviewed-By: Joyee Cheung <joyeec9h3@gmail.com>
17Reviewed-By: Tobias Nießen <tniessen@tnie.de>
18Reviewed-By: Refael Ackermann <refack@gmail.com>
19Reviewed-By: Colin Ihrig <cjihrig@gmail.com>
20---
21 src/node_crypto.cc | 23 +++++++++++------------
22 src/node_crypto.h | 12 +++++++++++-
23 2 files changed, 22 insertions(+), 13 deletions(-)
24
25diff --git a/src/node_crypto.cc b/src/node_crypto.cc
26index bd8d9e032554..ec7d4f2bb5be 100644
27--- a/src/node_crypto.cc
28+++ b/src/node_crypto.cc
29@@ -3562,22 +3562,20 @@ static MallocedBuffer<unsigned char> Node_SignFinal(EVPMDPointer&& mdctx,
30 return MallocedBuffer<unsigned char>();
31 }
32
33-std::pair<SignBase::Error, MallocedBuffer<unsigned char>> Sign::SignFinal(
34+Sign::SignResult Sign::SignFinal(
35 const char* key_pem,
36 int key_pem_len,
37 const char* passphrase,
38 int padding,
39 int salt_len) {
40- MallocedBuffer<unsigned char> buffer;
41-
42 if (!mdctx_)
43- return std::make_pair(kSignNotInitialised, std::move(buffer));
44+ return SignResult(kSignNotInitialised);
45
46 EVPMDPointer mdctx = std::move(mdctx_);
47
48 BIOPointer bp(BIO_new_mem_buf(const_cast<char*>(key_pem), key_pem_len));
49 if (!bp)
50- return std::make_pair(kSignPrivateKey, std::move(buffer));
51+ return SignResult(kSignPrivateKey);
52
53 EVPKeyPointer pkey(PEM_read_bio_PrivateKey(bp.get(),
54 nullptr,
55@@ -3588,7 +3586,7 @@ std::pair<SignBase::Error, MallocedBuffer<unsigned char>> Sign::SignFinal(
56 // without `pkey` being set to nullptr;
57 // cf. the test of `test_bad_rsa_privkey.pem` for an example.
58 if (!pkey || 0 != ERR_peek_error())
59- return std::make_pair(kSignPrivateKey, std::move(buffer));
60+ return SignResult(kSignPrivateKey);
61
62 #ifdef NODE_FIPS_MODE
63 /* Validate DSA2 parameters from FIPS 186-4 */
64@@ -3612,9 +3610,10 @@ std::pair<SignBase::Error, MallocedBuffer<unsigned char>> Sign::SignFinal(
65 }
66 #endif // NODE_FIPS_MODE
67
68- buffer = Node_SignFinal(std::move(mdctx), pkey, padding, salt_len);
69+ MallocedBuffer<unsigned char> buffer =
70+ Node_SignFinal(std::move(mdctx), pkey, padding, salt_len);
71 Error error = buffer.is_empty() ? kSignPrivateKey : kSignOk;
72- return std::make_pair(error, std::move(buffer));
73+ return SignResult(error, std::move(buffer));
74 }
75
76
77@@ -3639,18 +3638,18 @@ void Sign::SignFinal(const FunctionCallbackInfo<Value>& args) {
78
79 ClearErrorOnReturn clear_error_on_return;
80
81- std::pair<Error, MallocedBuffer<unsigned char>> ret = sign->SignFinal(
82+ SignResult ret = sign->SignFinal(
83 buf,
84 buf_len,
85 len >= 2 && !args[1]->IsNull() ? *passphrase : nullptr,
86 padding,
87 salt_len);
88
89- if (std::get<Error>(ret) != kSignOk)
90- return sign->CheckThrow(std::get<Error>(ret));
91+ if (ret.error != kSignOk)
92+ return sign->CheckThrow(ret.error);
93
94 MallocedBuffer<unsigned char> sig =
95- std::move(std::get<MallocedBuffer<unsigned char>>(ret));
96+ std::move(ret.signature);
97
98 Local<Object> rc =
99 Buffer::New(env, reinterpret_cast<char*>(sig.release()), sig.size)
100diff --git a/src/node_crypto.h b/src/node_crypto.h
101index 6fcf737f6c43..0c26c1f6ff1d 100644
102--- a/src/node_crypto.h
103+++ b/src/node_crypto.h
104@@ -518,7 +518,17 @@ class Sign : public SignBase {
105 public:
106 static void Initialize(Environment* env, v8::Local<v8::Object> target);
107
108- std::pair<Error, MallocedBuffer<unsigned char>> SignFinal(
109+ struct SignResult {
110+ Error error;
111+ MallocedBuffer<unsigned char> signature;
112+
113+ explicit SignResult(
114+ Error err,
115+ MallocedBuffer<unsigned char>&& sig = MallocedBuffer<unsigned char>())
116+ : error(err), signature(std::move(sig)) {}
117+ };
118+
119+ SignResult SignFinal(
120 const char* key_pem,
121 int key_pem_len,
122 const char* passphrase,
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs/0004-Make-compatibility-with-gcc-4.8.patch b/meta-oe/recipes-devtools/nodejs/nodejs/0004-Make-compatibility-with-gcc-4.8.patch
new file mode 100644
index 000000000..2b325b675
--- /dev/null
+++ b/meta-oe/recipes-devtools/nodejs/nodejs/0004-Make-compatibility-with-gcc-4.8.patch
@@ -0,0 +1,26 @@
1Implement function as wrapper for std::make_unique
2method to be compatible with gcc < 4.9 .
3"error::make_unique is not a member of 'std'"
4
5Signed-off-by: Andrej Valek <andrej.valek@siemens.com>
6
7diff -Naur node-v10.15.1/src/cares_wrap.cc node-v10.15.1/src/cares_wrap.cc
8--- node-v10.15.1/src/cares_wrap.cc 2019-02-17 09:40:36.040538319 +0100
9+++ node-v10.15.1/src/cares_wrap.cc 2019-02-17 09:39:57.883668702 +0100
10@@ -52,6 +52,16 @@
11 # define AI_V4MAPPED 0
12 #endif
13
14+#ifndef __cpp_lib_make_unique
15+ namespace std {
16+ /// make_unique implementation
17+ template<typename T, typename... Args>
18+ std::unique_ptr<T> make_unique(Args&&... args) {
19+ return std::unique_ptr<T>(new T(std::forward<Args>(args)...));
20+ }
21+ }
22+#endif
23+
24 namespace node {
25 namespace cares_wrap {
26
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs/0005-Link-atomic-library.patch b/meta-oe/recipes-devtools/nodejs/nodejs/0005-Link-atomic-library.patch
new file mode 100644
index 000000000..66ff18b4a
--- /dev/null
+++ b/meta-oe/recipes-devtools/nodejs/nodejs/0005-Link-atomic-library.patch
@@ -0,0 +1,20 @@
1Link atomic library to fix missing undefined referrences
2like "undefined reference to `__atomic_fetch_add_8'"
3
4Signed-off-by: Andrej Valek <andrej.valek@siemens.com>
5
6diff -Naur node-v10.15.1/deps/v8/gypfiles/v8.gyp node-v10.15.1/deps/v8/gypfiles/v8.gyp
7--- node-v10.15.1/deps/v8/gypfiles/v8.gyp 2019-02-13 09:02:21.000000000 +0100
8+++ node-v10.15.1/deps/v8/gypfiles/v8.gyp 2019-02-15 21:27:11.755679660 +0100
9@@ -452,6 +452,11 @@
10 '<(DEPTH)',
11 '<(SHARED_INTERMEDIATE_DIR)'
12 ],
13+ 'link_settings': {
14+ 'libraries': [
15+ '-latomic'
16+ ],
17+ },
18 'sources': [
19 '<@(inspector_all_sources)',
20 '../include//v8-inspector-protocol.h',
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_8.15.0.bb b/meta-oe/recipes-devtools/nodejs/nodejs_10.15.1.bb
index 44eaee974..17c9bb0c4 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs_8.15.0.bb
+++ b/meta-oe/recipes-devtools/nodejs/nodejs_10.15.1.bb
@@ -1,9 +1,10 @@
1DESCRIPTION = "nodeJS Evented I/O for V8 JavaScript" 1DESCRIPTION = "nodeJS Evented I/O for V8 JavaScript"
2HOMEPAGE = "http://nodejs.org" 2HOMEPAGE = "http://nodejs.org"
3LICENSE = "MIT & BSD & Artistic-2.0" 3LICENSE = "MIT & BSD & Artistic-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=fde91d5c5bbd1e0389623e1ac018d9e8" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=9ceeba79eb2ea1067b7b3ed16fff8bab"
5 5
6DEPENDS = "openssl zlib icu" 6DEPENDS = "openssl zlib icu"
7DEPENDS_append_class-target = " nodejs-native"
7 8
8inherit pkgconfig 9inherit pkgconfig
9 10
@@ -13,9 +14,16 @@ COMPATIBLE_MACHINE_mips64 = "(!.*mips64).*"
13 14
14SRC_URI = "http://nodejs.org/dist/v${PV}/node-v${PV}.tar.xz \ 15SRC_URI = "http://nodejs.org/dist/v${PV}/node-v${PV}.tar.xz \
15 file://0001-Disable-running-gyp-files-for-bundled-deps.patch \ 16 file://0001-Disable-running-gyp-files-for-bundled-deps.patch \
16" 17 file://0003-Crypto-reduce-memory-usage-of-SignFinal.patch \
17SRC_URI[md5sum] = "bfc5da493c72ded3a7f43b5662bfc53c" 18 file://0004-Make-compatibility-with-gcc-4.8.patch \
18SRC_URI[sha256sum] = "968523333947cc3f769d73dedc6c9c60580826d8714bc0e62ca4589de6a7c633" 19 file://0005-Link-atomic-library.patch \
20 "
21SRC_URI_append_class-target = " \
22 file://0002-Using-native-torque.patch \
23 "
24
25SRC_URI[md5sum] = "1cad7963255de53509bfa560221bdc88"
26SRC_URI[sha256sum] = "1a55f7b9fb80442182d9e1eba4fca4dac3c781cdcb25d6be37b24d253f61c858"
19 27
20S = "${WORKDIR}/node-v${PV}" 28S = "${WORKDIR}/node-v${PV}"
21 29
@@ -74,6 +82,10 @@ do_install_append_class-native() {
74 # use sed on npm-cli.js because otherwise symlink is replaced with normal file and 82 # use sed on npm-cli.js because otherwise symlink is replaced with normal file and
75 # npm-cli.js continues to use old shebang 83 # npm-cli.js continues to use old shebang
76 sed "1s^.*^#\!/usr/bin/env node^g" -i ${D}${exec_prefix}/lib/node_modules/npm/bin/npm-cli.js 84 sed "1s^.*^#\!/usr/bin/env node^g" -i ${D}${exec_prefix}/lib/node_modules/npm/bin/npm-cli.js
85
86 # Install the native torque to provide it within sysroot for the target compilation
87 install -d ${D}${bindir}
88 install -m 0755 ${S}/out/Release/torque ${D}${bindir}/torque
77} 89}
78 90
79do_install_append_class-target() { 91do_install_append_class-target() {