summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-04-12 23:04:53 -0700
committerKhem Raj <raj.khem@gmail.com>2024-04-12 23:07:33 -0700
commit1a03565ce3670c7f677fd27102aab179e23f1126 (patch)
treeade15d6b1ac726b932b8c3a7fbe953a7f0d0c86c
parentb201a26bd9280edb8262cbb01c72d48bb14a0acf (diff)
downloadmeta-openembedded-1a03565ce3670c7f677fd27102aab179e23f1126.tar.gz
psqlodbc: Fix ptests
There are two still left Failed ptests: {'psqlodbc': ['30_-_lfconversion', '43_-_result-conversions']} These need using unicode postgresql driver perhaps Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-dbs/psqlodbc/files/psqlodbc-fix-for-ptest-support.patch19
-rw-r--r--meta-oe/recipes-dbs/psqlodbc/psqlodbc_16.00.0000.bb4
2 files changed, 13 insertions, 10 deletions
diff --git a/meta-oe/recipes-dbs/psqlodbc/files/psqlodbc-fix-for-ptest-support.patch b/meta-oe/recipes-dbs/psqlodbc/files/psqlodbc-fix-for-ptest-support.patch
index 30e67b7df..081c6d0fd 100644
--- a/meta-oe/recipes-dbs/psqlodbc/files/psqlodbc-fix-for-ptest-support.patch
+++ b/meta-oe/recipes-dbs/psqlodbc/files/psqlodbc-fix-for-ptest-support.patch
@@ -19,8 +19,6 @@ Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
19 test/runsuite.c | 20 ++++++++++---------- 19 test/runsuite.c | 20 ++++++++++----------
20 3 files changed, 15 insertions(+), 15 deletions(-) 20 3 files changed, 15 insertions(+), 15 deletions(-)
21 21
22diff --git a/test/Makefile.in b/test/Makefile.in
23index 3f9a9af..09406ae 100644
24--- a/test/Makefile.in 22--- a/test/Makefile.in
25+++ b/test/Makefile.in 23+++ b/test/Makefile.in
26@@ -19,7 +19,7 @@ CPPFLAGS = @CPPFLAGS@ -I.. # config.h 24@@ -19,7 +19,7 @@ CPPFLAGS = @CPPFLAGS@ -I.. # config.h
@@ -32,8 +30,6 @@ index 3f9a9af..09406ae 100644
32 30
33 all: $(TESTBINS) runsuite reset-db 31 all: $(TESTBINS) runsuite reset-db
34 32
35diff --git a/test/odbcini-gen.sh b/test/odbcini-gen.sh
36index 2eaba35..6555cdb 100755
37--- a/test/odbcini-gen.sh 33--- a/test/odbcini-gen.sh
38+++ b/test/odbcini-gen.sh 34+++ b/test/odbcini-gen.sh
39@@ -6,7 +6,7 @@ 35@@ -6,7 +6,7 @@
@@ -45,6 +41,15 @@ index 2eaba35..6555cdb 100755
45 driver=${drvr}.so 41 driver=${drvr}.so
46 if test ! -e $driver ; then 42 if test ! -e $driver ; then
47 driver=${drvr}.dll 43 driver=${drvr}.dll
44@@ -16,7 +16,7 @@ if test ! -e $driver ; then
45 fi
46 fi
47
48-drvra=../.libs/psqlodbca
49+drvra=@LIBDIR@/psqlodbca
50 drivera=${drvra}.so
51 if test ! -e $drivera ; then
52 drivera=${drvra}.dll
48@@ -52,10 +52,10 @@ Driver = PostgreSQL Unicode 53@@ -52,10 +52,10 @@ Driver = PostgreSQL Unicode
49 Trace = No 54 Trace = No
50 TraceFile = 55 TraceFile =
@@ -59,8 +64,6 @@ index 2eaba35..6555cdb 100755
59 ReadOnly = No 64 ReadOnly = No
60 RowVersioning = No 65 RowVersioning = No
61 ShowSystemTables = No 66 ShowSystemTables = No
62diff --git a/test/runsuite.c b/test/runsuite.c
63index 3be5732..cd842dc 100644
64--- a/test/runsuite.c 67--- a/test/runsuite.c
65+++ b/test/runsuite.c 68+++ b/test/runsuite.c
66@@ -55,7 +55,7 @@ bailout(const char *fmt, ...) 69@@ -55,7 +55,7 @@ bailout(const char *fmt, ...)
@@ -72,7 +75,7 @@ index 3be5732..cd842dc 100644
72 { 75 {
73 const char *basename; 76 const char *basename;
74 #ifdef WIN32 77 #ifdef WIN32
75@@ -69,7 +69,7 @@ parse_argument(const char *in, char *testname, char *binname) 78@@ -69,7 +69,7 @@ parse_argument(const char *in, char *tes
76 if (strchr(in, DIR_SEP) == NULL) 79 if (strchr(in, DIR_SEP) == NULL)
77 { 80 {
78 strcpy(testname, in); 81 strcpy(testname, in);
@@ -90,7 +93,7 @@ index 3be5732..cd842dc 100644
90 if (runtest(binname, testname, i, inputdir) != 0) 93 if (runtest(binname, testname, i, inputdir) != 0)
91 failures++; 94 failures++;
92 } 95 }
93@@ -161,29 +161,29 @@ runtest(const char *binname, const char *testname, int testno, const char *input 96@@ -161,29 +161,29 @@ runtest(const char *binname, const char
94 #ifndef WIN32 97 #ifndef WIN32
95 snprintf(cmdline, sizeof(cmdline), 98 snprintf(cmdline, sizeof(cmdline),
96 "ODBCSYSINI=. ODBCINSTINI=./odbcinst.ini ODBCINI=./odbc.ini " 99 "ODBCSYSINI=. ODBCINSTINI=./odbcinst.ini ODBCINI=./odbc.ini "
diff --git a/meta-oe/recipes-dbs/psqlodbc/psqlodbc_16.00.0000.bb b/meta-oe/recipes-dbs/psqlodbc/psqlodbc_16.00.0000.bb
index 97333f679..a1ef8e75e 100644
--- a/meta-oe/recipes-dbs/psqlodbc/psqlodbc_16.00.0000.bb
+++ b/meta-oe/recipes-dbs/psqlodbc/psqlodbc_16.00.0000.bb
@@ -58,5 +58,5 @@ do_install_ptest() {
58FILES:${PN} += "${libdir}" 58FILES:${PN} += "${libdir}"
59 59
60# The tests need a local PostgreSQL server running 60# The tests need a local PostgreSQL server running
61RDEPENDS:${PN}-ptest = "postgresql" 61RDEPENDS:${PN}-ptest += "psqlodbc postgresql diffutils"
62 62RDEPENDS:${PN}-ptest:append:libc-glibc = " glibc-utils locale-base-en-us glibc-gconv glibc-charmaps"