summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPascal Bach <pascal.bach@siemens.com>2018-05-16 13:52:02 +0200
committerArmin Kuster <akuster808@gmail.com>2018-05-17 08:31:12 -0700
commit19e7db690ad32db758f526fd4f5cb82b0b5a6e23 (patch)
tree8acf9f4e15deeee58d509cc79fb026c08abbe9f2
parent8d6b55c95ccb9582059103459de97862b1dea75f (diff)
downloadmeta-openembedded-19e7db690ad32db758f526fd4f5cb82b0b5a6e23.tar.gz
poco: update to 1.9.0
Enable the new Encodings and Redis packages by default. Splitting into sub packages now uses PACKAGES_DYNAMIC instead of the custom logic used before. Signed-off-by: Pascal Bach <pascal.bach@siemens.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/poco/poco_1.9.0.bb (renamed from meta-oe/recipes-support/poco/poco_1.8.0.1.bb)42
1 files changed, 17 insertions, 25 deletions
diff --git a/meta-oe/recipes-support/poco/poco_1.8.0.1.bb b/meta-oe/recipes-support/poco/poco_1.9.0.bb
index 160b4d391..1016caef7 100644
--- a/meta-oe/recipes-support/poco/poco_1.8.0.1.bb
+++ b/meta-oe/recipes-support/poco/poco_1.9.0.bb
@@ -12,7 +12,7 @@ inherit cmake ptest
12 12
13BBCLASSEXTEND = "native" 13BBCLASSEXTEND = "native"
14 14
15SRCREV = "af527ab21fca5ab2659285408aec9920ed7c7b17" 15SRCREV = "94966785a8f9ad0191dffd075ebd67826e6e4b6d"
16SRC_URI = " \ 16SRC_URI = " \
17 git://github.com/pocoproject/poco.git \ 17 git://github.com/pocoproject/poco.git \
18 file://run-ptest \ 18 file://run-ptest \
@@ -33,7 +33,7 @@ EXTRA_OECMAKE_append = " -DCMAKE_SKIP_RPATH=ON"
33# By default the most commonly used poco components are built 33# By default the most commonly used poco components are built
34# Foundation is built anyway and doesn't need to be listed explicitly 34# Foundation is built anyway and doesn't need to be listed explicitly
35# these don't have dependencies outside oe-core 35# these don't have dependencies outside oe-core
36PACKAGECONFIG ??= "XML JSON MongoDB PDF Util Net NetSSL Crypto Data DataSQLite Zip" 36PACKAGECONFIG ??= "XML JSON MongoDB PDF Util Net NetSSL Crypto Data DataSQLite Zip Encodings Redis"
37 37
38PACKAGECONFIG[XML] = "-DENABLE_XML=ON -DEXPAT_LIBRARY:STRING=expat,-DENABLE_XML=OFF,expat" 38PACKAGECONFIG[XML] = "-DENABLE_XML=ON -DEXPAT_LIBRARY:STRING=expat,-DENABLE_XML=OFF,expat"
39PACKAGECONFIG[JSON] = "-DENABLE_JSON=ON,-DENABLE_JSON=OFF" 39PACKAGECONFIG[JSON] = "-DENABLE_JSON=ON,-DENABLE_JSON=OFF"
@@ -46,6 +46,8 @@ PACKAGECONFIG[Crypto] = "-DENABLE_CRYPTO=ON -DOPENSSL_SSL_LIBRARY:STRING=ssl -DO
46PACKAGECONFIG[Data] = "-DENABLE_DATA=ON,-DENABLE_DATA=OFF" 46PACKAGECONFIG[Data] = "-DENABLE_DATA=ON,-DENABLE_DATA=OFF"
47PACKAGECONFIG[DataSQLite] = "-DENABLE_DATA_SQLITE=ON -DSQLITE3_LIBRARY:STRING=sqlite3,-DENABLE_DATA_SQLITE=OFF,sqlite3" 47PACKAGECONFIG[DataSQLite] = "-DENABLE_DATA_SQLITE=ON -DSQLITE3_LIBRARY:STRING=sqlite3,-DENABLE_DATA_SQLITE=OFF,sqlite3"
48PACKAGECONFIG[Zip] = "-DENABLE_ZIP=ON,-DENABLE_ZIP=OFF" 48PACKAGECONFIG[Zip] = "-DENABLE_ZIP=ON,-DENABLE_ZIP=OFF"
49PACKAGECONFIG[Encodings] = "-DENABLE_ENCODINGS=ON,-DENABLE_ENCODINGS=OFF"
50PACKAGECONFIG[Redis] = "-DENABLE_REDIS=ON,-DENABLE_REDIS=OFF"
49 51
50# Additional components not build by default, 52# Additional components not build by default,
51# they might have dependencies not included in oe-core 53# they might have dependencies not included in oe-core
@@ -58,40 +60,30 @@ PACKAGECONFIG[PageCompiler] = "-DENABLE_PAGECOMPILER=ON,-DENABLE_PAGECOMPILER=OF
58PACKAGECONFIG[PageCompilerFile2Page] = "-DENABLE_PAGECOMPILER_FILE2PAGE=ON,-DENABLE_PAGECOMPILER_FILE2PAGE=OFF" 60PACKAGECONFIG[PageCompilerFile2Page] = "-DENABLE_PAGECOMPILER_FILE2PAGE=ON,-DENABLE_PAGECOMPILER_FILE2PAGE=OFF"
59PACKAGECONFIG[SevenZip] = "-DENABLE_SEVENZIP=ON,-DENABLE_SEVENZIP=OFF" 61PACKAGECONFIG[SevenZip] = "-DENABLE_SEVENZIP=ON,-DENABLE_SEVENZIP=OFF"
60 62
61# Make a package for each library 63python populate_packages_prepend () {
62PACKAGES = "${PN}-dbg ${POCO_PACKAGES}" 64 poco_libdir = d.expand('${libdir}')
63python __anonymous () { 65 pn = d.getVar("PN")
64 packages = [] 66 packages = []
65 testrunners = [] 67 testrunners = []
66 components = d.getVar("PACKAGECONFIG").split() 68
67 components.append("Foundation") 69 def hook(f, pkg, file_regex, output_pattern, modulename):
68 for lib in components:
69 pkg = ("poco-%s" % lib.lower()).replace("_","")
70 packages.append(pkg) 70 packages.append(pkg)
71 if not d.getVar("FILES_%s" % pkg): 71 testrunners.append(modulename)
72 d.setVar("FILES_%s" % pkg, "${libdir}/libPoco%s.so.*" % lib) 72
73 testrunners.append("%s" % lib) 73 do_split_packages(d, poco_libdir, '^libPoco(.*)\.so\..*$',
74 'poco-%s', 'Poco %s component', extra_depends='', prepend=True, hook=hook)
74 75
75 d.setVar("POCO_PACKAGES", " ".join(packages)) 76 d.setVar("RRECOMMENDS_%s" % pn, " ".join(packages))
76 d.setVar("POCO_TESTRUNNERS", "\n".join(testrunners)) 77 d.setVar("POCO_TESTRUNNERS", "\n".join(testrunners))
77} 78}
78 79
80PACKAGES_DYNAMIC = "poco-.*"
81
79# "poco" is a metapackage which pulls in all Poco components 82# "poco" is a metapackage which pulls in all Poco components
80PACKAGES += "${PN}"
81RRECOMMENDS_${PN} += "${POCO_PACKAGES}"
82RRECOMMENDS_${PN}_class-native = ""
83ALLOW_EMPTY_${PN} = "1" 83ALLOW_EMPTY_${PN} = "1"
84 84
85# -dev last to pick up the remaining stuff
86PACKAGES += "${PN}-dev ${PN}-staticdev"
87FILES_${PN}-dev = "${includedir} ${libdir}/libPoco*.so ${libdir}/cmake"
88FILES_${PN}-staticdev = "${libdir}/libPoco*.a"
89
90# ptest support
91FILES_${PN}-dbg += "${PTEST_PATH}/bin/.debug"
92
93# cppunit is only built if tests are enabled 85# cppunit is only built if tests are enabled
94PACKAGES += "${PN}-cppunit" 86PACKAGES =+ "${PN}-cppunit"
95FILES_${PN}-cppunit += "${libdir}/libCppUnit.so*" 87FILES_${PN}-cppunit += "${libdir}/libCppUnit.so*"
96ALLOW_EMPTY_${PN}-cppunit = "1" 88ALLOW_EMPTY_${PN}-cppunit = "1"
97 89