summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBill Randle <bill.randle@gmail.com>2017-12-07 21:49:10 -0800
committerArmin Kuster <akuster808@gmail.com>2017-12-22 19:43:54 -0800
commit18f157cec31ac0bdac88927b20d34fef8dee145b (patch)
tree2338eded2a688e7f3a4ec61ecf96c772d8bcffeb
parent99fd123afb8d8a4f20e79a748a4c77838a9cc01b (diff)
downloadmeta-openembedded-18f157cec31ac0bdac88927b20d34fef8dee145b.tar.gz
python[3]-xstatic-font-awesome: new recipes
Signed-off-by: Bill Randle <bill.randle@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-xstatic-font-awesome.inc17
-rw-r--r--meta-python/recipes-devtools/python/python-xstatic-font-awesome_4.7.0.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-xstatic-font-awesome_4.7.0.0.bb2
3 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-xstatic-font-awesome.inc b/meta-python/recipes-devtools/python/python-xstatic-font-awesome.inc
new file mode 100644
index 000000000..d13cb83f6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-xstatic-font-awesome.inc
@@ -0,0 +1,17 @@
1DESCRIPTION = "Font Awesome icons packaged for setuptools (easy_install) / pip."
2HOMEPAGE = "https://pypi.python.org/pypi/XStatic-Font-Awesome"
3SECTION = "devel/python"
4LICENSE = "Apache-2"
5LIC_FILES_CHKSUM = "file://PKG-INFO;md5=313d021898694cd2b0ea6508bdfe51a2"
6
7PYPI_PACKAGE = "XStatic-Font-Awesome"
8
9inherit pypi
10
11SRC_URI[md5sum] = "141a0e9a7e21e82f922573a00ae0c166"
12SRC_URI[sha256sum] = "e01fb480caaa7c7963dcb3328a4700e631bef6070db0e8b685816d220e685f6c"
13
14DEPENDS += " \
15 ${PYTHON_PN}-xstatic \
16 ${PYTHON_PN}-pip \
17 "
diff --git a/meta-python/recipes-devtools/python/python-xstatic-font-awesome_4.7.0.0.bb b/meta-python/recipes-devtools/python/python-xstatic-font-awesome_4.7.0.0.bb
new file mode 100644
index 000000000..41e85f4a9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-xstatic-font-awesome_4.7.0.0.bb
@@ -0,0 +1,2 @@
1inherit pypi setuptools
2require python-xstatic-font-awesome.inc
diff --git a/meta-python/recipes-devtools/python/python3-xstatic-font-awesome_4.7.0.0.bb b/meta-python/recipes-devtools/python/python3-xstatic-font-awesome_4.7.0.0.bb
new file mode 100644
index 000000000..639f80de9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-xstatic-font-awesome_4.7.0.0.bb
@@ -0,0 +1,2 @@
1inherit pypi setuptools3
2require python-xstatic-font-awesome.inc