summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoy.Li <rongqing.li@windriver.com>2014-10-17 13:24:23 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2014-10-21 14:54:11 -0400
commit15ccbddc6db99689548b518160ad26e1bdc37261 (patch)
treeb680c9dba6279d4e5faed69e2ab4d6b641abc166
parent4851bb16c3ffd3aca4d5846085a9c5c735c6d276 (diff)
downloadmeta-openembedded-15ccbddc6db99689548b518160ad26e1bdc37261.tar.gz
Revert "tftp-hpa: bug fix on empty file put error"
This reverts commit b2eb21a5fbcb065e84ed582e87de21bdc3082f00. It make 3d8520a0b411[tftp-hpa: add error check for disk filled up] unable to work Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
-rw-r--r--meta-networking/recipes-daemons/tftp-hpa/files/tftp-hpa-bug-fix-on-empty-file-put-error.patch33
-rw-r--r--meta-networking/recipes-daemons/tftp-hpa/tftp-hpa_5.2.bb1
2 files changed, 0 insertions, 34 deletions
diff --git a/meta-networking/recipes-daemons/tftp-hpa/files/tftp-hpa-bug-fix-on-empty-file-put-error.patch b/meta-networking/recipes-daemons/tftp-hpa/files/tftp-hpa-bug-fix-on-empty-file-put-error.patch
deleted file mode 100644
index aa29d9ce1..000000000
--- a/meta-networking/recipes-daemons/tftp-hpa/files/tftp-hpa-bug-fix-on-empty-file-put-error.patch
+++ /dev/null
@@ -1,33 +0,0 @@
1tftp-hpa: bug fix on empty file put error
2
3With the feature that checking the disk filled up, the return value of
4function write_behind was checked and used to detect the disk status.
5While for empty file, without data being written, this function will
6return -1 thus the disk filled up error was miss-raised. Fix it.
7
8Upstream-Status: pending
9
10Signed-off-by: Zhang Xiao <xiao.zhang@windriver.com>
11---
12 tftpd/tftpd.c | 4 ++--
13 1 file changed, 2 insertions(+), 2 deletions(-)
14--- a/tftpd/tftpd.c
15+++ b/tftpd/tftpd.c
16@@ -1692,7 +1692,7 @@ static void tftp_recvfile(const struct f
17 syslog(LOG_WARNING, "tftpd: write(ack): %m");
18 goto abort;
19 }
20- if(write_behind(file, pf->f_convert) < 0) {
21+ if(write_behind(file, pf->f_convert) < -1) {
22 nak(ENOSPACE, NULL);
23 (void)fclose(file);
24 goto abort;
25@@ -1727,7 +1727,7 @@ static void tftp_recvfile(const struct f
26 goto abort;
27 }
28 } while (size == segsize);
29- if(write_behind(file, pf->f_convert) < 0) {
30+ if(write_behind(file, pf->f_convert) < -1) {
31 nak(ENOSPACE, NULL);
32 (void)fclose(file);
33 goto abort;
diff --git a/meta-networking/recipes-daemons/tftp-hpa/tftp-hpa_5.2.bb b/meta-networking/recipes-daemons/tftp-hpa/tftp-hpa_5.2.bb
index e58a4b185..19517473f 100644
--- a/meta-networking/recipes-daemons/tftp-hpa/tftp-hpa_5.2.bb
+++ b/meta-networking/recipes-daemons/tftp-hpa/tftp-hpa_5.2.bb
@@ -25,7 +25,6 @@ SRC_URI = "http://kernel.org/pub/software/network/tftp/tftp-hpa/tftp-hpa-${PV}.t
25 file://init \ 25 file://init \
26 file://add-error-check-for-disk-filled-up.patch \ 26 file://add-error-check-for-disk-filled-up.patch \
27 file://tftp-hpa-bug-fix-on-separated-CR-and-LF.patch \ 27 file://tftp-hpa-bug-fix-on-separated-CR-and-LF.patch \
28 file://tftp-hpa-bug-fix-on-empty-file-put-error.patch \
29" 28"
30 29
31SRC_URI[md5sum] = "46c9bd20bbffa62f79c958c7b99aac21" 30SRC_URI[md5sum] = "46c9bd20bbffa62f79c958c7b99aac21"