summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Rini <trini@konsulko.com>2020-02-03 15:08:32 -0500
committerKhem Raj <raj.khem@gmail.com>2020-02-03 22:50:59 -0800
commit14e92f26794fca66b5f7cc7459e2757d9e7bd833 (patch)
treec098d5432bff564cc95b93ab1b0b2364deff76c3
parent5af9b2a3a9011a2dd7f6abab8ee58a92fe28d60a (diff)
downloadmeta-openembedded-14e92f26794fca66b5f7cc7459e2757d9e7bd833.tar.gz
nng: Add recipe
nng is the nanomsg project's rewrite of their libnanomsg library. Just like nanomsg it is a socket library that provides several common communication patterns. Unlike nanomsg it does not normally provide a number of tools and we do not attempt to add them here. We allow for optional mbedtls support. Signed-off-by: Tom Rini <trini@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-connectivity/nanomsg/nng_1.2.5.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/nanomsg/nng_1.2.5.bb b/meta-networking/recipes-connectivity/nanomsg/nng_1.2.5.bb
new file mode 100644
index 000000000..77be27ffa
--- /dev/null
+++ b/meta-networking/recipes-connectivity/nanomsg/nng_1.2.5.bb
@@ -0,0 +1,21 @@
1SUMMARY = "nanomsg-next-generation -- light-weight brokerless messaging"
2DESCRIPTION = "NNG, like its predecessors nanomsg (and to some extent ZeroMQ), is a lightweight, broker-less library, offering a simple API to solve common recurring messaging problems, such as publish/subscribe, RPC-style request/reply, or service discovery."
3HOMEPAGE = "https://github.com/nanomsg/nng"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a19b15be6e844b39a54de2ef665bd6de"
6
7SECTION = "libs/networking"
8
9SRCREV = "53ae1a5ab37fdfc9ad5c236df3eaf4dd63f0fee9"
10
11SRC_URI = "git://github.com/nanomsg/nng.git;branch=v1.2.x"
12
13S = "${WORKDIR}/git"
14
15inherit cmake pkgconfig
16
17EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON"
18
19PACKAGECONFIG ??= ""
20
21PACKAGECONFIG[mbedtls] = "-DNNG_ENABLE_TLS=ON,-DNNG_ENABLE_TLS=OFF,mbedtls"