diff options
author | Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> | 2019-09-25 23:04:36 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-09-25 14:45:20 -0700 |
commit | 13e0f3364e0381f4952e381ca9e4e76e7947463e (patch) | |
tree | 3f5aed8c2c370665929cb0a0fb23b74ba7a48f61 | |
parent | b544304c7cb50d55b28f0083ccfc23cc9fec8bc6 (diff) | |
download | meta-openembedded-13e0f3364e0381f4952e381ca9e4e76e7947463e.tar.gz |
libyui-ncurses: udpate to 2.52.0
Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/recipes-graphics/libyui/libyui-ncurses/0001-Use-override-consistently.patch | 147 | ||||
-rw-r--r-- | meta-oe/recipes-graphics/libyui/libyui-ncurses/0002-Define-own-resize-in-NCPad-and-fix-param-type-of-Set.patch | 49 | ||||
-rw-r--r-- | meta-oe/recipes-graphics/libyui/libyui-ncurses_2.52.0.bb (renamed from meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb) | 5 |
3 files changed, 1 insertions, 200 deletions
diff --git a/meta-oe/recipes-graphics/libyui/libyui-ncurses/0001-Use-override-consistently.patch b/meta-oe/recipes-graphics/libyui/libyui-ncurses/0001-Use-override-consistently.patch deleted file mode 100644 index 6d4bdc2ab6..0000000000 --- a/meta-oe/recipes-graphics/libyui/libyui-ncurses/0001-Use-override-consistently.patch +++ /dev/null | |||
@@ -1,147 +0,0 @@ | |||
1 | From 0acfb67f99fd8d6af323311fee8c08116295b148 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 5 Sep 2018 18:21:19 -0700 | ||
4 | Subject: [PATCH 1/2] Use override consistently | ||
5 | |||
6 | Make clang++ happy | ||
7 | error: 'setApplicationTitle' overrides a member function but is not marked 'override' [-Werror,-Winconsistent-missing-over ride] | ||
8 | |||
9 | Upstream-Status: Submitted [https://github.com/libyui/libyui-ncurses/pull/69] | ||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | src/NCApplication.h | 46 ++++++++++++++++++++++----------------------- | ||
13 | 1 file changed, 23 insertions(+), 23 deletions(-) | ||
14 | |||
15 | diff --git a/src/NCApplication.h b/src/NCApplication.h | ||
16 | index e24c3eb..09e4708 100644 | ||
17 | --- a/src/NCApplication.h | ||
18 | +++ b/src/NCApplication.h | ||
19 | @@ -60,7 +60,7 @@ public: | ||
20 | * Reimplemented from YApplication. | ||
21 | **/ | ||
22 | virtual void setLanguage( const std::string & language, | ||
23 | - const std::string & encoding = std::string() ); | ||
24 | + const std::string & encoding = std::string() ) override; | ||
25 | |||
26 | /** | ||
27 | * Open a directory selection box and prompt the user for an existing | ||
28 | @@ -77,7 +77,7 @@ public: | ||
29 | * Implemented from YApplication. | ||
30 | **/ | ||
31 | virtual std::string askForExistingDirectory( const std::string & startDir, | ||
32 | - const std::string & headline ); | ||
33 | + const std::string & headline ) override; | ||
34 | |||
35 | /** | ||
36 | * Open a file selection box and prompt the user for an existing file. | ||
37 | @@ -97,7 +97,7 @@ public: | ||
38 | **/ | ||
39 | virtual std::string askForExistingFile( const std::string & startWith, | ||
40 | const std::string & filter, | ||
41 | - const std::string & headline ); | ||
42 | + const std::string & headline ) override; | ||
43 | |||
44 | /** | ||
45 | * Open a file selection box and prompt the user for a file to save data | ||
46 | @@ -119,28 +119,28 @@ public: | ||
47 | **/ | ||
48 | virtual std::string askForSaveFileName( const std::string & startWith, | ||
49 | const std::string & filter, | ||
50 | - const std::string & headline ); | ||
51 | + const std::string & headline ) override; | ||
52 | |||
53 | /** | ||
54 | * Beep. | ||
55 | * | ||
56 | * Reimplemented from YApplication. | ||
57 | **/ | ||
58 | - virtual void beep(); | ||
59 | + virtual void beep() override; | ||
60 | |||
61 | /** | ||
62 | * Redraw the screen. | ||
63 | * | ||
64 | * Reimplemented from YApplication. | ||
65 | **/ | ||
66 | - virtual void redrawScreen(); | ||
67 | + virtual void redrawScreen() override; | ||
68 | |||
69 | /** | ||
70 | * Initialize the (text) console keyboard. | ||
71 | * | ||
72 | * Reimplemented from YApplication. | ||
73 | **/ | ||
74 | - virtual void initConsoleKeyboard(); | ||
75 | + virtual void initConsoleKeyboard() override; | ||
76 | |||
77 | /** | ||
78 | * Set the (text) console font according to the current encoding etc. | ||
79 | @@ -152,7 +152,7 @@ public: | ||
80 | const std::string & font, | ||
81 | const std::string & screen_map, | ||
82 | const std::string & unicode_map, | ||
83 | - const std::string & language ); | ||
84 | + const std::string & language ) override; | ||
85 | |||
86 | /** | ||
87 | * Run a shell command (typically an interactive program using NCurses) | ||
88 | @@ -165,7 +165,7 @@ public: | ||
89 | * | ||
90 | * Reimplemented from YApplication. | ||
91 | **/ | ||
92 | - virtual int runInTerminal( const std::string & command ); | ||
93 | + virtual int runInTerminal( const std::string & command ) override; | ||
94 | |||
95 | |||
96 | /// @{ | ||
97 | @@ -183,33 +183,33 @@ public: | ||
98 | // | ||
99 | // All implemented from YApplication. | ||
100 | |||
101 | - virtual int displayWidth(); | ||
102 | - virtual int displayHeight(); | ||
103 | - virtual int displayDepth(); | ||
104 | - virtual long displayColors(); | ||
105 | + virtual int displayWidth() override; | ||
106 | + virtual int displayHeight() override; | ||
107 | + virtual int displayDepth() override; | ||
108 | + virtual long displayColors() override; | ||
109 | |||
110 | - virtual int defaultWidth(); | ||
111 | - virtual int defaultHeight(); | ||
112 | + virtual int defaultWidth() override; | ||
113 | + virtual int defaultHeight() override; | ||
114 | |||
115 | - virtual bool isTextMode() { return true; } | ||
116 | + virtual bool isTextMode() override { return true; } | ||
117 | |||
118 | - virtual bool hasImageSupport() { return false; } | ||
119 | + virtual bool hasImageSupport() override { return false; } | ||
120 | |||
121 | - virtual bool hasIconSupport() { return false; } | ||
122 | + virtual bool hasIconSupport() override { return false; } | ||
123 | |||
124 | - virtual bool hasAnimationSupport() { return false; } | ||
125 | + virtual bool hasAnimationSupport() override { return false; } | ||
126 | |||
127 | - virtual bool hasFullUtf8Support(); | ||
128 | - virtual bool richTextSupportsTable() { return false; } | ||
129 | + virtual bool hasFullUtf8Support() override; | ||
130 | + virtual bool richTextSupportsTable() override { return false; } | ||
131 | |||
132 | - virtual bool leftHandedMouse() { return false; } | ||
133 | + virtual bool leftHandedMouse() override { return false; } | ||
134 | |||
135 | /** | ||
136 | * Set the application title | ||
137 | * | ||
138 | * Reimplemented from YApplication. | ||
139 | **/ | ||
140 | - virtual void setApplicationTitle(const std::string& title); | ||
141 | + virtual void setApplicationTitle(const std::string& title) override; | ||
142 | }; | ||
143 | |||
144 | |||
145 | -- | ||
146 | 2.18.0 | ||
147 | |||
diff --git a/meta-oe/recipes-graphics/libyui/libyui-ncurses/0002-Define-own-resize-in-NCPad-and-fix-param-type-of-Set.patch b/meta-oe/recipes-graphics/libyui/libyui-ncurses/0002-Define-own-resize-in-NCPad-and-fix-param-type-of-Set.patch deleted file mode 100644 index f65cbe6679..0000000000 --- a/meta-oe/recipes-graphics/libyui/libyui-ncurses/0002-Define-own-resize-in-NCPad-and-fix-param-type-of-Set.patch +++ /dev/null | |||
@@ -1,49 +0,0 @@ | |||
1 | From 162a0899f1dacd83007c4e82b9034f55610d8c20 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 5 Sep 2018 19:01:51 -0700 | ||
4 | Subject: [PATCH 2/2] Define own resize in NCPad and fix param type of | ||
5 | SetLabel() | ||
6 | |||
7 | Explicitly override resize() to avoid conflicts from NCursesWindow | ||
8 | definition since there is another resize definition as well | ||
9 | |||
10 | Fixes | ||
11 | src/NCPad.h:164:18: error: 'NCPad::resize' hides overloaded virtual function [-Werror,-Woverloaded-virtual] | ||
12 | |||
13 | NCTablePad.h:132:18: error: 'NCTableTag::SetLabel' hides overloaded virtual function [-Werror,-Woverloaded-virtual] | ||
14 | |||
15 | Upstream-Status: Submitted [https://github.com/libyui/libyui-ncurses/pull/69] | ||
16 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
17 | --- | ||
18 | src/NCPad.h | 1 + | ||
19 | src/NCTablePad.h | 2 +- | ||
20 | 2 files changed, 2 insertions(+), 1 deletion(-) | ||
21 | |||
22 | diff --git a/src/NCPad.h b/src/NCPad.h | ||
23 | index 328c4aa..d8fb324 100644 | ||
24 | --- a/src/NCPad.h | ||
25 | +++ b/src/NCPad.h | ||
26 | @@ -162,6 +162,7 @@ public: | ||
27 | virtual void Destwin( NCursesWindow * dwin ); | ||
28 | |||
29 | virtual void resize( wsze nsze ); | ||
30 | + virtual int resize( int lines, int columns ) { return NCursesWindow::resize(lines, columns );} | ||
31 | virtual void wRecoded(); | ||
32 | virtual void setDirty() { dirty = true; } | ||
33 | |||
34 | diff --git a/src/NCTablePad.h b/src/NCTablePad.h | ||
35 | index c450529..3756796 100644 | ||
36 | --- a/src/NCTablePad.h | ||
37 | +++ b/src/NCTablePad.h | ||
38 | @@ -129,7 +129,7 @@ public: | ||
39 | |||
40 | virtual ~NCTableTag() {} | ||
41 | |||
42 | - virtual void SetLabel( const NCstring & ) { /*NOOP*/; } | ||
43 | + virtual void SetLabel( const NClabel & ) { /*NOOP*/; } | ||
44 | |||
45 | virtual void DrawAt( NCursesWindow & w, const wrect at, | ||
46 | NCTableStyle & tableStyle, | ||
47 | -- | ||
48 | 2.18.0 | ||
49 | |||
diff --git a/meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb b/meta-oe/recipes-graphics/libyui/libyui-ncurses_2.52.0.bb index 18ea2e8285..dae5c342de 100644 --- a/meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb +++ b/meta-oe/recipes-graphics/libyui/libyui-ncurses_2.52.0.bb | |||
@@ -5,15 +5,12 @@ LIC_FILES_CHKSUM = "file://COPYING.lgpl-3;md5=e6a600fd5e1d9cbde2d983680233ad02 \ | |||
5 | " | 5 | " |
6 | 6 | ||
7 | SRC_URI = "git://github.com/libyui/libyui-ncurses.git \ | 7 | SRC_URI = "git://github.com/libyui/libyui-ncurses.git \ |
8 | file://0001-Use-override-consistently.patch \ | ||
9 | file://0002-Define-own-resize-in-NCPad-and-fix-param-type-of-Set.patch \ | ||
10 | file://0003-Simplify-ncurses-finding-module.patch \ | 8 | file://0003-Simplify-ncurses-finding-module.patch \ |
11 | " | 9 | " |
12 | 10 | ||
13 | SRC_URI_append_class-target = " file://0001-Fix-the-error-of-can-t-find-header-file.patch" | 11 | SRC_URI_append_class-target = " file://0001-Fix-the-error-of-can-t-find-header-file.patch" |
14 | 12 | ||
15 | PV = "2.48.3+git${SRCPV}" | 13 | SRCREV = "d5b64b6291b6f292871ad5c6df25c4f6896f7d50" |
16 | SRCREV = "c941b32246e8b2952fce4fd5743f8e318222ab98" | ||
17 | 14 | ||
18 | S = "${WORKDIR}/git" | 15 | S = "${WORKDIR}/git" |
19 | 16 | ||